IBM Support

"The underlying connection was closed: An unexpected error occurred on a send" error when using 32-bit Excel 2016 (not affecting 64-bit) when using TLS 1.2

Troubleshooting


Problem

User launches Excel. User clicks the Controller add-in and tries to login. An error appears.

Symptom

image-20190625112921-1
The underlying connection was closed: An unexpected error occurred on a send

Cause

There are several known causes for "The underlying connection was closed: An unexpected error occurred on a receive" errors.
  • TIP: See separate IBM Technote #0741571 for more examples.
This Technote specifically relates to the scenario where both of the following are true:
  • The problem only affects Excel (the 'main' Controller client works OK)
  • It only affects client devices which have 32-bit versions of Excel installed (not 64-bit Excel versions).
In this scenario, the cause is that the client device does not contain the required 32-bit registry key to force the use of TLS 1.2 for .NET

Environment

All of the following are true:
  • The customer has restricted network access to only using TLS 1.2
  • 32-bit version of Excel installed
  • The client device (for example the Windows 10 laptop) does not have the relevant 32-bit ("Wow6432Node") registry key to force TLS 1.2 for (32-bit) .NET applications.

Resolving The Problem

Fix:
Add the 32-bit registry key (in other words, inside "\Wow6432Node"), to force 32-bit .NET applications to use TLS 1.2.
  
Steps:
1. Logon to the 'bad' client device (as a Windows administrator)
2. Open the registry editor, by clicking on ‘Start’ menu and typing:    REGEDIT
3. Navigate to the following path: [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
4. Right-click on v4.0.30319 and select New –> DWORD (32-bit)
  • Set the name to: SchUseStrongCrypto
  • Set the value to 00000001
      
Workaround:
On the client device:
  • Uninstall 32-bit Excel
  • Install 64-bit Excel.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
25 June 2019

UID

ibm10956557