IBM Support

Unable to view ClearCase Context Menu from Windows Explorer

Troubleshooting


Problem

This technote explains why attempts to use IBM® Rational® ClearCase® from Microsoft® Windows® Explorer results in no available ClearCase context menus.

Cause

Note: This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article 256986.

Look to see if the following option is enabled in the ClearCase Control Panel (Start > Run type cc.cpl) on the Options tab under the section titled Connected to ClearCase Network (enable ClearCase integrations).




If the option is enabled, your account may not have adequate permissions to modify the Windows Registry.

The following registry key controls the visibility of the ClearCase context menus from Windows Explorer:


HKEY_CURRENT_USER\Software\Atria\ClearCase\CurrentVersion

Key:  Connected

Diagnosing The Problem

Verify that the above registry key exists:

  1. Run regedit
  2. Navigate to: HKEY_CURRENT_USER\Software\Atria\ClearCase\CurrentVersion
  3. In the right window panel of the display verify that the Key Connected exists and is set to a value of 1


Resolving The Problem

If the option above is not checked, enable the option and see if the ClearCase context menus appear from Windows Explorer.

If the option is enabled and the menus do not appear, you do not have the required permissions to modify the system registry.

Resolve the permission issue with your Windows administrator. Once resolved, the registry will update the key correctly from the ClearCase control panel (ClearCase Properties).

If the Connected key does not exist in the Windows registry for HKEY_CURRENT_USER\Software\Atria\ClearCase\CurrentVersion then create it:

  1. Right click in the right window panel
  2. Select new
  3. Select DWORD value
  4. Enter a value name of Connected, setting the value data to 1 and the base to hexadecimal

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: Windows Explorer (Integration)","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: Windows Explorer (Integration)","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21248362