IBM Support

Unable to transfer out inTM1 Performance Modeler: java.lang.OutOfMemoryError

Troubleshooting


Problem

When using TM1 Performance Modeler to transfer a model from one TM1 instance to another, the following error can sometimes be thrown: Transfer has failed due to the following error(s): ERROR The transfer failed. java.lang.OutOfMemoryError OutOfMemoryError

Symptom

Cause

TM1 Performance Modeler does not have enough memory allocated to transfer the model.

Resolving The Problem

For increasing the Memory used by Performance Modeler, the customer can try increasing the Max Memory for Perf Modeller here:

C\Users\<USERNAME>\AppData\Roaming\IBM\Cognos Performance Modeler\bins\bin_10.1.XXXX.X

Open the ModelingMDT.ini file with Notepad, and edit the XMX setting:

-Xmx512M

One can try increasing it in stages, from say 512, to 1024, then eventually up to 1792 as a maximum given the process is only 32-bit; 2GB is its maximum available memory.

Ensure that the ModelingMDT.exe process is not running, or the process is ended after adjusting the XMX setting.

To confirm that the setting took place, you can run Process Explorer on the client machine, and locate the modelingMDT.exe process, right-click this and select properties.  On the Image tab, you will see a "Command Line" field, if you copy that Command Line out to a notepad, you will see the XMX setting that you defined in the INI, if the setting is not the same, then you may need to ensure you are updating the right modelingMdt.ini file.

It may be necessary to try the Transfer out a few times, possibly, at different levels of max memory defined. Given one doesn't know ultimately how much RAM will be required to transfer a given model, it's best to start with increments of 256MB or so, from 512, to 768, to 1024, and so on.  Do not go over 1.5 GB or 1.75 GB as this leaves little space for the 32 bit process itself.

Note: Also check the tm1server.log for any errors that may affect memory use on the server. One customer was having a problem with "stack overflow" errors due to some problematic rules/feeders. This caused excess memory to be used (and not returned to the OS) which then appeared to lead to the above error when trying to transfer objects. Rebooting the server machine and then moving the objects, (prior to running any processes that trigger the stack overflow), was a workaround to the problem. However the problem rules should be addressed or the issue will likely recur.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Performance Modeler","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21600719