Troubleshooting
Problem
Service starts then stops without giving a clear indication why it stops.
Symptom
Start the Tivoli Storage Manager server as a service on Windows. The service starts then stops immediately with an error:
The TSM <Server instance> service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.
For example,

Starting the server in the foreground works fine.
Cause
There are several possible causes for this problem. This technote addresses one particular solution due to a corrupted installation that causes missing registry keys.
Diagnosing The Problem
Review the registry key HKLM\SOFTWARE\IBM\ADSM\CurrentVersion\Server.
The following key values must exist:
Path
ProductCode
PTFLevel
For example,
Resolving The Problem
First, use the native installer to fix the installation:
1) Halt TSM Server
2) Open Programs and Features in Windows Control Panel
3) Right Click on IBM Tivoli Storage manager Server (must be server) and select repair
4) Allow Repair to complete.
5) Try to start the service again. If the problem persists, go to the next step to modify the registry.
6) If the native installer does not fix the problem and if one or more key values mentioned above is missing, add it to the registry. For example,
Adding the Path:
reg add HKLM\SOFTWARE\IBM\ADSM\CurrentVersion\Server /v Path /d "C:\Program Files\Tivoli\TSM\Server" /f
Adding the PTFLevel:
reg add HKLM\SOFTWARE\IBM\ADSM\CurrentVersion\Server /v PTFLevel /d "6.3.4.000" /f
Important Notes:
1. Changing the registry can damage the system. Ensure you export a a copy of the registry to be used in the event there is a problem with the update.
2. Adjust the commands to use the correct values for a particular server. If you are uncertain of what values to add, consult a level 2 engineer or development.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21663831