IBM Support

Unable to Renew Local Server Certificate - "The validity period of the certificate does not include the current date"

Troubleshooting


Problem

When creating a self-signed certificate in Digital Certificate Manager for i (DCM), the following error is thrown:
"The validity period of the certificate does not include the current date or does not fall within the validity period of the issuing Certificate Authority (CA) certificate.  The certificate is not yet valid or is no longer valid.  Ensure the date, time, offset from GMT, and daylight savings time (if applicable) are set correctly on your system"

Cause

The reason this happens is because the Local CA is expired and needs to be renewed.

Resolving The Problem

To resolve this issue the Local CA certificate will need to be renewed.  See the following URL for instructions on how to renew a Local CA certificate:
Once the Local CA certificate is renewed, a Local server certificate can be created using the following instructions:

Related Information

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CISAA2","label":"Digital Certificate Manager"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.3.0;7.4.0;7.5.0"}]

Document Information

Modified date:
21 December 2022

UID

ibm16850825