IBM Support

Unable to perform operation due to timeout

Troubleshooting


Problem

In IBM Rational Rose RealTime, you are unable to perform an operation due to a timeout.

Symptom

When performing a Configuration Management operation you see the following error:

Error performing operation - timeout occurred.

Cause

Some configuration management source control operations may take longer than the prescribed number of seconds to perform. If the operation is against a large number of files and or the operation involves slow network communication, timeouts of the operation may occur causing the operation not to complete
successfully.

Virus protection software may cause some of the delays. Review 1125917: Poor performance adding or loading a Rose RealTime model in source control for more details on how to reduce delays caused by Virus protection software.

Resolving The Problem

ScriptTimeout can be increased in the cm_getcaps version control interface script.

$ROSERT_HOME/bin//cmscripts//cm_getcaps

Note: See online documentation under Team Development > Customizing Source Control Interface Scripts > Script Parameters > cm_getcaps.

The online documentation specifies an integer without identifying what unit of time the value of the integer refers to. This integer refers to the number of seconds to wait for a script response.

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Document Information

Modified date:
16 June 2018

UID

swg21119589