IBM Support

Unable to install Entity Anaytics Server v16 on Windows Server 2008 R2

Troubleshooting


Problem

Installation of Entity Analytics Server v16 on Windows Server 2008 R2 appears to go on an infinite loop. Installer never ends and when manually interrupted, install rolls back and EA Server is not installed correctly.

Symptom

Install of EA Server v16 does not finish. Appears to go on an infinite loop during install of DB2.
This only occurs when option to install DB2 as the EA repository is selected.

Cause

This is a problem with the Microsoft Installer Coordinator when a chained installation (an installer starts another install) is started. This is documented here: http://support.microsoft.com/kb/2655192

In this example, the first installer is EA Server 16. During the install, it starts the second installer, DB2. This is where the hanging/infinite looping behaviour occurs.

Environment

This behaviour was observed on a Windows Server 2008 R2 environment.

Diagnosing The Problem

* Run the EA Server installer from the command prompt as an Administrator and enter the following command:
server64.exe /v"/l*v C:\Temp\EAinstall.log"
- Ensure that "C:\Temp" folder exists and end-user has read/write permissions on it
* A failed install will have the following messages in the 'EAinstall.log':
=========================================================
MSI (c) (C0:80) [05:51:50:986]: Note: 1: 1708
MSI (c) (C0:80) [05:51:50:986]: Product: IBM SPSS Entity Analytics for IBM SPSS Modeler Server 16.0 -- Installation operation failed.

MSI (c) (C0:80) [05:51:50:986]: Windows Installer installed the product. Product Name: IBM SPSS Entity Analytics for IBM SPSS Modeler Server 16.0. Product Version: 16.0. Product Language: 1033. Manufacturer: IBM. Installation success or error status: 1603.

MSI (c) (C0:80) [05:51:51:002]: Grabbed execution mutex.
MSI (c) (C0:80) [05:51:51:002]: Cleaning up uninstalled install packages, if any exist
MSI (c) (C0:80) [05:51:51:002]: MainEngineThread is returning 1603
=== Verbose logging stopped: 1/20/2014 5:51:51 ===
=========================================================

* The User Interface will also show the following dialog window:
Windows Installer Coordinator
"Please wait while the application is preparing for the first use"

Resolving The Problem

According to the MS KB article, the following can be used as a workaround:
The RDSH (Remote Desktop Session Host) setting can be changed using the following
* HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Terminal Services\TSAppSrv\TSMSI\Enable.
* Local Computer Policy (MMC + Group Policy ObjectEditor)\Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Application Compatibility – Turn off Windows Installer RDS Compatibility
* This might require changes in group policies by a domain administrator.

Once this policy change has been made, re-install EA Server by following the steps below. This is to ensure a clean environment is made for the DB2 instance:
1. Reboot the server machine.
2. Open the Services Applet of Window to check for any DB2 services. If the DB2 Services does not exist and is not active, move to the next Step. If DB2 Services are present and active, please stop it.
Note that DB2 Services will start with DB2, such as:
- DB2 - DB2COPY1,
- DB2 GOVERNOR (DB2COPY1),
- DB2 License Server etc
3. Open "Control Panel > Programs and Features" to check is there are any DB2 installations present.? If exist, please uninstall it. Also uninstall any Entity Analytics entries if present.
4. Open "regedit" to remove some DB2 keys, If exist, please remove them:
HKEY_LOCAL_MACHINE--SOFTWARE--IBM--DB2
HKEY_CURRENT_USER--Software--IBM--DB2
5. Reboot machine
6. Reinstall Entity Analytics with verbose logging enabled, eg:
server64.exe /v"/l*v C:\EAinstall.log".

Leave the installer plenty of time to complete- check task manager to see if DB2 and msiexec processes are running during the time that the installer progress bar appears to freeze for some time.

Installation should now complete without further issues.

[{"Product":{"code":"SS3RA7","label":"IBM SPSS Modeler"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Entity Analytics","Platform":[{"code":"PF033","label":"Windows"}],"Version":"16.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21663188