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Unable to delete content in Filenet Content Manager

Troubleshooting


Problem

User recieving an error when deleting content: Error message: CONTENT_FXCA_OPERATION_FAILED_CONTENT_IS_MIGRATING: Operation [delete] cannot be performed while content is being migrated to Fixed Content Device

Cause

The content_referral_blob is incomplete or in transient state with no content assigned.

Resolving The Problem

1. Find the content_referral_blob with incomplete or transient state by running the query.

select object_id, content_referral_blob, datalength(content_referral_blob)as LenghtOfRefferalBlob FROM [OS0004].[dbo].[DocVersion] where object_id = '{guid}';

The length returned should be computed as 1.

2. Use the length to locate the other documents with the migration status:

select object_id, u1708_documenttitle FROM [OS0004].[dbo].[DocVersion] where datalength(content_referral_blob) = 1;

3. To remove such documents, you will need to perform a direct SQL against CE database to reset the content_referral_blob back to null. A SQL similar to:

Update docversion set content_referral_blob = null where object_id = ‘<document id>’;

Once the content_referral_blob has been reset to null, user can can delete/remove the document through the usual means through ACCE or Content Navigator.

4. Add the content or document in question if you still have a copy as new to Filenet Content Manager.

[{"Product":{"code":"SSNW2F","label":"FileNet P8 Platform"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.1;5.2;5.2.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 March 2024

UID

swg21978744