IBM Support

Unable to create or edit desktop after upgrade to ICN 3.0.2

Troubleshooting


Problem

Following an upgrade from IBM Content Navigator (ICN) v2.0.3 to v3.0.2 no desktop can be edited or created, or a desktop setting could be changed but after saving and rechecking, the changes revert back to oringal values.

Symptom

No error occurs - the action just does nothing. In addition, the ICN ping page still displays the old version of ICN, despite the upgrade being successful.

Cause

Residual files are left in the /{root dir}/configure/explodedformat/navigator/web-inf/classes folder and not removed during the initial upgrade attempt.

Environment

ICN v3.0.2

Diagnosing The Problem

Check the installation logs for v3.0.2 to ensure that the upgrade was actually successful.

Check the ICN ping page to see if it displays the correct ICN version.

Resolving The Problem

Perform the following steps:

1) Backup and then delete the following from the web-inf/classes folder:
/com
/netscape
/org
wcversion.properties

2) Once the directories are removed, un-deploy Content Navigator and clear the Websphere cache.

3) Then run the following ICN Configuration and Deployment steps again:

- Configure the IBM Content Navigator Web Application
- Build the Web Application
- Deploy the Web Application

[{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"}],"Version":"3.0.2","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}}]

Document Information

Modified date:
17 June 2018

UID

swg22011170