IBM Support

Unable to create Crystal Reports Engine error, after upgrading Crystal Reports version

Troubleshooting


Problem

This technote discusses not being able to edit report formats in IBM® Rational® ClearQuest®. This can occur after uninstalling Crystal Reports Developer Edition (DE) 8.5 and installing a later version Crystal Reports.

Symptom

Attempting to edit a report format results in one of these errors:


Unable to create Crystal Reports Engine for report format version 10.0.

OR



Problems executing Report

Couldn't display Crystal Reports viewer (crviewer9.dll)
Contact your ClearQuest administrator to verify that crviewer9.dll is registered

This error message is not limited to the versions referenced in these examples. It might have a different version depending on the current version of Crystal Reports installed on the computer.

Cause

Two DLL files from the prior installation of Crystal Reports DE 8.5 need to be manually removed and updated.

Resolving The Problem



Installing Crystal Reports after uninstalling Developer Edition version 8.5

To uninstall the .dll files:

  1. Close the ClearQuest Windows client if it is running.

  2. From a command prompt run the following commands:

    regsvr32 "C:\Windows\system32\craxdrt.dll" /u
    regsvr32 "C:\Windows\system32\cpeaut32.dll" /u

Installing Crystal Reports 10
  1. Register the new craxdrt.dll file. Search for the craxdrt.dll file from the Common Files folder. For example, with Crystal Reports 10, you might find the file in C:\Program Files\Common Files\Crystal Decisions\2.5\bin)

  2. From a command prompt run the following command:

    regsvr32 "C:\Program Files\Common Files\Crystal Decisions\2.5\bin\craxdrt.dll"

For 2003 versions, this information can be found in the ClearQuest Documentation Supplement in the cq_supplement.pdf file found in the C:\Program Files\Rational\ClearQuest\doc\books directory.


ClearQuest 7 and Crystal Reports XI
This issue is also known to occur with Crystal Reports XI and ClearQuest 7. The steps to register the new craxdrt.dll file vary slightly from previous versions of Crystal Reports:
  1. Search for the craxdrt.dll file from the version XI folder (for example, C:\Program Files\Common Files\Business Objects\3.0\bin).

  2. From a command prompt run the following command:

    regsvr32
    "C:\Program Files\Common Files\Business Objects\3.0\bin\craxdrt.dll"


  3. If that does not resolve the error, then register the following dll file:

    regsvr32 "C:\Program Files\Common Files\Business
    Objects\3.0\crystalreportviewers11
    \ActiveXControls\CRViewer.dll"


REGISTRY EDITS:

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986


[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Reporting","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21216788