IBM Support

Unable to connect to Teradata database using Teradata Connector in IBM Information Analyzer

Troubleshooting


Problem

Unable to connect to Teradata database using Teradata Connector in IBM Information Analyzer

Symptom

Error message:
Unable to describe database due to one of the following reasons: either the database configuration is invalid or possible source database connection issues, Verify your source database configuration and connection.

Information Analyzer logs are not being generated. Similarly, Websphere Application Server logs (SystemOut.log & SystemErr.log) are not updated.

Connector (CAS) logs contain:
ISF-CAS-NATIVE 350001 2014-06-12 17:07:44,581 Fatal Fatal error message received from the native (C++) layer:
CC_TeraConnection::getDefaultDatabase, file CC_TeraConnection.cpp, line 1655
ISF-CAS-HANDLER 100010 2014-06-12 17:07:44,581 Trace A response of type
com.ascential.asb.cas.shared.ConnectorServiceException: Query returned 0 row(s). SQL statement: LOCK ROW FOR ACCESS SELECT TRIM(DefaultDataBase)
FROM DBC.Users WHERE UserName = '' (NOT CASESPECIFIC)
at com.ascential.asb.cas.handler.Worker.processGetMetadataRequest(Worker.java:470)
at com.ascential.asb.cas.handler.Worker.run(Worker.java:205)
was placed in the response box by the worker thread
ISF-CAS-SERVER 050038 2014-06-12 17:07:44,589 Fatal An exception was received from the handler: Query returned 0 row(s). SQL statement: LOCK ROW FOR ACCESS SELECT TRIM(DefaultDataBase) FROM DBC.Users WHERE UserName = '' (NOT CASESPECIFIC)

Cause

This issue is caused by usage of the environment variable DS_NO_PROCESS_METADATA

Environment

Attempting to set up Teradata connection in using Teradata Connector. Installed Teradata client 14.0 on Information Analyzer Engine Server. The dsenv is configured with all appropriate variables.
Confirmed both ODBC and JDBC Connectors to Teradata database are working fine. Confirmed Server name, user & password are correct.

Resolving The Problem

Unset the environment variable DS_NO_PROCESS_METADATA by setting to 0 or removing it altogether, then restart the ASBAgent.

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Document Information

More support for:
InfoSphere Information Analyzer

Software version:
9.1, 8.7, 8.5, 8.1, 11.3

Operating system(s):
AIX, HP-UX, Linux, Windows

Document number:
253741

Modified date:
16 June 2018

UID

swg21687115

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