IBM Support

Unable to connect to the IBM i2 iBase security database after security file (.ids) is upsized to SQL Server

Troubleshooting


Problem

Client desktop installs of i2 iBase user cannot login to iBase security database after the security file is upsized to SQL Server. Server side installs of iBase user can login.

Symptom

"Failed to connect to the security database. Please contact your system administrator."

Cause

Not determined conclusively, but seems to be one or more of:

  • machine alias varying between server and client
  • network configuration variances in SQL Server
  • subtle file permission variances (the same user executed the failed test and the resolution, but the issue may be a subtle problem)

Environment

iBase server: Windows Server 2012
iBase client machine: Windows 7. iBase 8.9.11. SQL Server 2014 with SSL configured and force encryption enabled.

Diagnosing The Problem

Perform the following steps to diagnose:

      1. On the iBase server, create the folder to store the database connection (.idb) and security (.ids) files.
      2. On the iBase server, Share the folder to your test login. Grant full security and share access permissions.
      3. On the iBase server, inside Designer, create a new security file in that folder. Use the shared path to the folder, not the local one.
      4. On the iBase server, inside Designer, create the iBase database from a template, as an Access database. Now there is an Access security database and an Access database schema.
      5. On the client desktop, test login from iBase user to Access security/Access data database. Successful.
      6. On the iBase server, Upsize the Database to SQL Server (leave the security database in Access.) <If client is using a port besides 1433, specify ",###" i.e. "myserver,2431".
      7. On the client desktop, test login from iBase user to Access security (.ids) / SQL Server database (.idb). Successful.
      8. On the iBase server, Upsize security database (.ids), deselecting Windows Auth.
      9. On the client desktop, attempt to login from iBase User to the iBase security file (.ids). This fails even if you turn off force encryption on all protocols on all configurations, whether or not a server port is specified in the connection string.
      10. On the iBase server, attempt to login to the iBase security file (.ids) and the SQL Server database (.idb). Successful.
Additional Note: This problem has not been observed anywhere else by the engineer who recorded it, so it may be an edge case, but is documented in case others run into it.

Resolving The Problem


Resolving the Problem (ALL executed on the client machine):

  1. Install iBase Designer on the client machine if not already present.
  2. Create a NEW security file. Use the shared path to the file, not a direct reference like \\machine\c$. Close iBase Designer.
  3. Verify the user can access the NEW security file from iBase User. Close iBase User.
  4. Open iBase Designer and upgrade the Security file to SQL Server. Close iBase Designer.
  5. Verify the user can access the NEW upgraded security file from iBase User. Close iBase User.
  6. Open iBase Designer. Add a new Access database to the security file you created in Step 2 using a template of your previous iBase database. Close iBase Designer.
  7. Open iBase User. Verify that the user can access the new iBase database.
  8. Open iBase Designer. Upsize your database to SQL Server. Close iBase Designer.
  9. Open iBase User. Verify that the user can access the new iBase database.
  10. If a pre-existing iBase database exists with critical data, create import specs to load data from the old iBase database to the new one.
Note: The fix above is executed in a series of steps with tests in between, (i.e. create the Access security file and test and then upsize it and then test) to try and identify any other issues that may be causing problems, such as share folder limitations or networking.
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Document Information

More support for:
i2 iBase

Software version:
8.9.11, 8.9.11.1, 8.9.11.2

Operating system(s):
Windows

Document number:
297835

Modified date:
16 June 2018

UID

swg22009354