IBM Support

Unable to connect to CLM Server with RTC Eclipse client using Smard Card

Troubleshooting


Problem

Unable to authenticate with Smart Card when connecting to the IBM Rational Collaborative Lifecycle Management (CLM) server using the IBM Rational Rational Team Concert (RTC) Eclipse client.

Symptom

You are able to authenticate with Smart Card when connecting to the CLM server using the web client but fail when connecting with the RTC Eclipse client.

Cause

 The Java SDK that comes with the RTC Eclipse client does not support Smart Card.

Resolving The Problem


In order to connect with a Smart Card in the RTC eclipse client, the Java SDK that comes with the Eclipse client must be updated to IBM 1.6 SR12 for Smart Card support.  This issue is being tracked in defect 250856.



Leverage the Jazz Community

Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

[{"Product":{"code":"SSUC3U","label":"IBM Engineering Workflow Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Eclipse","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"3.0.1;3.0.1.1;3.0.1.2;3.0.1.3;3.0.1.4;3.0.1.5;4.0;4.0.0.1;4.0.0.2;4.0.1;4.0.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Product Synonym

Rational Team Concert

Document Information

Modified date:
16 June 2018

UID

swg21633703