Troubleshooting
Problem
"db2 backup database on all dbpartitionnums use tsm" command fails due to SQL2033N with TSM reason code 41.
Symptom
When the user runs db2 backup database command with "all dbpartitionnums" and "use tsm" option, the db2 backup database command fails with TSM reason code 41, as below:
>>>>>
$ db2 backup db DB01 on all dbpartitionnums online use tsm
Part Result
---- ------------------------------------------------------------------------
0000 SQL2033N An error occurred while accessing TSM during the processing of a database utility. TSM reason code: 41
0001 SQL2033N An error occurred while accessing TSM during the processing of a database utility. TSM reason code: 41
...
<<<<<
Cause
When "all dbpartitionnums" option is specified in the db2 backup database command, DB2 client tries to make a lot of sessions between Tivoli Storage Manager Client and Tivoli Storage Manager Server.
Therefore, the number of sessions exceeds the maximum number of mount points.
As result, the db2 backup database command fails due to SQL2033N with TSM reason code 41.
Therefore, the number of sessions exceeds the maximum number of mount points.
As result, the db2 backup database command fails due to SQL2033N with TSM reason code 41.
Environment
Tivoli Storage Manager is configured for DB2 BACKUP DATABASE command. ( ref: http://www-01.ibm.com/support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.admin.ha.doc/doc/c0024705.html
Diagnosing The Problem
Look into the Tivoli Storage Manager ACTLOG. You can see ANR0539W message at the time that TSM reason code 41 occurs, as below:
>>>>>
yyyy.mm.dd hh:mm:ss ANR0539W Transaction failed for session nnnn for node NODE0001. This node has exceeded its maximum number of mount points. (SESSION: nnnn)
<<<<<
Resolving The Problem
Increase the maximum number of mount points allowed on the Spectrum Protect (TSM) server to accommodate the total number of backup sessions.
To do so, update the value of MAXNUMMP (Maximum Mount Points Allowed) on the Node definition of the Spectrum Protect server by running the following command:
UPDate NOde {nodename} MAXNUMMP={value}
For more information on how to update the node, see the UPDATE NODE (Update node attributes) topic in the IBM Storage Protect Docs site.
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
Historical Number
29276
Was this topic helpful?
Document Information
Modified date:
11 July 2024
UID
swg21964097