Troubleshooting
Problem
The TSM backup/archive client is installed on the same system as McAfee VirusScan Enterprise 7.1.0 and TSM performance is impacted.
Cause
Anti-virus products and backup/restore products can use significant amounts of system resources and therefore impact application and file system performance. They may also interact with each other to seriously degrade the performance of either product.
Resolving The Problem
The following recommendations are therefore made to allow optimal performance of TSM backup and restore:
1. Schedule anti-virus file system scans and TSM incremental backups for non-overlapping times.
2. Change the McAfee VirusScan Enterprise On-access Scan properties so that files are not scanned when opened by the TSM client processes.
The steps required to complete the second recommendation are as follows:
1. Open the On-Access Scan Properties dialog box. On the Default Processes settings page, Processes tab, click Use different settings for high-risk and low-risk processes.
2. On the Low-risk Processes settings page, Processes tab, click Add, and then Browse, and then locate each of the following TSM client process executables (dsm.exe, dsmc.exe, dsmcad.exe, dsmcsvc.exe, and tsmjbbd.exe) in the TSM install directory, and add them to the list. of low-risk processes.
3. On the Low-risk Processes settings page, Detection tab, uncheck the When writing to disk and When reading from disk boxes.
Refer to the attached files for pictures of these dialog boxes.
Note: There is no negative impact on the TSM journal service caused by a full file system scan by this anti-virus product, when the TSM journal service is using the default notify filter value, NotifyFilter=0x00000117.
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Document Information
Modified date:
17 June 2018
UID
swg21165972