IBM Support

Trying to save a new artifact reports error "An error has occurred while processing a server request. The server returned this error code: >ID CRRRW7553E; A message that was received from the server indicates an error with no specific handler."

Troubleshooting


Problem

When trying to save a new artifact using IBM Rational Requirements Composer (RRC), an error is returned "An error has occurred while processing a server request. The server returned this error code: >ID CRRRW7553E; A message that was received from the server indicates an error with no specific handler".

Symptom

Existing artifacts can be saved without problems.

Cause

This issue can happen in an IBM Rational Collaborative Lifecycle Management (CLM) distributed environment after a restart of the servers and if the Rational Requirements Composer (RRC) server is started up before the Jazz Team Server (JTS) server is up and running.

Diagnosing The Problem

Errors similar to this are visible in the logs when this happens:

The full error message is as follows:

2013-01-01 10:10:10,800 [  RM-Change Event Listener-175] ERROR om.ibm.rdm.fronting.server.services.uid.UIDService  - Could not write UID (XXXXX) after max number of retries (10)
com.ibm.rdm.fronting.server.exception.ForbiddenException: com.ibm.rdm.fronting.server.exception.ForbiddenException
at com.ibm.rdm.fronting.server.exception.RRSException.newException(RRSException.java:170)
[...]
Request
PUT
 https://CLMserver:/jts/storage/com.ibm.rdm.uid/com.ibm.rdm.trs.changeLogs_tps://CLMserver:/jts/storage/com.ibm.rdm.uid/com.ibm.rdm.trs.changeLog

HTTP/1.1
If-Match: "_xXXxxxXXXxXXXxxxXXxXXXX"
Content-Type: text/plain
Authorization: OAuth oauth_token_secret="", oauth_nonce="-XXXXXXXXXXXXXXXXXXXX", oauth_token="", oauth_consumer_key="XXXXXXXXXXXXXXXXXXXXX", oauth_signature_method="HMAC-SHA1", oauth_timestamp="XXXXXXXXXX", oauth_version="1.0", oauth_signature="7XXXXXXXXXXXXXXXXXXXXXXXXXX"
--Start entity---

--End entity-----
Response:
HTTP/1.1 403
Date: Thu, 02 May 2013 10:09:34 GMT
Server: IBM_HTTP_Server
X-HP-CAM-COLOR: V=1;ServerAddr=XXXXXXXXXXXXXXXXXXQ==;GUID=XXXXXXXXXXXXXXXXXXXXXXX.
$WSEP:
Keep-Alive: timeout=10, max=96
Connection: Keep-Alive
Content-Type: text/html;charset=UTF-8
Content-Language: en-US
Content-Length: 284
---Start entity---
Error 403: CRJAZ1848E To do the "com.ibm.team.jfs.write" operation, you must have one of the following licenses that are installed on the server: Contributor-Floating, Developer-Floating, Analyst-Floating, Contributor-Floating. The server administrator can assign licenses.

 

Resolving The Problem

To avoid this issue, when restarting the servers follow this sequence:

  1. Stop the RRC server
  2. Stop the JTS server
  3. Start the JTS server
  4. When JTS has completely started, start the RRC Server


As a way to make sure everything is up, monitor the index page until the indexing is complete by going to https://server:port/jts/indexing. This will bring up an XML page. In this page there are some
"<jazz:backlog>" tags showing whether there is an indexing backlog or not.
Re-indexing is complete once the backlog #'s reach 0


Leverage the Jazz Community

The Jazz based products have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.

Review technote 1319600: Leveraging the Jazz Community on Jazz.net for details.


[{"Product":{"code":"SSWMEQ","label":"Rational Requirements Composer"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"4.0;4.0.0.1;4.0.0.2;4.0.1;4.0.2;4.0.3;4.0.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

More support for:
Rational Requirements Composer

Software version:
4.0, 4.0.0.1, 4.0.0.2, 4.0.1, 4.0.2, 4.0.3, 4.0.4

Operating system(s):
Windows, Linux

Document number:
234707

Modified date:
16 June 2018

UID

swg21650557