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** Troubleshooting ** Very slow performance to launch client - takes many minutes to launch Controller

Troubleshooting


Problem

Extremely poor performance when using Controller client. Launching the client and/or clicking on menu items takes a very long time.

Symptom

For example:

  • User launches Controller from icon/URL. It takes a long time (for example 3 minutes) to logon to Controller
  • Once inside Controller, it takes many minutes to do certain simple tasks
    • For example, it may take 10 minutes to launch the Excel link.

Cause

There are many potential causes for poor performance with Controller.

  • This Technote shall deal with the scenario where the symptoms appear to affect almost all functionality, but is especially noticeable in the long time taken to launch the Controller client.

In this scenario, there are many different potential causes. Some of the most common include:
  • Scenario #1 - Slow network performance between APP and Database server
    • See separate IBM Technote #1382321
  • Scenario #2 - .NET Certificate security checking
    • See separate IBM Technote #1347312
  • Scenario #3 - Poor network connectivity between the Controller application server (or gateway server) and the client PC.
    • All communications between the client PC and the Controller application server(s) is via web protocol to/from the Microsoft IIS web server (which by default means HTTP over TCP port 80)
    • Therefore, it is VITAL for performance that the network channel between the client PC and the application server/gateway is quick
  • Scenario #4 - Cognos CAM namespace configured to use a read only AD domain controller (RODC)
    • See separate IBM Technote #1696789
  • Scenario #5 - Aggressive anti-virus product on client device
    • See separate IBM Technotes #1367435 & 2004655
  • Scenario #6 - Client device configured to auto-detect proxy server
    • See separate IBM Technote #1366681
  • Scenario #7 - Cognos CAM namespace configured to use a remote (across slow network) active directory domain controller
    • See separate IBM Technote #2012694

Environment

Scenario #3
There are many potential networking environments which could cause this problem.

  • For example, one environment that has been seen is if the customer places their Controller application/gateway server inside their DMZ, and there is a poorly-configured network connection between the DMZ and the user's network (e.g. LAN / WAN).
    • For example, there may be an aggressively/poorly configured firewall between the DMZ and the user's network (e.g. LAN / WAN).
    • This will cause each of the HTTP/TCP network packets to be slowed down considerably as they pass between the Controller application server and the user's client PC network.
  • In another example, the slow/delays can be caused by a firewall between the client device and the server(s)
    • See separate IBM Technote #1591686 for an example of this.

Diagnosing The Problem

For example, as a test, try moving the Controller application server to the same network (e.g. LAN) as the client PCs (rather than locating servers inside a DMZ)

Resolving The Problem

Scenario #1 (Slow network performance between APP and Database server)
See separate IBM Technote #1382321

Scenario #2 (.NET Certificate security checking)
See separate IBM Technote #1347312


Scenario #3 (slow network between client and server)

Ask your I.T. department's network expert to reconfigure the network (routers/firewalls etc) to reduce the network bottleneck between the Controller server(s) and client(s). For example:

  • Between the server and client, ensure that:
    • the bandwidth is high (for example >256 or 512 kbps per active standard user)
    • and the network round-trip latency is low (for example 80 ms or less)
  • If there is a firewall between the client device and the server(s), try disabling/reconfiguring the firewall
    • See separate IBM Technote #1591686 for an example of this.

Workaround:
Until the quality of the network link between the client PC and the server can be improved, it may be possible to squeeze some extra performance gains by compressing the network traffic between the client and the server. For more information, see separate IBM Technote #1347307.

Scenario #4 (Controller application server configured to use a read only AD domain controller)
Modify the domain controller (which is being used by the Controller application server) to be a standard read-write (RWDC) domain controller.
  • See separate IBM Technote #1696789

Scenario #5 (Aggressive anti-virus product on client device)
Reconfigure the anti-virus product on the client device.
  • See separate IBM Technotes #1367435 & 2004655

Scenario #6 (Client device configured to auto-detect proxy server)
Reconfigure the client device, to not autodetect a proxy server.
  • See separate IBM Technote #1366681

Scenario #7 (Cognos CAM namespace configured to use a remote (across slow network) domain controller)
Reconfigure the Cognos CAM namespace to use an active directory domain controller which is located in the same location (typically same country) as the location of the application server.
  • See separate IBM Technote #2012694

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Historical Number

1041286

Document Information

Modified date:
15 June 2018

UID

swg21367308