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** Troubleshooting ** "The underlying connection was closed: An unexpected error occurred on a receive" when launching Controller client

Troubleshooting


Problem

User launches Controller client. User receives an error.

Symptom

image-20181121073932-1

The underlying connection was closed: An unexpected error occurred on a receive.
   at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Cognos.Controller.ControllerSoapHttpClientProtocol.Invoke(String methodname, Object[] parameters)
   at Cognos.Controller.Proxy.Light.WSLight.CheckServerConnection(String sGuid, String sUser)
   at Cognos.Controller.Direct.ServerInfoD.CheckServerConnection()
   at CCR.AppContext.CheckConnectionToServer()

Cause

The 'The underlying connection was closed: An unexpected error occurred on a receive' error can occur at different times when using Controller client.

  • This Technote *only* relates to the scenario where the error occurs immediately after launching the client
  • If the error occurs when you are using Controller's functionality (after you have successfully logged in) then see explanations inside separate IBM Technotes.

There are several known causes of this error when launching the client:

  •  Scenario #1 - The Controller application server's Windows SSL/TLS/security protocols had been partially disabled (locked down), so that only a very few protocols were enabled
    • Typically (most likely) it is caused by customers disabling TLS 1.0 and 1.1 (leaving only TLS 1.2 available)
    • For more details, see separate IBM Technote #276599.

  •  Scenario #2 - Both of the following are true:
    • Controller client configured to use SSL (HTTPS) for its communication (to the Controller application server)
    • Client (and/or the application server) has been configured to disable some required SSL/TLS communication protocols.
      • For more details, see separate IBM Technote #2015415.
  
  • Scenario #3 - Client device (and/or Controller application server) has Microsoft patch KB4467697 installed.
  
  • Scenario #4 - (32-bit Excel link error only, not 'main' Controller client) - The client device does not contain the required 32-bit registry key to force the use of TLS 1.2 for .NET
    • For more details, see separate IBM Technote #0956557.

Resolving The Problem

Scenario #1

Fix: Reconfigure Controller client to use the relevant communication protocol (typically TLS 1.2)

Workaround: Re-enable the relevant/required IIS communication protocols (on the application server).

  • For more details, see separate IBM Technote #276599.

Scenario #2

Reconfigure the client device (plus also the application server if necessary) so that the required protocols are enabled.

  • For more details, see separate IBM Technote #2015415.

   

Scenario #3

Uninstall Microsoft patch KB4467697 from client device:

image-20181121091306-1

  • If the problem remains, uninstall the same patch from the Controller application server.

   

Scenario #4
Add the 32-bit registry key (in other words, inside "\Wow6432Node"), to force 32-bit .NET applications to use TLS 1.2.

  • For more details, see separate IBM Technote #0956557.

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Document Information

Modified date:
16 September 2020

UID

ibm10741571