Troubleshooting
Problem
Symptom
Cause
- TIP: For many generic examples, see separate IBM Technote #1690080.
- Database hosted on DB2
- Performance problems are directly related to poor database maintenance (typically, out of date indexes).
- Cause #1 - Superuser has not recently run an 'internal' database optimise, where they ticked the box 'Analyze Schema'
- By ticking 'Analyze Schema' the DB2 database indexes/statistics get updated/improved, leading to improved performance
- For more details, see separate IBM Technote #1367485.
- Cause #2 - I.T. department do not have a regular/scheduled 'external' database maintenance plan (enabled on their DB2 server)
- This would perform many of the tasks (done inside an 'internal' database optimise) automatically. Specifically, it ensures that the database indexes/statistics get updated.
- For more details, see separate IBM Technote #1981728.
- Cause #3 - Limitation of Controller 10.4.0 (and earlier) where the 'internal' database optimise does not update all the indexes fully
- For more details, see separate IBM Technote #0879753.
Environment
Resolving The Problem
- Typically this should be done 1-2 times per month.
- For more details, see separate IBM Technote #1367485.
- For more details, see separate IBM Technote #1981728.
- Upgrade to a later version of Controller which correctly performs the extra/enhanced re-indexing (as part of its 'internal' database optimise routine)
- or workaround the problem by manually running the extra/enhanced re-indexing (periodically).
Related Information
1690080 - ** Best Practices ** How to improve performance in Cognos Controller
1367485 - FAQ - What does an 'internal' database optimise do, and how often sho…
1981728 - Controller DB2 database optimisation and maintenance Proven Practice …
0879753 - Slow performance when using DB2, caused by limitation of database opt…
Document Location
Worldwide
Was this topic helpful?
Document Information
Modified date:
03 April 2019
UID
ibm10879725