Troubleshooting
Problem
No notification of new Active Reports being sent to IBM Cgonos iOS Mobile App.
Symptom
Reports are delivered to the Mobile App, but there is no indication when they arrive as configured.
Cause
Netowrk problems with APNS connections:
Cognos Mobile Service or the iPad App does not have a connection available to the Apple Corporations servers.
Cognos Mobile Service or the iPad App does not have a connection available to the Apple Corporations servers.
APN Certificate expiry:
The APN Certificate has expired.
Environment
This could happen with any Supported iOS App version.
Diagnosing The Problem
Netowrk problems with APNS connections:
You will need to verify with your Wi-Fi Network Team that the network topology allows for external connections to Apple Corporation. Your Mobile Devices will need Internet access as well as access to the webserver for full functionality. Included below is a Knowledge Base article from Apple.
You will need to verify with your Wi-Fi Network Team that the network topology allows for external connections to Apple Corporation. Your Mobile Devices will need Internet access as well as access to the webserver for full functionality. Included below is a Knowledge Base article from Apple.
Two commands that can be used on the IBM Cognos server to ensure connection to the Apple Coporation's servers.
openssl s_client -connect gateway.sandbox.push.apple.com:2195 -tls1_2
openssl s_client -connect gateway.sandbox.push.apple.com:2196 -tls1_2
APN Certificate expiry:
In the ..\logs\mob.log file shows errors concerning the APN Certificate expiry and when it expired. In this case you can use this Technote to download a new Certificate that will be valid for 365 days from the date it was issued.
Resolving The Problem
Netowrk problems with APNS connections:
Verify that a valid connection to the Apple Corporations servers is available.
APN Certificate expiry:
Use the Technote below to download and replace the current APN Certificate and restart the Cognos system.
Verify that a valid connection to the Apple Corporations servers is available.
APN Certificate expiry:
Use the Technote below to download and replace the current APN Certificate and restart the Cognos system.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEN9H","label":"IBM Cognos Mobile"},"Component":"IBM Cognos iOS Mobile App","Platform":[{"code":"PF014","label":"iOS"}],"Version":"12.x;13.x","Edition":"IBM Cognos Mobile 11.0.x and 11.1.x","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
25 March 2020
UID
ibm10879607