IBM Support

** Troubleshooting ** "The cell or chart you're trying to change is on a protected sheet" when click on cell in Excel

Troubleshooting


Problem

User launches a Controller function (for example Data Entry) that initiates Excel. User clicks on a cell in Excel. User receives error.

Symptom


Microsoft Excel
The cell or chart you're trying to change is on a protected sheet.
To make changes, click Unprotect Sheet in the Review tab (you might need a password).
[OK]

Cause

There are several possible causes for this message:

  • Scenario #1 - User has opened a data entry form, but has chosen a period (i.e. month) that is locked
  • Scenario #2 - User has a 'security group' associated with their user ID.
    • For example, the user has a security form group linked to their user account. The security settings for this Form Group are set to "Read-Only" (not Read / Write).
    • Alternatively, the user has a security company group linked to their user account. The security settings for this Company Group are set to "Read-Only" (not Read / Write).
  • Scenario #3 - The Controller superuser has added new accounts in the form.
    • Afterwards, the superuser remembered to update the layout, however forgot to generate the movement account by linking the movement extension to the relevant base account.
  • Scenario #4 - Code production problem (defect reference APAR PM74277) in Controller 10.1.1308 and earlier.
    • Problem only affects some forms. Specifically, it only affects forms created to dynamically expand on a dimension.
  • Scenario #5 - Customer has forgotten to optimise the database after making structure changes.
    • Optimising the database is a required step after making many changes to the Controller system's structures.

Resolving The Problem

Scenario #1 - User has opened a data entry form, but has chosen a period that is locked
This behaviour is by design. Either:

  • Unlock the period
  • or choose a different period (which is unlocked).

Scenario #2 - User has a 'security group' (associated with their user ID) which is set to read-only.
Change security setting of relevant group (which the user belongs to) to Read / Write, or change the group (that the user belongs to) to be a different group (one that has Read/Write access to the relevant form parameters).

TIP:
  • For more details of 'security form groups', see separate IBM Technote #1346073.
  • For more details of how 'security company groups' work, see separate IBM Technote #1663765.

Scenario #3 - The Controller superuser has added new accounts in the form.
Ask the Controller superuser to generate the movement account.
  • TIP: For more details, see separate IBM Technote #1347695.

Scenario #4 - Code production problem (defect reference APAR PM74277) in Controller 10.1.1308 and earlier.
Upgrade to Controller 10.1.1 RP1 FP1 (10.1.1671) or later.
  • TIP: For more details, see separate IBM Technote #1666563.

Scenario #5 - Customer has forgotten to optimise the database after making structure changes.
Perform a database optimise.
  • TIP: For more details, see separate IBM Technote #1666564.

Internal Use Only

Created as part of PMR# 11497,019,866

[{"Product":{"code":"SS9S6B","label":"Cognos Controller"},"Business Unit":{"code":"BU002","label":"Business Analytics"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;10.1;10.1.1","Edition":""}]

Document Information

Modified date:
15 June 2018

UID

swg21666512