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Troubleshooting BusinessObjects metadata import

Troubleshooting


Problem

When you import metadata from SAP BusinessObjects, problems with dependencies within the BusinessObjects Central Management Server (CMS) can cause incomplete business lineage or data lineage in InfoSphere Metadata Workbench.

Symptom

This issue can have the following symptoms:

  • BI reports are imported with a stub of the BI model that has the same name as the report.
  • Linked universes are not imported.
  • Implementation resource metadata is missing.

Cause

Any of the following issues can contribute to broken lineage within InfoSphere Metadata Workbench:

    • Dependencies within the SAP BusinessObjects Central Management Server (CMS) might become stale or broken. These dependencies often go unnoticed because the BusinessObjects reporting run-time does not use them.
    • Granting insufficient access rights to the credentials that are used for importing from BusinessObjects can negatively affect the results of queries that the bridge uses to import metadata.
    • Insufficient access rights on the account under which the metadata interchange server runs can cause problems when the bridge accesses the BusinessObjects client APIs.

Resolving The Problem

General connectivity and access rights
The bridge requires administrator access to the BusinessObjects APIs and unrestricted access to the metadata within the BusinessObjects repository. The bridge assumes a fully privileged server-to-server interaction. The bridge does not modify BusinessObjects metadata. However, many bridge problems are caused by access rights issues. Queries that are executed by the bridge might silently fail and return no result when access is denied.

To resolve these issues take the following steps:

  1. Ensure that only one version of the BusinessObjects client tools is installed on the computer where the bridges are installed and that the client tools are at the same service pack level as the BusinessObjects server. If you are using BusinessObjects XI 4.x you may need to install additional service packs and patches. For more information on BusinessObjects XI 4.x patches, see technote: http://www-01.ibm.com/support/docview.wss?uid=swg27049262.
  2. Some bridge operations might fail while accessing local file-system resources. Ensure that the bridge agent is configured to run under a privileged (Administrator) account and not the local system account. For more information on changing the login account for the bridge agent, see technote: http://www-01.ibm.com/support/docview.wss?uid=swg21614605.
  3. Specify the BusinessObjects administrator user name and password when you run the bridge. This is the only way to ensure that you have eliminated issues with BusinessObjects access rights while troubleshooting.
  4. To rule out issues with service accounts while troubleshooting, you can start the bridge agent manually as an application instead of running it as a service.
    Log into the administrators account and open a DOS command window with administrator privileges. Execute the following commands:

    On versions V8.7 and V9.1 (Tomcat):
    > SET JRE_HOME=C:\IBM\InformationServer\ASBNode\apps\jre\
    > CD \IBM\InformationServer\Clients\MetaBrokersAndBridges\web\bin


    To start the bridge agent:
    > STARTUP

    To stop the bridge agent:
    > SHUTDOWN

    On version V11.3 (WebSphere Liberty Profile):
    > CD \IBM\InformationServer\wlp\bin

    To start the bridge agent in the background:
    > SERVER START MIS

    or run the bridge agent in console foreground:
    > SERVER RUN MIS

    To stop the bridge agent
    > SERVER STOP MIS

Missing database assets or missing linked universes.
When the bridge encounters unusable database connections or unresolvable linked universes, the implementation metadata often cannot be retrieved.

To resolve this issue, take the following steps:

  1. Using the BusinessObjects Designer client that is installed on the bridge server machine, ensure that you can import and edit any universe that you intend to import InfoSphere Information Server. Resolve any errors that occur with your BusinessObjects administrator.
  2. If you use linked universes, ensure that you can open the linked universes in BusinessObjects Designer without error.
  3. Ensure that the data connections for each universe are working from the bridge server machine:  From the Tools menu in BusinessObjects Designer, select Connections, choose a connection, and click Test.
  4. Save the universe and export it back to the Central Management Server.

BI model fragments with the same name as BI reports
A BI model fragment that is imported with the same name as a BI report indicates that dependencies between the report and its universe are broken within the BusinessObjects Central Management Server (CMS). These dependencies are established when a report is saved and exported to the CMS.

These dependencies are not used by the BusinessObjects reporting run-time so they may go unnoticed. The bridge requires these dependencies to establish the correct connection between the report and the objects within the universe. If these dependencies are broken, the bridge imports stubs of the universe objects under a BI model with the same name as the BI report.

To resolve most of these issues, take the following steps:

  1. Import the report into the appropriate report-authoring tool on the bridge server machine (the Web Intelligence rich client or the Desktop Intelligence client).
  2. Edit the report and ensure that Refresh on open is not selected.
  3. Edit each query, then close it without making changes.
  4. Save the report and export it back to the CMS.
  5. Clear the local cache in My Documents\My BusinessObjects Documents\userDocs.

There is no workaround for the following cases, where the bridge might be unable to resolve the dependencies between the report and its universe:
  • More than one universe in the CMS has the same name.
  • You migrated reports without their universes from another BusinessObjects system by using a BIAR file.

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Document Information

Modified date:
16 June 2018

UID

swg21620135