Troubleshooting
Problem
tipcli.,bat and consolecli.bat Export script failed during the TDWC upgrade because it couldn't resolve the Pathname where "Program Files" was used on the E: drive, because short name was not enabled.
Symptom
This is the failure message:
Error: Could not find or load main class
Files\IBM\JazzSM\profile\installedApps\JazzSMNode01Cell\isc.ear\JSON4J.jar; E:\PROGRA~1\IBM\WEBSPH~1\APPSER~1\derby\lib\derby.jar;
E:\PROGRA~1\IBM\WEBSPH~1\APPSER~1\derby\lib\derbytools.jar;E:\Program
You will also get the same result if you run "consolecli.bat Version"
Cause
The short name is not enabled on the E: drive, which causes the consolecli.bat script to fail when using any space in the path name, i.e. "Program Files"
Note: in DASH, tipcli.bat is just a wrapper script that calls consolecli.bat
Environment
DASH installed on E: drive where short names is not enabled.
Diagnosing The Problem
Run this command on the drive that you are running tipcli.bat ( which is a wrapper for consolecli.bat in DASH):
E:>fsutil 8dot3name query E:
The volume state is: 1 (8dot3 name creation is disabled).
The registry state is: 0 (Enable 8dot3 name creation on all volumes).
The volume state would be "0" if short names were enabled, here is an example from C: drive where it is enabled:
C:>fsutil 8dot3name query C:
The volume state is: 0 (8dot3 name creation is enabled).
The registry state is: 0 (Enable 8dot3 name creation on all volumes).
For additional information on fsutil, please see this article:
technet.microsoft.com/en-us/library/ff621566%28v=ws.11%29.aspx
Resolving The Problem
Three Options:
1) Enable the short name on the volume, which should be done after consulting with the Windows System Administrator and DASH Support. and taking a backup of the current DASH Installation:
"fsutil 8dot3name set E: 0"
2) Install the product on a drive where the short name is enabled.
3) We have a temporary fix for the consolecli.bat script to handle the case where short names are not enabled and you have "Program Files" in the install path. In this case, please contact DASH L2 Support and upload your copy of the <JazzSM_HOME>\ui\bin\consolecli.bat script.
Note: An APAR has been created for this issue: IV86979
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Document Information
Modified date:
17 June 2018
UID
swg21987306