Troubleshooting
Problem
Symptom
<Cognos 10>/logs/cbs_start.logに以下のログが出力されますが、cogserver.logには何も出力されません。
CBSSocketCommand failed to connect, CAM error: <errorDetail><errorCode>-12</errorCode><errorMessage>CAM-CRP-0026 The underlying socket: '127.0.0.1:9300' returned an error.</errorMessage><errorStack><errorCode>111</errorCode><errorMessage>Could not connect the socket, errno: 0x6f(111)</errorMessage></errorStack></errorDetail>
Cause
APAR:PI08403の問題(10.2.2で解決)であり、<Cognos 10>/temp/cbs.prefsファイルが削除されることにより発生します。
Environment
Tomcat/Oracle Sun JRE環境でのみ発生します。
Resolving The Problem
<Cognos 10>/tempディレクトリ下のファイルを削除時には、cbs.prefsファイルを残して削除します。
すでに削除した場合は、バックアップから戻すか、以下の手順でcbs.prefsファイルを作成します。
- IBM Cognos Configurationを起動します。
- どこかの設定を一箇所変更し、設定を保存します。(この時点でファイルは作成されます。)
- 変更箇所を元に戻し、再度設定を保存します。
Related Information
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21963831