Troubleshooting
Problem
How to correct wrong timestamp in TDI log files for Turkey Time
Symptom
The timestamp in the TDI log file is not the one reported by the OS.
Cause
In 2015 Turkey changed the date for the end of the daylight saving time to 8. Nov
Environment
TDI all versions
Diagnosing The Problem
Installing TDI on a windows machine and set the timezone to Istanbul and verify the TDI timestamp into the log file.
Resolving The Problem
Update the Java Time Zone Update Utility (JTZU) to the latest level ,
Edit the ibmdiservice.props add a line as
jvmcmdoptions= -Duser.timezone=Europe/Istanbul
[{"Product":{"code":"SSCQGF","label":"Tivoli Directory Integrator"},"Business Unit":{"code":"BU008","label":"Security"},"Component":"General","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21973041