IBM Support

TCTUI1003E error when selecting dataset to configure Impact widget in DASH

Troubleshooting


Problem

After upgrading to JazzSM 1.1 FP2. This error occurred when selecting a dataset when configuring DASHBoard Application Services Hub (DASH) widgets: "TCTUI1003E An error has occurred communicating with the server."

Symptom

When selecting the "Edit" -> "Select a Dataset", it will error out with the 'TCTUI1003E" error.

Cause

Software bug in JazzSM 1.1 FP02.

Environment

Attempting to select a Dataset when configuring an Impact Widget in DASH

Diagnosing The Problem

When trying to select a Dataset in DASH, this error is displayed:

Corresponding errors in the <JAZZSM_HOME>/profile/server1/SystemOut.log:


[8/17/15 9:05:27:536 BST] 000000c2 ClientEventSe E
com.ibm.isclite.runtime.aggregation.tags.ClientEventSettingsJSON getClientEventPortletSettings(request,window) Unable to retrieve client event settings per pii _1728157932 java.lang.NullPointerException
at com.ibm.isclite.service.datastore.eventing.EventingServiceImpl.getEventP
ortletSettings(EventingServiceImpl.java:789)

[8/17/15 9:05:45:086 BST] 000000c3 HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry I/O
exception (java.net.ConnectException) caught when processing request: Connection refused: connect

Resolving The Problem

The Problem was introduced in JazzSM 1.1 Fixpack 2, please refer to this technote and download the Impact 6.1.1-TIV-NCI-FP0002 fix for windows and install.

www-01.ibm.com/support/docview.wss?uid=swg1IV55464

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Jazz for Service Management","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.1.0.2","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

swg21965471