Troubleshooting
Problem
Resuming Base Services install after corrections with "taskrunner.bat CONTINUE STOPONERROR" gets "TaskID: ProcessManagerPackage TaskAction: runConfigurationStep ReturnCode -1..." even though it ends with "ERRORLEVEL 0".
Symptom
taskrunner.bat CONTINUE STOPONERROR gets:
TaskID: ProcessManagerPackage TaskAction: runConfigurationStep
ReturnCode -1 Completion Message: Not able to copy security for the DE database. Check the trace to get more information.
The CTGInstallTrace00.log shows:
20/02/2009 12:16:49 PM com.ibm.tivoli.ccmdb.install.common.util.CmnDEDatabaseBackupUtil backupDEDatabase(backupFileName, backupFileDir)
and:
StandardError: 'de_backupdb' is not recognized as an internal or external command,
operable program or batch file.
Cause
Checking into it showed that DE binaries were missing.
Resolving The Problem
Normally a backup of the DE registry is taken before the install and it should be under <CCMDB_HOME\de_backups> folder. For every install it will create another backup. The errors shows that it is not a problem with the backup as it is a problem with finding the command.
It appears that the DE was uninstalled or removed from the admin workstation. The DE should be laid down during base services install (if it doesn't find one). Looks like part of the DE install (or acsi directory) still remained after the uninstall causing base services not to install acsi.
To proceed:
1) make sure old DE directory is completely removed (usually in c:\program files\ibm\common\acsi)
2) run the <ccmdb_home>/bin/setupPSIEnv.bat
3) manually install DE: <ccmdb_home>/de/si_inst.bat
4) finish installing base services using command "TaskRunner.bat CONTINUE STOPONERROR"
Product Synonym
SRM TSRM
Was this topic helpful?
Document Information
Modified date:
27 February 2019
UID
swg21378203