IBM Support

'SystemServerConnectionFailure' error when opening a published workspace or report on a unix server

Troubleshooting


Problem

While using TM1 FP6 as a data source, Cognos Insight and Cognos Business Intelligence users opening a published workspace on a Unix server may encounter a "SystemServerConnectionFailed" error message.

Cause

This issue is caused by TLS version incompatibility. TM1 FP6 uses TLS v1.2 by default. If a client application is not using TLS v1.2, the connection will fail.

Resolving The Problem

In order to resolve this issue, users must enable pre TLS v1.2 support on the TM1 Server and TM1 Admin Server:

TM1 Admin Server


  1. Stop all TM1 servers, including TM1 servers created by IBM Cognos Insight Publish
    Note: Users will need to find and stop servers created by IBM Cognos Insight Publish via Task Manager > Services
  2. Click Start > IBM Cognos TM1 > IBM Cognos Configuration
  3. Expand Environment > TM1 Application Server
  4. Click TM1 Admin Server
  5. Set the Support pre-TLS v1.2 clients? property to True
  6. Click File > Save
  7. Click File > Exit
  8. Click Yes if prompted to restart the TM1 Admin Server

TM1 Server


Perform the following for TM1 servers created by IBM Cognos Insight Publish or TM1 servers used as a TM1 data source by IBM Cognos Business Intelligence 10.2.2 FP5 or earlier:
  1. Locate and open the tm1s.cfg file in an editor
    Note: The tm1s.cfg file for TM1 servers created by IBM Cognos Insight Publish can be found in \webapps\pmpsvc\WEB-INF\desktopdata
  2. Add 'SupportPreTLSv12Clients=T'
  3. Save the file
  4. Restart all TM1 servers

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21986940