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Click here to go to change history 
The IBM Z Batch Network Analyzer (IBM zBNA) application accepts SMF Record Types 14, 15, 16, 
30, 42, 70, 72, 74, 78, and 113 data to analyze a single batch window of user defined length. The 
data is extracted using the CP3KEXTR program, which is run on an IBM Z processor under z/OS. 
Both zBNA and CP3KEXTR are designed by the Capacity Planning Support (CPS) Tools team of 
IBM’s Washington Systems Center. 
 
Instructions to obtain both the required IBM CPS Java Runtime Environment (JRE) v8 64-bit and the 
CP3KEXTR materials are available on the download website where you obtained zBNA. 

1. IBM employees 
https://supportcontent.ibm.com/support/pages/node/6354319 

2. IBM Business Partners and IBM Clients 
https://www.ibm.com/support/pages/node/6354321 

Note: When other Java Runtime Environments have been installed and configured with Java security 
enabled, a fresh install of CPS Java may fail to execute properly.  This has been observed in a very 
small number of CPS Java installations.  Should this situation occur, one possible solution is to:  1) 
uninstall the other Java, 2) uninstall CPS Java, 3) re-install CPS Java, and 4) re-install the other Java. 

Installation Tips, Usage Notes, and Problem Solutions 

1. The currently supported environment is Windows 10 64-bit. 
2. The IBM CPS Java Runtime Environment requires a minimum of 4GB of memory in order to 

run smoothly.  If less than 4GB is available, zBNA will not start. 
3. A monitor resolution of 1024x768 or higher is required.  Some windows may require the entire 

vertical or horizontal dimension at this resolution (see next item). 
4. The Windows task bar, if set to Always on Top, some windows may not be entirely visible 

without moving the application’s window.  This situation can be corrected by going to Windows 
task bar properties and un-checking Keep the taskbar on top of other windows. 

5. Erratic Behavior and Abend Situations:  Most of the reported execution problems have been 
traced to outdated graphics drivers and Java activities that invoke "Hardware acceleration".  To 
identify this as the problem, you should turn "Hardware acceleration" off (go to Desktop 
properties, click on the Settings tab, click the Advanced button, click the Troubleshoot tab, 
and move the slider to "None").  If this solves the problem, you can try to find a more current 
graphics adapter driver version or continue to run with the accelerator slider at a reduced 
setting. 

  

https://supportcontent.ibm.com/support/pages/node/6354319
https://www.ibm.com/support/pages/node/6354321
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Registration 

A user registration process has been implemented to assist in monitoring the distribution and 
use of zBNA. Registration is required for continued usage. You must be connected to the 
internet to register. 

Until your registration process is completed, a registration form will appear each time zBNA is 
started.  zBNA may be used up to three times without completing and successfully submitting 
the registration information. After that, the registration process must be completed before the 
function of the application can be accessed. 

Fill in the requested fields (e.g., name, company name, geographical location, and email 
address), and click the Register (Internet) button.  The primary value of providing a valid 
email address lies in our (CPS applications) ability to notify you of any critical news 
relating to zBNA’s usage and/or updates. Use of the email address will be limited to this 
purpose only. 

There may be cases where a firewall will prevent direct internet registration. In this situation, 
(internet registration has failed at least once) you should click the Register (email) button. 
This will: 
1. attempt to initiate a properly addressed email for you, and 
2. invoke a dialog box with instructions to copy the encoded registration information into the 

email note. 

Send the email, as addressed, with the encoded registration information and wait for an email 
response (generally within 24 hours on normal workdays). Once received, start zBNA again, 
click the Register (email) button, and continue with the dialog box instructions, indicating that 
you are to copy the contents of the returned note and click the Complete Registration button. 
 
Registration via internet requires access to a URL.  In certain instances, installation firewalls 
would need to be updated to allow internet access, per the table below. 
 

 URL 

CPS Registration https://cpsregistration.us-south.cf.appdomain.cloud/ 

Registration is only required once, the first time that zBNA is installed and attempted to be 
used. Once registered, you have unlimited access to zBNA. Occasionally, as major versions of 
zBNA become available, your registration will automatically be renewed. 

Documentation 

Available for download from the distribution site: 
o zBNA User's Guide in PDF format 

Disclaimer 

The performance data contained in zBNA was derived by IBM in a controlled environment. A 
customer's actual performance results may vary significantly.  Accordingly, IBM provides no 
representations or assurances that a customer will obtain the same or similar results. 

Contact 

Support concerning zBNA’s function, usability, satisfaction, etc. is available from: 

• email:  zbna@ibm.com 

 

mailto:%20zbna@ibm.com
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Current Version / Latest Changes 

V2.7.4 (12/12/2025) 
Fix potential crash when opening Classic Batch. 
 
V2.7.3 (10/28/2025) 
1. IBM Java: A new version of the IBM Semeru 64-bit runtime environment is included with this 

version 2.7.3 install package.  
Microsoft Windows Platform Users: Any previous version of IBM zBNA must be uninstalled 
prior to installing IBM zBNA 2.7.3.  

2. “Graph Options” for Key jobs and data sets has been replaced with the new “Key Options” filter. 
This filter allows the user to filter both tables and graphs to jobs or data sets selected as “Key”. It 
also allows “Key” items to be hidden. 

3. Trim a DAT file: Multiple DAT files can be selected and trimmed in one operation. If multiple DAT 
files are selected, they must:  

• cover the same date and time period 

• be located in the same file directory 
4. Update zEDC, zHyperLink™, and DFSORT IBM Z Sort algorithms for z17. 
 
V2.7.2 (07/22/2025) 
1. Smarttext enhanced for chart ZHL1001. 
2. Miscellaneous other enhancements and bug fixes. 
 
V2.7.1 (05/06/2025) 
1. Added “G10 Eligibility” as a potential value for the zHyperLink™ column in the following tables. 

• Top Data Sets 

• Life of a Data Set 

• Job Data Set Report 
This indicates the data set is zHyperLink™ eligible on IBM DS8000 G10 DASD but not prior 
generations. The value “Has Eligibility” indicates zHyperLink™ eligibility on IBM DS8900 or later. 

2. Miscellaneous other enhancements and bug fixes. 
 
V2.7.0 (04/08/2025) 
1. The IBM z17 (9175-ME1) processor family has been added with 337 General Purpose models 

(208 full-speed and 129 sub-capacity) and 208 IFL models. Real CP maximum settings, based on 
number of drawers, are 43, 90, 136, 183, and 208. Real CPs may be configured as General 
Purpose (maximum of 43 on /400, /500, and /600 speeds), zIIP, IFL, or ICF. 

2. zHyperLink™: The “Max Box Size” filter panel is replaced with two new panels. 

• DASD Technology 

• Max zHL Read Block Size 
The default DASD Technology is DS8900 (same as previous versions of zBNA). When DS8900 is 
selected, zHL Read Max Block Size is defaulted to 4K and cannot be changed. If DS8000 G10 is 
selected, zHL Read Max Block Size is set to 16K by default. zHL Write Max Block size is always 
4K regardless of DASD Technology.  

3. zBNA main window’s “Time Span” panel now includes three time spans: 

• Global Filter 

• EDF Time Span 

• DAT Time Span 
4. Miscellaneous other enhancements and bug fixes. 
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V2.6.2 (02/25/2025) 
1. New Named Favorites “Generate Multiple LPAR Reports” Mode: 

• “Named Favorites” menu item on zBNA main panel can be accessed without initial data load. 

• In the Named Favorites panel under the “Generate” menu, click “Multiple LPAR Options” to 
select multiple EDF & DAT pairs (and optional filter file) to include when generating a report. 

2. Time durations are now displayed in ##h.##m.##s format in both tables and charts for the 
following analyses. 

• Classic Batch 

• Classic Batch DFSORT 

• DFSORT IBM Z Sort 
3. Miscellaneous other enhancements and bug fixes. 
 
V2.6.1 (12/17/2024) 
1. Report, zHyperLink™ Intensity (ZHL1004), is included in the IBM Named Favorite for a 

zHyperLink™ Study.  
2. The term, “Est. GCP Queue Time”, replaces “Queue delay”, “GCP delay”, and “GCP queue delay” 

for consistency throughout IBM zBNA.  
3. Miscellaneous other enhancements and bug fixes. 
 
V2.6.0 (09/27/2024) 
1. zHyperLink™ support for IBM DS8000 G10 Storage 

• Estimate response time benefit on IBM DS8000 G10. 

• When modeling on IBM DS8000 G10, default block size limit increases from 4K to 16K. A 
new option to increase limit up to 32K. 

• For data sets actively using zHyperLink™ on IBM DS8900, can estimate additional 
response time benefit when migrating to IBM DS8000 G10. 

2. Updated DFSORT IBM Z Sort algorithm. 
3. Miscellaneous other enhancements and bug fixes. 
 
V2.5.6 (06/25/2024) 
1. Updated zEDC eligibility algorithm for data sets accessed by a SORT program. Note: Requires 

data extracted by CP3KEXTR Version 4.35 dated 04/19/2024 or later. 
2. Updated text for chart, zHL1001, with zHyperLink™ adapter considerations based on active and 

eligible zHyperLink™ I/Os per second. 
3. Updated DFSORT IBM Z Sort algorithm. 
4. Updated tooltips for the “Initiator Delay”, “Queue Delay”, and “Init Time” columns in Classic Batch. 
5. Miscellaneous other enhancements and bug fixes. 
 
V2.5.5 (03/19/2024) 
Notes for this release: 

• Starting with this release, for the Windows platform, there is a single zBNA installation file, 
zBNAInstallwithJava.exe, which is available to Clients, Business Partners, and IBM 
employees via the regular distribution locations. 

• Additionally, the IBM Java Runtime version has been updated in this release, which requires 
an uninstall of the previous version. With this said, the V2.5.5 installation will not complete until 
the previous version is uninstalled. 
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1. Added “Proc Step” column to DFSORT IBM Z Sort table. 
2. Additional Classic Batch charts are supported in the Graph Aggregator application. 

• BATCH1008 – Total Job Initiator Time in MIPS 

• BATCH1017 – Total IIPCP Time in MIPS 
3. Miscellaneous other enhancements and bug fixes. 
 
V2.5.4 (12/12/2023) 
1. New Classic Batch charts 

• BATCH1018 – Steps Ended and CPU Time Report 

• BATCH1019 – GCP Time by Top Job Pattern 
2. New Top Programs chart, TOPPGM1002 – Job Steps by Top Program Name. 
3. Miscellaneous other enhancements and bug fixes. 
 
V2.5.3 (10/10/2023) 
1. IBM Java has been updated to Java V17 (previous version was Java V8 SR8). This change will 

be transparent to the user and function should remain consistent with previous versions.  

• IBM employees ONLY on the Windows platform must download and install the new 
CPSJavaV17 package available on the IBM CPS Tools download site. In addition to zBNA, 
CPSJavaV17 supports new versions of zPCR. The previous CPSJavaV8 remains a 
requirement for zSoftCap for the time being.  

• Authorized IBM Business Partners and Clients need not be concerned, as the required 
Java is included as part of each install package. 

2. Miscellaneous other enhancements and bug fixes. 
 
V2.5.2 (07/18/2023) 
1. DFSORT analysis is available in the Classic Batch Application on the DFSORT tab.  

Note:  SMF 16 records are required. 
2. Modify Document enhanced to work when no data is loaded in zBNA. 
3. Smarttext enhanced for chart ZHL1001.  
4. zEDC algorithm updated. 
5. Job order in Classic Batch CSV output now matches sorted order in the table. 
6. Miscellaneous other enhancements and bug fixes. 
 
V2.5.1 (04/04/2023) 
1. The IBM z16 (3932-A02) processor family has been added. There are 156 General Purpose 

models (26 speed settings) and up to 68 IFL models. A single-drawer configuration provides a 
maximum of 32 real CPs; a 2-drawer configuration provides a maximum of 68 real CPs. CPs may 
be configured as General Purpose (maximum of 6), zIIP, IFL, or ICF. 

• The 3932-A02 is a factory frame model; the 3932-AGZ is a client rack mount model. 
2. Added an option to the File menu to always use US English data and number formats. 
3. Miscellaneous other enhancements and bug fixes. 
 
V2.5.0 (02/17/2023) 
1. The main File menu has been enhanced to include flexibility for setting the number of saved files 

remembered up to eight (default is four) and clearing the list. 
2. zBNA will provide a warning when loading a .dat file that is likely to exceed workstation memory 

limits and provide the option to trim the .dat file. 
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3. When loading a .dat file from an LPAR where Global Performance Data is disabled, zBNA 
provides a prompt for the system configuration information. 

4. Added the DFSORT tab in the Classic Batch Application, and the following requirements must be 
met for it to be enabled. 

• The .dat file contains SMF 16 records. 

• CP3KEXTR Version 4.28 dated 02/09/23 or later. Note: Using CP3KEXTR Version V4.27 
enables the DFSORT tab, however, not all of the charts are viewable.   

There are seven new charts (CBSORTnnnn) to support the Classic Batch DFSORT table data. A 
CSV file can also be generated.   

5. Miscellaneous other enhancements and bug fixes. 
 
V2.4.4 (11/08/2022) 
1. A “Save Selected” button has been added to the Graph Selection Windows. Selected charts can 

be saved directly to your document by clicking this button. The Modify Document window will 
automatically open once the selected charts have been saved in the document. 

2. Miscellaneous other enhancements and bug fixes. 
 
V2.4.3 (9/13/2022) 
1. The LinuxONE Emperor 4 (3931-LA1) processor family has been added. 
2. The Time Span is always shown for the loaded data on the main zBNA panel. 
3. “Named Favorites” and “Modify Document” have their individual menu items on the main panel. 
4. The DFSORT IBM Z Sort table now includes the “IBM Z Sort Not Used Code” column. 
5. Added the “Show All” button to the Job Name Include Mask filter window. 
6. Added a new column, “Steps with Cond Code>=0008 zIIP Time”, to the Top Program candidate 

table, graphs, and programs only CSV output. 
7. When sorts that are already using IBM Z Sort are present in the data, “Using IBM Z Sort” will show 

as a Location filter. 
8. In the “Show ineligible job steps” table, the row count has been added along with the Find 

function on the Action menu. 
9. Miscellaneous other enhancements and bug fixes. 
 
V2.4.2 (7/22/2022) 
1. Added zHyperLink™ write estimates for Db2 log data sets. 
2. Added “Data Set by Hour” analysis to zBNA Applications analyzing data sets. 
3. Tables and graphs display dates in localized format and times in 24-hour format. 
4. Miscellaneous other enhancements and bug fixes. 
 
V2.4.1 (6/01/2022) 
1. Enhanced “Trim a DAT file” user interface. 
2. Miscellaneous other enhancements and bug fixes. 
 
V2.4.0 (4/05/2022) 
1. The IBM z16 (3931-A01) processor family has been added with 317 General Purpose models 

(200 Full-Speed and 117 Sub-Capacity) and 200 IFL models. 
2. New zBNA Enablement website containing education videos; both navigation mechanics and 

application charts review. The following two resources are available for the DFSORT IBM Z Sort 
application in zBNA. 
zBNA Putting the New Z SORT Named Favorite into Practice 
IBM Z Sort and DFSORT Considerations  

https://www.ibm.com/support/pages/zbna-enablement
https://ibm.ent.box.com/file/722576200981?v=zBNA-Z-Sort-Webinar
https://www.ibm.com/support/pages/node/6468061
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3. Miscellaneous other enhancements and bug fixes. 
 
V2.3.1 (3/08/2022) 
1. The smarttext of many charts has been updated to improve readability. 
2. The STC and TSU Job Classes are now excluded, by default, in the Classic Batch Application. 
3. Implemented the ability to import a list of Job or DSN Masks from a text file. Click the new button 

that has been added in the Filter window for the Applications that support this.  
4. Algorithm updates to the Classic Batch and Top Programs Applications. 
5. Miscellaneous other enhancements and bug fixes. 
 
V2.3.0 (10/05/2021) 
1. Added a new Filters panel that shows the state of all filters across zBNA Applications. It also 

enables compatible filters to be copied between zBNA Applications. Access the Filters panel from 
any zBNA window using the Filters menu and “View/Edit”. 

2. Added dialog to confirm closing zBNA. Also, if the data loaded was in tersed format, a prompt 
displays asking to save an untersed copy for faster loading. 

3. Updated the Classic Batch Column Selection (Edit→Select Columns) window. 
4. Miscellaneous other enhancements and bug fixes. 
 
V2.2.4 (5/25/2021) 
1. Added two new DFSort Z Sort reports: 

• SORT1007 – Top 15 Memory Object >=75% Report 

• SORT1008 – Top 15 Potential Z Sort Report w/Add. Proc. Storage 
 
2. The following columns in the DFSort Z Sort table are now reported in Gigabytes instead of 

Megabytes: 

• Bytes Sorted 

• Memory Obj Used 

• Memory Limit 
3. Graph Aggregator support for DFSort Z Sort graphs. 
4. Classic Batch CSV output has the option to include defined alternate processors. 
5. Improved performance when changing filters in Classic Batch and DFSort Z Sort. 
6. Miscellaneous other enhancements and bug fixes. 
 
V2.2.3 (3/26/2021) 
1. Update DFSort Z Sort charts to improve identification of sorts that may be eligible for Z Sort 

acceleration if more processor storage is made available. 
2. Fix GCP Time reported for Hiperspace Sorts in DFSort Z Sort. Requires data from CP3KEXTR 

v4.18 or later. 
3. Update zHyperLink™ candidate algorithm. 
4. Minor updates to Classic Batch and zEDC UI. 
5. Improved formatting of filters in chart text. 
6. Miscellaneous other enhancements and bug fixes. 
 
V2.2.2 (12/11/2020) 
1. The Preview Window of Modify Document now has a delete button, so you no longer have to 

leave the preview screen to remove an unnecessary chart. 
2. Miscellaneous other enhancements and bug fixes. 
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Statement of Direction:  
The images directory that is created as part of the HTML report generation will no longer be created 
in the next release. The images are now embedded into the HTML directly and the images directory is 
now a redundant repository of said images. To access the images in the future, open the HTML file in 
a browser or document editor, right click the image and either save the image or copy to the clipboard 
for your use. 
 
 
V2.2.1 (10/21/2020) 
1. Modification made to the zEDC algorithm calculations for Generic and Tailored compressed data 

sets. 
2. Miscellaneous other enhancements and bug fixes. 
 
V2. 2 (9/30/2020) 
1. General 

• New DFSORT Z Sort function, which requires SMF Type 16 and 30 subtype 4 records. This 
function provides an analysis of IBM DFSORT job steps that are eligible to exploit the IBM 
Integrated Accelerator for Z Sort on the z15 processor. Each row in the table represents a job 
step that is eligible to use Z Sort on z15 and provides an estimate of elapsed time and CPU 
time savings that may be achieved. Several charts that provide visual representations of the 
estimated savings over the study period can be viewed by clicking on the Analysis button. 
- SORT1000: Top 15 Z Sort Gantt Chart 
- SORT1001:  Estimated Z Sort MIPS Savings 
- SORT1002:  Estimated Z Sort MSU Savings 
- SORT1003:  Total Sorts analysis 
- SORT1004:  Total Megabytes Sorted analysis 
- SORT1005:  Estimated z15 Elapsed Time Savings 

• Added the IBM Z Sort Named Favorite. 

• Added the "Charts Only" report function to Modify Document panel. 
 
2. Top Programs 

• "Save as CSV, Programs and Job Steps" function added under the File > Save as CSV 
submenu. This produces a CSV with the program names from the table and all jobname / 
steps using the program. 

3. zEDC 

• EDC1009 supports showing zEDC usage on a z15 host with SMF74 subtype 10 records. 
4. Miscellaneous other enhancements and bug fixes. 
 
V2. 1 (4/14/2020) 

• The IBM z15 -T02 processor family (8562-xxx) has been added, with 156 General Purpose 
Models (26 speed settings), in various configurations of up to 2 drawers. 

• New function, Favorites Report, is added to the Action menu on the main zBNA window. 

• New function, Trim a DAT file, is added to the File menu on the main zBNA window.  

• Miscellaneous other enhancements and bug fixes. 
 
V2. 0.3 (2/28/2020) 

• New charts added for Tailored Fit Pricing: 
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- BATCH1007;  Top 15 Jobs by Initiator Time 
- BATCH1008;  Total Job Initiator Time in MIPS 
- BATCH1009;  Top 15 Jobs by CPU Time 
- BATCH1010;  Top 15 Jobs by EXCP Count 
- BATCH1011;  Top 15 Jobs by EXCP per CPU Second 
- BATCH1012;  Top Jobs by CPU and by EXCP 
- BATCH1013;  Top 15 Jobs by Estimated CPU Queue Delay 
- BATCH1014;  Total Estimated CPU Queue Delay 
- BATCH1015;  Top Jobs by CPU and by Estimated CPU Queue Delay 
- BATCH1016;  Top 15 Jobs by IIPCP Time 
- BATCH1017;  Total IIPCP Time in MIPS 

• Access the Job Data Set Report on all Gantt Charts when you left click on a specific job. 

• Red no longer represents Key jobs on BATCH1003, Jobs Gantt Chart. A description of the colors 
on the graph are shown as a list of items. 

• BATCH1005, Top 15 Jobs Report, now includes a Gantt Chart. Updated the "Understanding the 
Processor Table" section in the smarttext. Added the percentage of CPU time consumed by 
initiator time in the Overview section. 

• The Graph Aggregator Application updated to support these two new graphs: 
- TOPDS1001; Data Set I/O Rate 
- TOPDS1002; Data Set I/O GigaBytes per Hour 

• The Top 15 Data Sets Report, TOPDS1000, was updated. 

• Added TOPPGM1001, Top 15 Programs Cond Code>=0008 CPU Time Report. 

• Miscellaneous other enhancements and bug fixes. 
 
V2. 0.2 (11/08/2019) 

• Improved load times for BSAM/QSAM zEDC and Data Set Encryption applications. 

• Updated the zEDC algorithm. 

• “Show ineligible data sets” button added to zEDC Filters. 

• Added PDSE support for Data Set Encryption. 

• The Data Set Encryption algorithm was updated. 

• Miscellaneous other enhancements and bug fixes. 
 
V2. 0.1 (9/12/2019) 

• The IBM z15 (8561-T01) processor family has been added, with 190 full-speed and 102 sub-
capacity General Purpose Models, and 190 IFL models. Various drawer configurations provide up 
to 190 real CPs, which can be configured as General Purpose, zIIP, IFL, or ICF engines. The 
processor designation is 8561-7xx for full speed models, and 8561-4xx, -5xx, or 6xx for sub-
capacity models. 

• New zEDC analyses: 
- EDC1007 (requires SMF 78 subtype 3 records) 
- EDC1008 (requires SMF 74 subtype 9 and 78 subtype 3 records) 
- EDC1009 

• Added “Save Options” to the File menu on the main zBNA window. 

• Miscellaneous other enhancements and bug fixes. 
 
V2. 0.0a (7/31/2019) 

• Fixed algorithms for the following zEDC analyses: 
- EDC1002 
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- EDC1003 
- EDC1004 
- EDC1005  

• Reduced memory usage (RAM) as compared to v2.0.0.  As a result, some applications and charts 
will take longer to load. 

• Fixed Estimated Compression Ratio column in the Top 15 zEDC and Data Set Encryption 
Report, EDCE1000. 

• Corrected error generating CSV files for the zEDC analyses. 

• Fixed error when using the Analysis button in the Top Data Set Programs Applications.  

• Miscellaneous other enhancements and bug fixes. 
 
V2.0 (7/12/2019) 

• A brand-new UI design allowing users to easily find and directly access the applications they want 
to use. 

• The ability to import and export zBNA filters used in each application for later use and/or share 
with others. 

• Top Program analysis to help users identify which programs are consuming the most CPU time 
during their batch window. zBNA can also perform a Life of a Program analysis showing every 
Job Step in the analysis found to be using a specific program. 

• An encryption analysis enhancement to enable users to view CPU Time, MIPS, and MSU saving 
projections when compressing QSAM/BSAM zEDC eligible data sets before encrypting them with 
DFSMS Encryption. 

• Error files are now stored in the same folder where zBNA is installed.  The default is 
C:\CPSTOOLS\zBNA. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8. 4a (2/25/2019) ***updated 03/26/2019*** 

• ***Made minor changes in the zHyperLink™ smarttext. *** 

• ***Fixed an error in the Top Programs Application when there are no SMF 42(6) records in the 
data, as they are not used in this application. *** 

• Corrected problem with Unicode characters displaying in the zHyperLink™ graph names. 

• Additional updates to the zHyperLink™ smarttext. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8. 4 (1/4/2019) 

• Top Programs added to the Applications menu. 

• The Encryption Application now includes zEDC + DS Encryption. 

• The CSV now includes the processor serial number. 

• Smarttext updates to the zHyperLink™ analyses. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8. 3 (10/22/2018) 

• "Ineligible Data Set List" function added to Data Set Encryption. 

• Top Data Sets: added new columns, in addition to support for one microsecond. 

• Major update to the Report generation using the Analysis pushbutton. 

• Enhancements and updates made to the Report document. 
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• Life of a Data Set: added new columns, in addition to support for one microsecond, and read % 
now based on I/O, not blocks. 

• Filter information is now included in the report document. 

• zHyperLink™: added new columns. 

• "What's New" and "Check for Updates" added in the Help menu. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8. 2 (04/10/2018) ***updated 04/23/2018*** 

• ***Metrics concerning z14-ZR1 CP Contention have been revised. This change may lower z14-
ZR1 capacity results by up to 1.1%, depending on the ratio of GP+zIIP to IFL+ICF real CPs 
configured. There is no contention cost if all CPs are in one group. *** 

 

• The IBM z14 (3907-ZR1) processor family has been added, with 156 General Purpose models (26 
speed settings) and 30 IFL models.  It is a single drawer configuration providing a maximum of 30 
real CPs.  CPs may be configured as General Purpose (maximum of 6), zIIP, IFL, or ICF. 

• The new Multiple Systems Graph Creator allows loading multiple CSVs saved from the graphs 
within zBNA and aggregate them together to get a “multi-system” graph.  The support is currently 
available to the zEDC, Encryption and zHyperLink™ applications. 

• Enhancements to the Data Set and Coupling Facility Encryption function. 

• Added the ability to estimate the benefit of zHyperLink™ I/O activity using the new zHyperLink™ 
Application. SMF 42 (6) records are required. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8.1d (12/15/2017) updated 01/25/2018 

• Corrected problems accessing the Encryption Application. 

• Added a message to display when there is no SMF Type 30 subtype 5 data. 
• Corrected the problem in the zEDC table that affected the compression ratio. 
 
V1.8.1c (12/07/2017) 

• Added the Customer Name dialogue when creating reports. 

• Added "Encrypted" column on the Top Data Sets panel. 

• Added MSU graphs to both the zEDC and Encryption applications. 

• Several text updates for the Top Data Sets, zEDC, and Encryption HTML reports. 

• Added the Multiple System Graph Creator function to the Applications menu. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8.1b (09/29/2017) 

• Text updates to the main zBNA report. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.8.1a (08/31/2017) 
Updates to the encryption algorithm. 
 
V1. 8. 1 (08/25/2017) 

• Support for Pervasive Encryption – Data Set and Coupling Facility.  NOTE: For z14 estimations, 
the estimate presented assumes that the following performance APARs have been applied to the 
system: OA53718, OA53664. 
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• Miscellaneous other enhancements and bug fixes. 
 
V1. 8. 0 (07/27/2017) 

• The IBM z Systems (z14) processor family has been added, with 269 General Purpose models 
(170 full-speed and 99 slugged) and 170 IFL models.  Various drawer configurations provide up to 
170 real CPs, which can be configured as General Purpose, zIIP, IFL, or ICF engines.  The  

• processor designation is 3906-7xx for full speed models, and 3906-4xx, -5xx, or 6xx for sub-
capacity models. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.7. 5 (06/01/2017) 

• Time filter set on the Filters panel is propagated on the Top Data Sets panel. 

• Added support for a default output directory when creating CSV and HTML files. 

• The MIPS graph is added in the list of zEDC graphs. 

• On the zEDC panel, the Compression Ration, 1:1, is now shown as “N/A”. 

• Update to the zEDC algorithm. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.7. 4 (03/03/2017) 

• Options are available on the File menu on the main zBNA panel to save Alternate processor, 
Jobs, and/or step level data in the CSV files created. 

• A service class job filter panel is included in the Life of a Program dialog. 

• The time filter set on the Filters panel is propagated on the zEDC Top Data Sets panel. 

• Includes updated z13 RNI formula. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.7.3 (01/17/2017) 

• All of the column data on the zBNA main panel is saved in the CSV file. 

• zEDC algorithm updated to separate reads/writes for Generic and Tailored data sets. 

• When a terse file is loaded, "Save untersed file as DAT file" is enabled on the File menu on the 
main zBNA panel.  This function will save the . dat file from the untersed data that is in the model. 

• Support added when multiple monitors are being used. 

• Display the "Init Time" data on both the Main and Job Details panel. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.7. 2 (08/19/2016) 

• Added a feature that combines multiple systems’ zEDC graphs. This feature is accessible using 
Action, Create Multiple System Graph on the "zEDC Top Data Sets" panel. 

• Updated the "Top Data Sets" function. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.7.1 (06/28/2016) 

• On the "zEDC Top Data Sets" panel in the MB/sec column, correctly show that data, instead of 
displaying the bytes per second. 

 
V1.7.0 (06/24/2016) 

• Support for Java Version 8 migration. 
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• Implemented Applications menu on the main zBNA panel. Both the Top Data Sets and zEDC 
Compression functions are now on this menu item. 

• Updated the "Top Data Set" panel to produce an HTML report and sort the columns. Added the 
Service Class and Job Name columns on the panel, and that data is in the HTML report and CSV. 

• Performance improvements to the load process 
 
V1.6.9 (03/31/2016) 

• Implemented the MSU 4-hour Rolling Average graph. 

• Added tooltips on both the CPU Utilization and MSU 4-hour Rolling Average graphs. 

• Corrected the problem in the zBNA report when there are alternates, the “Total” line is off by three 
columns.  

• Added two columns for the I/O Count and CPU Time data into the CSV generated on the “zEDC 
Top Data Sets” panel. 

• The zIIP calculation for the alternate processors has been corrected.   

• Miscellaneous other enhancements and bug fixes. 
 
V1.6.8 (02/16/2016) 

• The IBM z Systems z13s processor family has been added, with 156 General Purpose models 
(various speed settings) and 20 IFL models. Single drawer configurations (2965-N10) provide up 
to 10 real CPs; 2-drawer configuration (2965-N20) provide up to 20 CPs. CPS can be configured 
as General Purpose (maximum of 6), zIIP, IFL, or ICF engines. 

• LSPR data is based on z/OS-2.1. 

• The "Top 10 Data Set Report" has been updated to allow the user to specify the number of data 
sets. 

• A new panel, "Life of a Program", is now available with Step information for a selected program. 
The panel is obtained from the "Job Details" panel. 

• On the "Edit, Select Columns" menu on the main zBNA panel, Reset Columns has been added. 
This allows the original columns view to display. 

• The "Edit, Find" menu has been updated to perform a forward and backward search. 

• The zBNA panels can now be maximized. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.6.7 (12/10/2015) 

• zBNA remembers up to the last four loaded files on the File menu. 

• When an ". edf" file is selected on the "Import Files" panel, zBNA automatically inputs its 
corresponding ". dat" with the identical file name, when it exists in the same directory. The same 
is true when there is a corresponding ". trs", instead of the ". dat". 

• The "Queue Delay" metrics are included on the main panel. 

• On the main panel, the user can now choose which Job information columns are shown, from a 
preselected list, using Select Columns on the Edit menu. 

• Added the Job RACF UserID and RACF Group to the "Job Details" and "Filters" panel, as well as 
in the report. 

• Miscellaneous other enhancements and bug fixes. 
 
V1.6.6 (09/30/2015) 

• GCP physical utilization graph implemented on the main Graph menu. 

• zBNA displays a warning message when CP3KEXTR is older than six months. 
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V1.6.5 (07/31/2015) 
There are no function changes in zBNA for this release, however, a mandatory update to some of its 
packaging files was required. 
 
V1.6.4 (06/30/2015) 

• Enhancements made to the load files process. 

• Improvement in recognizing invalid SMF 14 records on input to the zEDC function. 

• zBNA now reports CPU delay data for a specific job. 

• Miscellaneous other enhancements and bug fixes.  
 
V1.6.3 (03/27/2015) 

• An option, Create CSV File – All data, has been added on the File menu allowing all of the zEDC 
data sets to be saved. 

• In the EXTRALL or EXTRZBNA member of the CP3KEXTR program, do not specify a 
DURATION less than 00:05 minutes. 

• Apply SMT defaults (25% for zIIP and IFL is 20%) using Action, Apply IFL/Apply zIIP SMT 
Defaults. Manually input values in the SMT column on the zIIP and/or IFL rows. The % is 
automatically applied; press Enter while the cursor is in the input field. 

• Miscellaneous bug fixes. 
 
V1.6.2 (03/02/2015) 

• Fixed problem with sorting in the columns on the zEDC Top Data Sets panel. 

• Added the Locale to the zBNA saved study file. This feature is supported for version 1.6.2 and 
future ones. 

• Added a new column, Delta DASD Space MB, to the zEDC table to estimate how many MBs won't 
be stored on disc as a result of converting the data set to zEDC. 

• Miscellaneous bug fixes. 
 
V1.6.1 (01/31/2015) 

• Miscellaneous enhancements and bug fixes. 
 
V1.6.0 (01/14/2015) 

• The IBM z Systems (z13) processor family has been added, with 231 General Purpose models 
(90 slugged and 141 full-speed) and 141 IFL models.  Various drawer configurations provide up to 
141 real CPs, which can be configured as General Purpose, zIIP, IFL, or ICF engines.  The 
processor designation is 2964-7xx for full speed models, and 2964-4xx, -5xx, or 6xx for slugged 
models. 

• LSPR data is now based on z/OS-2.1 (formerly z/OS-1.13). 

• Removed the erroneous column in the CSV created on the zEDC Top Data Sets panel. 

• Enhanced the zEDC graph CSV files. 

• Updated the status bar on the zEDC data sets table. 
 
V1.5.1 (12/12/2014) 

• Enhancements made to the “zEDC Top Data Sets” panel include the following. 

− New graph, Data set Gigabytes per Hour, has been added. 

− Added a filter function, Graphing Options, to support what gets graphed. 
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− A checkbox column has been added to the DSN table that allows a data set to be included or 
excluded from the graphs. 

− The status bar has been added at the bottom of the table to show how many DSNs (maximum 
is 1000) there are. 
 

• A total row has been added for each compression type in the zEDC report. 

• A file is created when zBNA detects an error. The default directory where the file is saved is 
C:\Users\IBM_ADMIN\AppData\Roaming\zBNA. 

 
V1.5.0 (10/22/2014) 

• The Job Information panel (Step Details) was updated to look like the regular panels. The panel 
can now be resized. Two menus are added: 
• File, Create CSV File 
• Action, Report 

• Step Details will include a new Proc Step column containing the procedure step name.  Note: 
The data must be extracted using CP3KEXTR dated 10/10/2014 or later. 

• Improvements in load processing to help handle large amounts of data. 

• Fixes to CSV and HTML generation for zEDC 

• Fix to the main table and filters (seconds added where needed) 

• The “zEDC Top Data Sets” panel now shows the estimated I/O Count, I/O time, and CPU Time 
deltas, if the candidate data set would be compressed with zEDC. For current PS and EF data 
sets this panel also allows the user to specify a compression ratio used for the estimate. 

• Added the following zEDC graphs: Projected zEDC CPU Savings, Projected zEDC I/O Count, 
and zEDC Data Set Analysis. 

• Reporting on selection detail of the SMF 14/15s used in the zEDC analysis has been added. 
 
V1.4.6 (08/29/2014) 

• Added the IIP CP Time column on the zBNA main panel. 

• The "Load" function has been enhanced to allow loading different files without exiting zBNA. 

• Updates to the zEDC graph; Generic, Tailored, and zEDC are now supported. 

• Support has been added to load in tersed .dat files. 

• The Find command is now case insensitive. 

• Added the ability to create a CSV file from the zEDC graph. 

• Regular maintenance. 
 
V1.4.5 (05/30/2014) 

• zBNA now allows a job class that is greater than one character. 

• The CSV save function now includes overwrite, append, and cancel options. 

• The "Clear Data" function has been removed from the File menu on the main zBNA panel. 
Enhancements are being made, and the function will be available in 3Q2014. 

• The value in the "Comp Ratio" column in the table on the "zEDC Top Data Sets" graph panel now 
has one decimal place. 

 
V1.4.3 and V1.4.4 (05/01/2014) 

• On entry to the zEDC Compression function, the “zEDC Top Data Sets” panel now displays first. 
Access the graph using the Action menu. 

• Add the RW Ratio and Comp Ratio columns to the table on the “zEDC Top Data Sets” panel. 
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• Add the Compression Type, RW Ratio, and Comp Ratio table on the zEDC graph panel. 

• Add the Block Size column to the table on both the “Job Data Set Report” and “Life of a Data Set” 
panels. 

• Add the IIP CP Time column to the table on the “Job Information” panel. 

• For a selected job on the graph, show the name of the alternate CPU in the tooltip. 

• Fixed a problem to correctly format the EXCP data on the zBNA main panel and in the CSV when 
the value is greater than 1,000. 

• Columns can now be sorted on the “Job Information” panel while keeping the blue highlighted line 
remains on the job. 

 
V1.4.2 (03/17/2014) 

• Add Report to the Action menu on the “Job Data Set Report” panel. 

• Add Report to the Action menu on the “Life of a Data Set” panel. 

• Add Create CSV file to the File menu on the “zEDC Top Data Sets” panel. 

• The check boxes on the “zEDC Top Data Sets” and “zEDC Options” are interchangeable. 

• Corrected the problem with national language and the decimal point not saved correctly in the 
“.zBNA” file. 

• Corrected the problem with the filters not being identified correctly with the report generation. 

• Implemented the support to generate an error file, if zBNA crashes. 
 
V1.4.1 (02/11/2014) 

• The zEDC Compression function has moved to the Action menu. 

• The routine that loads the SMF Type 14/15 records for the zEDC Compression function has been 
significantly improved to only read the input file one time! 

• A cover page has been added to the zBNA report. 

• The Find and Find Next are now available on the Edit menu on several of the zBNA panels that 
contain tables. 

• The ability to generate CSV output has also been added to the File menu on the “Job Data Set 
Report”, “Top 10 Data Sets”, and “Life of a Data Set” panels. 

• Updated the CSV output to contain periods for decimals even in countries where it is a comma 
so that the CSV can be parsed. 

 
V1.4.0 (01/31/2014) 

• zBNA v1.4 requires the new 64-bit IBM CPS Java Runtime Environment v7 

As of this zBNA release, it will only install on a Windows 7 64-bit operating system. Due to the 
large amount of data that can be loaded into zBNA, many users were not able to process their 
files. 

The CPS team surveyed current and prospective zBNA users, and the majority confirmed that 
the requirement to move to the IBM CPS Java v7 64-bit on Windows 7 64-bit is acceptable. 

IBM Employees obtain the IBM CPS Java v7 64-bit by downloading and installing the 
CPSJava64 package (cpsjava64.exe). 

 When the 64-bit CPS Java v7 install is started, detailed instructions will appear as a PDF. 

• Uninstall any previous version (1.3.0 or earlier) of zBNA and CPS Java v6 (CPSJAVA - 
IBM 32-bit Runtime Environment for Java v6) first using Programs and Features. 

• Then install CPS Java v7 64-bit followed by the new CPS Java7 version of zBNA 
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NOTE: All of the other CPS Java-based applications have been upgraded from CPS Java v6 to 
require CPS Java v7. They must be replaced with newly available CPS Java7 versions and the 
32-bit CPS Java v7. 

• Windows Administrator Authority:  It will be necessary to uninstall all of your CPS Java6 
material (Administrator Authority required).  The CPS Java6 registry entries must be deleted 
from “Local Machine” so that the CPS Java7 registry entries can be created under “Current 
User”.  As a result, Administrator Authority will no longer be required to install/uninstall IBM 
CPS Java, zBNA or any other CPS application.  Due to this change, a CPS application and its 
supporting CPS Java must be installed to the same user ID.  CPS applications can only be 
run on the user ID to which it was installed. 

 
V1.3.0 (12/31/2013) 

• IBM zEnterprise Data Compression (zEDC) support is implemented. SMF Record Types 14 and 
15 are required. Invoke the function using the zEDC: Compression menu on the main zBNA 
panel. Use the CP3KEXTR program dated 12/12/13 or later. 

 
V1.2.2 (10/30/2013) 

• Fixed a problem when the service class is defined with multiple periods. 
 
V1.2.1 (09/26/2013) 

• Fixed a problem when adding a graph to the report. 
 
V1.2.0 (09/17/2013) 

• This version requires the CP3KEXTR program dated 09/17/13. Previous .edf and .dat files 
created by CP3KEXTR prior to 09/17/13 will not load in this version of zBNA. Use the updated 
EXTRZBNA JCL to generate the (.edf) and (.dat) data files. 

• Support for DASD data set information; SMF Type 42 subtype 6 records are required.  The SMF 
40 and 30 data are combined in the .dat file. 

• The data is now loaded in two separate steps. 
1. The first, Load Files (Job Level Only), loads the SMF Type 30 Subtype 5 job records only. 

You determine what you’re interested in looking at. Select “Key Batch” box for all jobs that are 
important to you then proceed to set the job thresholds (top program %, GCP time, and 
elapsed time) and define filters such as time, service/report/job class, and account code. This 
will reduce the number of jobs to something more manageable for the analysis. 
Note: These settings can only be manipulated during the first load; they cannot be altered 
once the job step details have been loaded into zBNA. 

2. The second part of the load process is to add the SMF Type 30 Subtype 4 job step records. 
Click File Add Selected Step Level Records→. 

• Support added for “Life of a Data Set”, which is accessible via the DSNs menu on the main 
zBNA panel. 

• The zBNA Filters panel has been enhanced. 
 
V1.1.0 (07/23/2013) 

• The IBM zBC12 processor family has been added. 

• A fix was implemented to correct a problem on the Account Codes filter on the Filters panel. 
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V1.0.0 (04/10/2013) 

• Initial release of the zBNA. 


