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Lab 07 – Advanced Topics 
 

Overview 
 
This tutorial teaches you how to customize the Rational Developer workbench and the RSE perspective. 

Learning objectives 
 
You will be able to customize various aspects of the workbench. 

Skill level and prerequisites 
 
Intermediate. 
 

 

Important! 
 
You should complete RDi Lab01 ‘Getting started’ before you work on this lab.  Lab01 
contains the following information and instructions: 

• Which IBM i server to connect to 
• Which User ID to use 
• How to start RDi, create a connection and connect 
• How to setup the correct library list for this lab 

 
Knowledge of basic Microsoft Windows operations such as working with the desktop, mouse operations 
such as opening folders and drag-and-drop is assumed.  It will also be helpful if you understand DDS and 
ILE RPG. 
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Conventions used in this workbook 
 
Bold font   is used to highlight user interface controls 
Mono-spaced font is used for user input text and code blocks 
Italic font   is used for variable names and glossary terms 
 
The following icons are also used to identify categories of information: 
 

Icon Purpose Explanation 

 
Important! 

This symbol calls attention to a particular step or command. 
For example, it might alert you to type a command carefully 
because it is case sensitive. 

 
Information 

This symbol indicates information that might not be necessary 
to complete a step, but is helpful or good to know. 

 

Trouble-
shooting 

This symbol indicates that you can fix a specific problem by 
completing the associated troubleshooting information. 

 

Client System requirements 
 
The labs require IBM Rational Developer for IBM i (RDi) to be installed on your workstation. If you do 
not yet have this, you can download it for free from http://ibm.biz/rdi_trial. As of version 9.5, RDi 
includes a built-in emulator so you will not need any additional software. If you are using a previous 
version, then any 5250 emulator will work.  The IBM i Access Client Solutions contains a best of breed 
emulator that is freely available to those who have an IBM i that is V6R1 or later. 
 

Host System requirements 
 
The easiest way to ensure you have everything you need, is to use the EM Sandbox demonstration IBM i 
server that is set up and ready to use with these lab exercises.   

 

Tip 
If this is not an instructor led class with PC's provided, you may need to install and setup the 
IBM software on your PC first. 
 
120 day Trial of Rational Developer for i can be downloaded here: 
http://ibm.biz/rdi_trial 
Page to request userid for IBM i demonstration system: 
http://ibm.biz/rdi_labs_getuserid 

The picture can't be displayed.
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1 Customizing the Remote Systems Explorer perspective 
 
This module teaches you how to customize the Remote Systems Explorer perspective.  You will learn 
how to define filters, perform actions and define your own actions.  In short, you’ll see how Remote 
Systems Explorer can organize and integrate your work and make that work easier. 
 
This module also teaches you how to move, re-size or close existing views.  You learn how to open other 
views that you want to add to the perspective.  You then save the customized layout as a new perspective. 
 
Learning objectives 
• Know the features of Remote Systems Explorer 
• Move, dock, rearrange, resize, hide, close, reopen and add views 
• Save and reset a customized perspective 
• Create a filter to show specific libraries 
• Change the filter to add more libraries 
• Create a filter to show all the source files in a library 
• Access members to edit from your filter 
• Create a user action that copies a source file with data to a new source file in the same library 
• Specify user action parameters 
• Specify a restriction on a user action 
• Try the user action 
• Create a user action for jobs 
• Create a user action for IFS folders and files 
• Create your own compile command 
• Edit an existing compile command 
• Use Run configurations 
 
 

1.1 More about Remote Systems Explorer and perspectives 
 
Remote Systems Explorer is an alternative to PDM (Program Development Manager) on the workstation. 
 
Remote Systems Explorer allows you to: 
1. Simplify your work by giving you quick access to lists of IBM i libraries, objects, members, IFS files, 

UNIX® files, and local files. 
2. Use the context-sensitive pop-up menus on these lists to perform actions such as start the Remote 

Systems LPEX Editor, or Integrated IBM i Debugger or other common IBM i actions. 
3. Use the Work with User Actions option to create and manage your own user-defined actions and have 

them appear in the pop-up menus. 
4. Use the command support to increase your productivity by allowing you to enter and repeat IBM i or 

local commands without switching to an emulator session. 
 
Perspectives can be modified to fit your work style.  You can move, resize, or close existing views.  You 
can open other views that you want to add to the perspective. 
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You should have expanded library RSELABxx (xx being your assigned team number if you work with an 
IBM i server supplied by IBM.) 
 

1.2 Move a view 
 
In this exercise you will move the Outline view: 
 
__1.  From the Remote Systems view double-click member MSTDSP in the QDDSSRC source file. 

Choosing No to changing perspective so we stay in Remote Systems Explorer perspective. 
The Remote Systems LPEX Editor opens. 

__2.  In the Remote Systems view, double-click member PAYROLL in the QRPGLESRC source 
file. 
This member will be loaded into the editor as well. Your perspective will look something like: 
 

 
Notice the two tabs in the Editor window. 
Now let’s customize the perspective 

__3.  Click the title bar of the Outline view in the workbench window and drag the view across the 
Workbench window. Do not release the left mouse button yet. 

The picture can't be displayed.
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__4.  While still dragging the view around on top of the workbench window, note that the various 
light grey boxes appear. These light grey boxes indicate where the view will dock in relation to 
the view or editor area underneath the cursor when you release your mouse button.  To see the 
drop cursor change, drag the view over the left, right, top, or bottom border of another view or 
editor. 
 

 
 

__5.  Dock the view in any position in the Workbench window, and view the results of this action. 
 

 
 

__6.  Click and drag the Outline view over one of the tabs in the Remote Systems view.  You will see a 
very subtle green vertical line. 
 

 
 

The picture can't be displayed.

The picture can't be displayed.
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__7.  When you release the mouse button the Outline view will be stacked on top of the Remote 
Systems view. 
 

 
You can rearrange the order of tabs. 
 

__8.  Click on the Outline view tab and drag it left to the Remote Systems view tab.  The subtle green 
vertical line shows where the tab will locate once you release the mouse button. 
 

 
 

__9.  Release the mouse button when the Outline view tab is in the desired location. The view that you 
selected is now moved. 

 

1.3 Resize the outline view 
 
To resize the outline view: 
__1.  To resize the Outline view, select the right border and drag the mouse pointer to the right to 

increase the size of the Outline view. 
 

 
__2.  Click on any of the other tabbed views such as Remote Systems view and you will see this view 

has the same size as the Outline view. 
 

 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.



IBM Software 

Page 10 IBM Rational Developer for i Sandbox – RDi Lab 07 – Advanced Topics 

1.4 Minimize a set of tabs 
 
You can quickly minimize and restore a set of tabs.  
 
__1.  Use the minimize button for a set of tabs. 
__2.  Restore the set of tabs. 
__3.  Note that you can relocate the tool bar for minimized tabs, hover over the 4 dots, once cross 

appears hold down left mouse button to drag the bar around.  It highlights in a green color to 
show where you can drop the bar. 
 

 

 

 
 
 

 

Tip: The bars dock easily to the bottom, left or right of the workbench 
 

 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.
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1.5 Close, reopen and add other views 
 
You can remove views, reopen views and add new views to a perspective. 
 
__1.  To remove the Outline view from the Remote Systems Explorer perspective, click the Close 

icon, the X, in the top right-hand corner of the tab. 
__2.  Reopen the Outline view by clicking Window > Show View > Other. The Show Views dialog 

opens. 
__3.  Expand General and select Outline. 

 

 
 

__4.  Click OK. 
The Outline view opens in the workbench at the location where it resided last. 
You can add views to the perspective.  To add more IBM i views, 

__5.  Click Window > Show View > Other. 

The picture can't be displayed.
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__6.  In the Show View dialog, expand IBM i and choose a view from the list of views, for example 
Job Status. Or type into the Filter field at the top to help find matches for 'Job'. 
 

 
 

__7.  Click OK. 
The Job Status view is added to the perspective. 
 

 
 
Now you know how to add, move, hide, and close views. 
Manipulating the RSE perspective allows you to work with a highly flexible, and customized 
workbench. 
 
You could for example change the perspective so that the editor takes up most of the space, the 
Object Table view resides below the editor and all other views are either closed or moved to the 
bottom as fast views, as shown here: 
 

The picture can't be displayed.

The picture can't be displayed.
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You have customized the Remote Systems Explorer perspective. 

 
 
 

1.6 Saving the perspective 
 
If you have modified a perspective by adding, deleting, or moving (docking) views, you can save your 
changes for future use. 
 

The picture can't be displayed.
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__1.  Click Window > Perspective > Save Perspective As. 
 

 
 

__2.  Type a new name for the perspective into the Name field. 
 

 
 

The picture can't be displayed.
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__3.  Click OK. 
The name of the new perspective is added to the Select Perspective dialog. Try it out and look at 
the Open perspective list by: 

__4.  Window > Perspective > Open Perspective menu then select  
__5.  Other. 

 

 
 
You have saved the perspective and looked at the updated perspective list. 

 

 

Tip: 
You can also make the new perspective the default by selecting Window > Preferences, 
expanding Workbench and then clicking Perspectives.  You then select the new perspective 
and make it the default by clicking Make Default. The next time you open the workbench, this 
will be your default perspective. 

 

1.7 Resetting the perspective 
 
If you have modified a perspective and don’t like the changes that you have made you can reset the 
perspective to its original layout. 
 
__1.  Move some views around in the current perspective 
__2.  Click Window > Perspective > Reset Perspective. The Reset Perspective confirmation 

message dialog appears. 

The picture can't be displayed.

The picture can't be displayed.
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__3.  Click OK. The perspective returns to its original layout. 
__4.  Click Window > Perspective > Open Perspective and select Remote Systems Explorer. 

This opens the default Remote Systems Explorer perspective, ready for the next exercise. 
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2 Expanding files and folders 
 
Typically you start using the Remote Systems Explorer by just expanding libraries to show the objects 
and expanding the source files to show the members. 
 

 

Tip: 
You can also expand the Home directory to see folders in \home in the IFS 

 
Sometimes the lists are too big.  You really want to keep lists small, to a few hundred at most. 
 
One very quick way to reduce the amount of items in a list is to use the Expand To object for libraries.  It 
allows you to expand a library to see only objects of a particular type.  This sub-setting remains in effect, 
even when you expand with the plus sign, until you subsequently choose All or any other expand-to 
criteria. 
 
To expand files and folders: 
__1.  In the Remote Systems view, right-click your library RSELABxx (where xx is your team 

number) 
__2.  Click Expand To > Source Files from the pop-up menu. 

 

 

The picture can't be displayed.

The picture can't be displayed.
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All the source files display. 
 

 
 

__3.  Right-click your RSELABxx (xx being you team number) and click Expand To > Data Files 
on the pop-up menu. All the data files display. 

__4.  Right-click RSELABxx  
__5.  Click Expand To > All on the pop-up menu. 

All the files display. 
 
You have learned how to expand a library to show just the objects of a specific type. 

 

The picture can't be displayed.
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3 Working with filters 
 
Eventually you will find the need to see a subset list.  That is what filters offer and the Remote Systems 
Explorer has extensive filter support.  On each subsystem you can create filters.  In the Objects subsystem 
you can create a library filter, an object filter and a member filter.  In the Commands subsystem you can 
create a command set filter.  In the Jobs subsystem you can create a job filter. In the IFS Files subsystem 
you can create a filter. 
 
You can also use the Work with libraries, Work with objects, and Work with members prompts under 
Objects to create filters. 
 

3.1 Using predefined filters 
 
There are several predefined filters as shown below under the Remote Systems view. 
 

 
 
Now that you have looked at predefined filters you are going to learn how to create a filter. 

The picture can't be displayed.
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3.2 Creating a library filter 
 
In the Remote Systems Explorer perspective, you now need to get to the i5/OS objects you want to work 
with. 
 
In the previous modules you have worked with the Library list.  Now you will create your own library 
filter.  Library filters list a set of libraries from your IBM i system in the Remote Systems view.  But first 
let’s understand what filters are all about. 
 
Filters allow you to easily organize elements within your system.  You use the filter function to list IBM i 
native file system objects (such as libraries, objects, or members). 
 
To create a library filter: 
__1.  In the Remote Systems view expand the connection that connects to your IBM i system if it’s 

not already expanded. 
__2.  Expand Objects if it’s not already expanded. 
__3.  Expand Work with Libraries. (You can also right-click Objects and click New > Library 

Filter on the pop-up menu). 
 
Expanding Work with libraries corresponds to the WRKLIBPDM command, plus creates the 
filter in the Remote Systems view. 
 
The New Library Filter page opens: 
 

 
 
 

The picture can't be displayed.
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Tip: The History button shows past selections you have used.  This button is available on 
many of the workbench dialogs  

 
You are going to create a filter to specify the libraries you want to work with, so they will show 
in subsystem Objects.  You want to create a filter that shows all libraries on the IBM i system 
with the name RSExxxxxx and WFxxxxxxx, xxx being any character. 
 

 

Tip: The New Filter dialog only allows to specify one selection criteria, but in the change filter 
dialog you will be able to specify multiple selection criteria 

 

Note: You may need to select different libraries that appear on your system if libraries 
with the above names do not exist. 

 
You specify the first filter string that selects the libraries starting with RSE. 

__4.  Type RSE* into the Library field, using the * wild card character.  
__5.  Click Next. 

 
The Name the new Filter dialog opens. 
 

 
 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.
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Tip: You can choose between creating the filter for all connections or for this specific one only.  
By default, the filter is created for the selected connection only. 

 
In the Filter name field, type All RSE and WF libraries. 
You give your filters a name because the Remote Systems Explorer saves them for future use, 
unlike PDM, which does not save filters. 

__6.  Click Finish. 
Back in the Remote Systems view under Objects you will see the new filter. 

__7.  Expand it to see the list of all RSE* libraries. 
__8.  Now you need to add the WF libraries. 

To change the library filter: 
__9.  Right-click the filter All RSE and WF libraries and click Change. 

 

 
 
The Change Library Filter window opens. 
 

 
 

__10.  Select New filter string from the Filter strings list. 
__11.  In the Library field, type WF*. 

The picture can't be displayed.
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__12.  Click Create. 
The WF* filter string is added to the list. 

__13.  Click OK. 
You are now back in the Remote Systems view. 
 
You will see the list expanded to include your filter. Now you can work with the libraries directly 
and can drill down to the object you want to work with. 
 
You have created a filter to show specific IBM i libraries and changed that filter to add an 
additional selection criteria. 

 

3.3 Creating an object filter 
 
Now create an object filter. Object filters list a set of objects from your IBM i host in the Remote Systems 
view. 
 
To create an object filter: 
 
__1.  In the Remote Systems view, expand your connection and then expand Objects if not already 

expanded. 
__2.  Expand Work with objects. You can also right-click Objects and click New > Object filter on 

the pop-up menu. 
 

 
Tip: Expanding Work with objects corresponds to the WRKOBJPDM command. 

 
The Create a new object filter page opens. 
Now create a filter to show all your source files in your RSELABxx library. 
 

 
 
 

__3.  In the Library field, type RSELABxx. 

The picture can't be displayed.

The picture can't be displayed.
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__4.  Click Browse beside the Object type field. 
 
The Select Object Type window opens. 
 

 
 

__5.  Select *FILE under the Select an object type list. 
__6.  Click OK. 

The Create a new object filter page displays with the object type updated. 
__7.  Click Browse beside the Object attribute field. 

 

 
 
The Select Object Attribute window opens. 

__8.  Select PF-SRC from the Select an object attribute list. 

The picture can't be displayed.

The picture can't be displayed.
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__9.  Click OK. 
 

 
 
In the New Object Filter dialog: 

__10.  Click the Next button. 
The Name the new Filter dialog opens. 
 

 
 
 

__11.  In the Filter name field, type My source files. 
__12.  Click Finish. 

 
The new object filter displays in the Remote Systems view under Objects. 
 

The picture can't be displayed.

The picture can't be displayed.
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__13.  Expand the filter to display see all source files in your library RSELABxx. 
 

 
 

 

Note:If you end up with too many filters, you can create filter pools. They allow you to group 
filters. You will learn about filter pools later 

 
Now you know how to create filters and tailor your development environment. Filters can also be 
specified for non IBM i servers and your local system. 
From the filters, you can work with the objects you have in your Remote Systems view like you 
worked in PDM with a subset of libraries, objects, or members. 
Let’s assume you want to edit the member PAYROLL in the source file QRPGLESRC using this 
object filter. 
To edit a member from your own object filter: 

(1)  Expand QRPGLESRC. 
(2)  Right-click member PAYROLL. 
(3)  Click Open With > Remote Systems LPEX Editor on the pop-up menu. 

__14.  This will download the source member and open the editor with this member. After you have 
edited the member you could save it and then compile it from the Remote Systems view by using 
the pop-up menu options on this member. You can also create your own actions in addition to the 
default actions. 
You will learn about creating user actions later. 
 
You have created a filter to show all the source files in your library and accessed members to edit 
from your filter. 

 
 

The picture can't be displayed.

The picture can't be displayed.
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4 Working with filter pools 
 
If you have been using the Remote Systems Explorer for some time, your workspace might contain too 
many filters to navigate easily.  Or, you might just want to keep groups of filters separate if, for example, 
you need to represent two distinct IBM i environments in the Remote Systems Explorer, regardless of 
how many filters you have.  In either case, you can group filters into filter pools.  Without filter pools, all 
of your filters appear together either in the specified connection or in all connections. 
 

4.1 Showing filter pools 
 
When you create filter pools, however, any filter you create within that filter pool is distinct to that 
connection, and will not appear in any other connection. 
 
__1.  Create a connection to the same host. (Expand New Connection then IBM i) 

If you don't have a New Connection node , use the New connection button, or right click on the 
blank space in the RSE view and the New Connection action on the context menu. 

__2.  Give your new connection the name IBM i Test System 2. 
 

 

The picture can't be displayed.
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To illustrate the use of filter pools: 

__3.  Click the menu button on the toolbar for the Remote Systems view, and select Show Filter 
Pools. 
 

 
 

__4.  Expand the IBM i Test System connection and the objects sub system. 
Under Objects you can now see the default filter pool with the pre-defined filters and a 
connection specific filter pool which contains your user defined filters. 

The picture can't be displayed.
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__5.  Expand both filter pools. 
 

 
 

4.2 Creating a filter pool 
 
To create a new Filter Pool: 
 
__1.  Right-click Objects and select New > Filter Pool. 

 

 

The picture can't be displayed.

The picture can't be displayed.
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__2.  Enter a pool name and click Finish. (You do not need to change your profile selection.) 
Your new filter pool displays underneath your connection. 
The filter pool is added only to the connection from which it was created. 

__3.  Right-click your new filter pool and select New > Library filter. 
 

 
 

The picture can't be displayed.
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__4.  Complete the wizards as you did before. Use *LAB* as the generic library name for the library 
filter. Give your filter any name you like. 
 

 

 
 



IBM Software 

Page 32 IBM Rational Developer for i Sandbox – RDi Lab 07 – Advanced Topics 

__5.  Click Finish. 
When you are finished, you can see your new library filter displayed underneath the new filter 
pool. 
 

 
 
If you decide not to work with filter pools anymore, click the menu button on the toolbar for the 
Remote Systems view, and select Show Filter Pools again to clear the check mark. 
For each filter pool, you can right-click and select from a number of actions. For example, you 
can rename, copy, move or delete a filter pool. 
You have learned how to group filters into filter pools and how to create a new filter pool. 

 
 

4.3 Sharing filter pools 
 
You can share filter pools among many connections through the use of a filter pool reference.  A filter 
pool reference is a mechanism that displays a filter pool from one connection in any other connection, so 
that when you make a change to the original filter pool, your change is reflected in your filter pool 
reference.  Before you create a filter pool reference, ensure that you have already completed the 
following:  
1. You have defined more than one connection to the same IBM i server. 
2. You have defined more than one filter pool.  
3. You have enabled Show Filter Pools from the Remote Systems view toolbar. 
 
To use filter pool references: 
__1.  Make sure you have another connection established. 

The picture can't be displayed.
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__2.  In the Remote Systems view, expand the IBM i Test System 2 connection where you want to 
display a filter pool that exists in another connection. 
 

 
 

__3.  Right-click Objects and select New > Filter Pool Reference > your profile > pool name. 
__4.  Look under Objects again and you will see the filter pool reference. 

 

 
 
Next, you make a change to the filter pool in order to see that change also occur in the filter pool 
reference. 
Add new object filter called RPGLE. 

The picture can't be displayed.

The picture can't be displayed.
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__5.  Right-click your new filter pool and select New > Object filter. 
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__6.  Complete the wizards. 
When you are finished you will see the referenced filter is available in both connections. 
 

 
 
To delete a filter pool reference: 

The picture can't be displayed.
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__7.  Right-click it and select Remove reference. 
 

 
 
 

__8.  You can also move your filter pools up and down with the pop-up menu. 
 

 
 
You have learned how to share filters. 

 
 

The picture can't be displayed.

The picture can't be displayed.
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5 Working with User Actions 
 
In PDM you can create user actions in addition to using the supplied system actions.  In Remote Systems 
Explorer you can do the same.  
 
You define user actions through the Work With User Actions window.  User actions can be defined for 
IBM i libraries, objects, members and jobs as well as folders and files in any remote UNIX, Windows, 
Linux, Local, or IFS system. 
 

5.1 Creating a User Action 
 
To open the Work with User Actions wizard: 
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__1.  Expand your IBM i connection and expand Objects if not already expanded.  You may need to 
turn off Show Filter Pools to simplify the view. 
 

 
 
 

__2.  Expand the Library list filter if not already expanded. 
__3.  Right-click RSELABxx.  (xx being your team number) 
__4.  Click User Actions > Work with User Actions on the pop-up menu. 

The Work with User Actions window opens. 
__5.  In the left pane of the Work with User Actions window, expand New in the list, if it is not 

expanded already. 

The picture can't be displayed.
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__6.  Select Object action. 
 

 
 
You want to create a user action that copies a source file with data to a new source file called 
QJUNKSRC in the same library. 

__7.  In the Action name field, type Copy source file for the user action name. 
__8.  In the Comment field, type Copy source files with data. 
__9.  In the Command field, type CRTDUPOBJ for the command to execute. 
__10.  Click Prompt to open the command prompter for this command. 

 

 
 
This is the command you will be running: 
CRTDUPOBJ OBJ(&N) FROMLIB(&L) OBJTYPE(&T) NEWOBJ(QJUNKSRC) 
DATA(*YES) 
To specify user action parameters: 

__11.  In the From Object field, type &N to indicate to use the name of the selected object in the 
Remote Systems view. 

The picture can't be displayed.

The picture can't be displayed.
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__12.  In the From Library field, type &L to pick up the library name from the selected object. 
__13.  In the Object Type field, type &T to pick up the object type from the selected object. 
__14.  In the New Object field, type QJUNKSRC. 
__15.  Select the All parameters check box to see the additional Duplicate data parameter. 

Now the Duplicate data parameter is also shown on the prompt window. 
__16.  Select *YES from the Duplicate data list. 
__17.  Click OK. 

 

 
 
You return to the Work with User Actions window. 
 
 

The picture can't be displayed.
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Tip: You can use the Prompt button to enter the variables or you can type the command 
directly and when you type &, you see a pop-up selection list of valid substitution variables with 
an explanation of what they do, or you can use Ctrl+ Space or press the Insert Variables 
button to get the list.  From the list, you can then double click to insert the selected variable, at 
the cursor position. See below a sample of the variable list. 

 

 
 

 
This user action is only valid for Source physical files. You need to specify this restriction so this 
user action will only show in pop-up menus when you right-click on a source physical file. 
 
To specify a restriction on a user action: 

__18.  Under the Defined Types list box, click FILE_SRC 
__19.  Click Add beside the Defined Types list box. 

FILE_SRC is now one of the selected types. Actually since you only selected this one it is the 
only one. 

The picture can't be displayed.
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__20.  Click Create then click Close. 
 

 
 
Now, only when you right-click on a source file, will this user action appear on the pop-up menu. 
For any other object type it will not appear.  Back in the workbench and the Remote Systems 
view, give it a try. 
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Note: Remember to close all the source members if you opened any earlier.  

 
To try a user action: 
You will now work with your filter My source files, this is the filter you created in a previous 
step. 
 

 
 

__21.  Expand the filter My source files, if it is not already expanded. 
__22.  Right-click the QCLSRC file. 
__23.  Click User Actions > Copy source file on the pop-up menu. 
__24.  Right-click My source files and select Refresh.  

Your new source file will show in the list. You can check the messages of the CL commands you 
are running in the RSE communications server job by looking at the Commands log view in the 
bottom right of the workbench. 
 

 
 
 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.
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__25.  Try other objects such as *pgm or *lib. Notice that the user action that you just created is not 
there. 
To delete the source file QJUNKSRC that you just created: 

__26.  Right-click QJUNKSRC. 
 

 
 

__27.  Cick Delete on the pop-up menu. 
The Delete Confirmation dialog opens. 

__28.  Click Delete. 
 
You have created a user action that copies a source file with data to a new source file, specified 
user action parameters, specified restrictions on the user action and tried the user action. 

 

5.2 Creating user actions for jobs 
 
You can also create user actions for Jobs, which will appear in the User Actions popup menu for jobs in 
the Jobs subsystem under a connection.  The substitution variables include variables for the selected job’s 
number, user and name. 
 
To create a job action: 

The picture can't be displayed.
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__1.  In the Remote Systems view, expand your IBM i connection, if it is not already expanded, 
right-click Jobs, and select Work with > User actions. 
 

 
 

__2.  Select New Job action. 
__3.  Type the text to display in the Action name field. For example, ENDJOB. This is a brief label 

for the action. 
__4.  Type a longer, more descriptive text description for the action in the Comment field. For 

example, End Job Immediately. 
__5.  Type the actual workstation or IBM i command string to run when a user selects this action. For 

example: ENDJOB JOB(&IJR/&IJU/&IJN) OPTION(*IMMED). 
 
This command is using substitution variables when you run the action.  These variables are used 
when defining the command string to run for a particular action.  Substitution variables will at 
command execution be replaced with values from the RSE. 
 

__6.  Click Insert variable to view and select valid variables. Here is your completed job action: 

The picture can't be displayed.
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__7.  Click Create then Close. 
 

 
 
Now let’s try this job action that you just created.  For this you will end your own interactive 
5250 session, if you don't have a 5250 session start one by right-clicking the connection and 
select Host Connection Emulator.  Login with your WLABxx userid and wxxxxxx password. If 
you don’t have a built-in Host Connection Emulator, please refer to “Starting a 5250-emulation 
session” in Lab 1 for more information. 
 

__8.  Expand Jobs.  
__9.  Expand My active jobs.  
__10.  Expand QBASE (or QINTER). 
__11.  Right-click you 5250 job (xxxxxx/WLABxx/QPADEVxxxy) 

The picture can't be displayed.
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__12.  Select User actions > ENDJOB from the pop-up menu. 
 

 
 

__13.  Switch to the 5250 session to verify that the job has ended. 
 

 
Tip: Similar to user actions for objects and jobs, you can also create user actions for IFS 

 
You have created a user action for a job let's go on and work with compile commands. 

 
 

The picture can't be displayed.

The picture can't be displayed.
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6 Working with compile commands 
 
In addition to user actions, there is specific support for creating compile commands.  You use the Work 
with Compile Commands window from the Objects subsystem under an IBM i connection to change 
IBM or vendor supplied compile commands or your own compile commands. 
 

6.1 Creating a compile command 
 
To create your own compile command: 
__1.  In the Remote Systems view, from Library list expand your RSELABxx, expand QRPGLESRC 

and right-click PAYROLLG.rpgle. 
__2.  Click Compile (Prompt) > Work with Compile Commands in the pop-up menu. 

 

 
 
 

The picture can't be displayed.
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Tip: You can also work with compile commands from the Compile option (Compile > Work 
with Compile Commands). 

 
The Work with Compile Commands dialog opens. 
 

 
 
New command is already selected for you in the list of commands. 
 

 

Tip: To edit an existing command, first find it by selecting the member type it applies to (or add 
a new member type if necessary) at the top of the Work with Compile Commands dialog, and 
select the command in the list of commands on the left.  Edit the command and apply the 
changes.  You can also right-click on a command to delete it, copy and paste it or re-order it. 
You cannot delete IBM-supplied commands, but after editing them, you can restore them to 
their shipped value. 

 
__3.  In the Label field, type CRTBNDRPG - no debug command. 
__4.  In the Command field, type CRTBNDRPG command. 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.
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__5.  Click Prompt. 
 

 
 
The Create Bound RPG Program (CRTBNDRPG) dialog opens. 

__6.  Change the Debugging Views option to *NONE. 

The picture can't be displayed.
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__7.  Click OK. 
 

 
 
The Work with Compile Commands displays. 

__8.  Click Create to create this new command. 

The picture can't be displayed.
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__9.  Click Close. 
 

 
 

__10.  Right-click PAYROLLG.rpgle. 
 
The new command is added to the list of available compile commands for members of the type 
specified in this command.  The check mark appears beside the last used compile command for 
the selected member’s type. 
 

The picture can't be displayed.
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__11.  Click Compile(Prompt) > CRTBNDRPG - no debug on the pop-up menu and change the 
program name to PAYROLLN. 
 

 

 
The member is compiled and the program object is created. 
Any errors produced by the compile are displayed in the Error List window, where you can 
double-click to open the editor and position it at the error. 
 

The picture can't be displayed.
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__12.  Right-click the program PAYROLLN and click Debug As > Batch.  If you don’t see the program 
PAYROLLN in the list, click the Refresh icon (or press F5) in the Remote Systems view. 
 
An error message displays indicating that PAYROLLN cannot be added to debug since it does 
not have debug data. 
 

 
 
You have created you own compile command, let's look at the Commands subsystem in the RSE. 
 
You may have automatically switched to the Debug Perspective and probably want to switch 
back to the Remote Systems Explorer view (Window / Open Perspective / Other / RSE ). 
 

 
 

The picture can't be displayed.
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7 Working with the Commands subsystem 
 
For some of the frequently used commands, the Commands subsystem provides you with a number of 
predefined command sets. 
 

7.1 Using predefined command sets 
 
You can use these command sets or create new ones of your own. For example, to run the ADDLIBLE 
command set: 
__1.  In the Remote Systems view, expand the Commands subsystem. 
__2.  Right-click Add library to library list and click Change. 

 

 
 
The Change Command Set window opens. 
From here you can now modify the existing command or create a new one. 
 

The picture can't be displayed.
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__3.  Click Cancel. 
 

 
 
 

 

Tip: There is a Preferences dialog that has many preferences which effect substitution 
variables for user actions and compile commands. 
 

 
Let's have a look at the command preferences. 

__4.  Click the  Menu button on the tab for the RSE view and select Preferences 
__5.  Select IBM i.... 

 

 
On the Preferences dialog: 

__6.  Expand IBM i 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.
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__7.  Click Command execution. 
 

 
 
 
You have worked with the Commands subsystem in RSE and know how to change or create IBM 
i commands. 

 

The picture can't be displayed.
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8 Using Run Configurations 
 
If you need to run an application multiple times directly from the RSE, for example for testing, a Run 
Configuration allows you to setup a startup script.  This allows re-use to avoid retyping the same 
commands and parameters again and again.  For example, if you want to run a program that takes a 
number of parameters, you can predefine this information into a named configuration.  
 
Once created, the configuration appears in the configuration list, and can be selected from there.  Every 
configuration defined can be accessed from the pull down menu of the Run tool bar button through the 
Run option. 
 

8.1 Creating a new Run Configuration 
 
To work with the Run Configuration for program CLBATCH: 
__1.  Right-click program CLBATCH in your library RSELABxx (expand Objects / Library List) 
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__2.  Select action Run (Prompt) --> IBM i application in RSE Job..  on the context menu. 
 

 
 
 
The Edit Configuration window opens. 
My program for run (RSE Job) is the default name assigned to a configuration created on the 
fly when you select Run from the pop-up menu of a program. To save a configuration for later 
use, you would change this default name. 

__3.  Change the name of the configuration to CLBATCHRun. 
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__4.  Click the Prompt button. 
 

 
 
The Call Program (CALL) window opens. 
 

__5.  In the Parameters field, type 10. 
__6.  Click the OK button. 

 

 
 
The complete start command for the program appears. 
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__7.  Click the Run button. 
 

 
 
The program runs. Open the Commands Log tab and you should see the output of the program.  
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__8.  This Run Configuration is now the default run when the Run button is pressed. 

 

 
You can edit, delete and create run configurations by clicking the Menu button beside the Run 
icon on the workbench toolbar. 

__9.  Click the Menu button beside the Run button 
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__10.  Select the Run Configurations action from the context menu. 
 

 
 
You can also click Run on the workbench menu and select Run Configurations. 
 

 
 
The Run Launch Configurations window opens. 
 

The picture can't be displayed.



IBM Software 

Page 64 IBM Rational Developer for i Sandbox – RDi Lab 07 – Advanced Topics 

 
Here you can see the CLBATCHRun configuration that you just created.  This is your saved 
configuration to run CLBATCH.  Notice the list of configurations you can choose. 
 
You have created and saved a run configuration. 
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Congratulations! 
 
You have successfully completed the Advanced Topics lab exercises. 
 
We recommend that you move on to the next lab in the sequence; or browse the list of labs on Rational 
Developer for i - Hands-On Labs at http://ibm.biz/rdi_labs to choose a lab of interest. 
 
More information, material and opportunities to discuss the product can be found at our RDi Hub:  
 
http://ibm.biz/rdi_hub 
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Appendix A  Notices 

This information was developed for products and services offered in the U.S.A. 

IBM may not offer the products, services, or features discussed in this document in other countries. 
Consult your local IBM representative for information on the products and services currently available in 
your area. Any reference to an IBM product, program, or service is not intended to state or imply that only 
that IBM product, program, or service may be used. Any functionally equivalent product, program, or 
service that does not infringe any IBM intellectual property right may be used instead. However, it is the 
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter described in this document. 
The furnishing of this document does not grant you any license to these patents. You can send license 
inquiries, in writing, to: 

IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A. 

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property 
Department in your country or send inquiries, in writing, to: 

IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES 
CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in 
certain transactions, therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein; these changes will be incorporated in new editions of the publication. 
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience only and do not in 
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of 
the materials for this IBM product and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you. 

Any performance data contained herein was determined in a controlled environment. Therefore, the 
results obtained in other operating environments may vary significantly. Some measurements may have 
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been made on development-level systems and there is no guarantee that these measurements will be the 
same on generally available systems. Furthermore, some measurements may have been estimated through 
extrapolation. Actual results may vary. Users of this document should verify the applicable data for their 
specific environment. 

Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM 
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those 
products. 

All statements regarding IBM's future direction and intent are subject to change or withdrawal without 
notice, and represent goals and objectives only. 

This information contains examples of data and reports used in daily business operations. To illustrate 
them as completely as possible, the examples include the names of individuals, companies, brands, and 
products. All of these names are fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. All references to fictitious companies or individuals are used 
for illustration purposes only. 

COPYRIGHT LICENSE: 

This information contains sample application programs in source language, which illustrate programming 
techniques on various operating platforms. You may copy, modify, and distribute these sample programs 
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing 
application programs conforming to the application programming interface for the operating platform for 
which the sample programs are written. These examples have not been thoroughly tested under all 
conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these 
programs.
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Appendix B  Trademarks and copyrights 

The following terms are trademarks of International Business Machines Corporation in the United States, 
other countries, or both: 

IBM AIX CICS ClearCase ClearQuest Cloudscape  

Cube Views DB2 developerWorks DRDA IMS IMS/ESA  

Informix Lotus Lotus Workflow MQSeries OmniFind   

Rational Redbooks Red Brick RequisitePro System i   

System z Tivoli WebSphere Workplace System p   

 
Adobe, Acrobat, Portable Document Format (PDF), and PostScript are either registered trademarks or 
trademarks of Adobe Systems Incorporated in the United States, other countries, or both. 

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the United States, other 
countries, or both and is used under license therefrom. 

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both. See Java Guidelines 

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in 
the United States, other countries, or both. 

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, Intel Xeon, 
Intel SpeedStep, Itanium, and Pentium are trademarks or registered trademarks of Intel Corporation or its 
subsidiaries in the United States and other countries. 

UNIX is a registered trademark of The Open Group in the United States and other countries. 

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both. 

ITIL is a registered trademark and a registered community trademark of the Office of Government 
Commerce, and is registered in the U.S. Patent and Trademark Office. 

IT Infrastructure Library is a registered trademark of the Central Computer and Telecommunications 
Agency which is now part of the Office of Government Commerce. 

Other company, product and service names may be trademarks or service marks of others. 
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