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Lab 02f - Maintain an IBM i application using Remote System
Explorer (RSE) to Edit Free-Form RPG source
Overview
This tutorial teaches you how to maintain an IBM i application written in ILE RPG using the Remote
System Explorer.

Learning objectives
Use tools and views in the Remote System Explorer (RSE) perspective to edit, a source member.

Skill level and prerequisites
Introductory.
Important!
You should complete RDi Lab01 ‘Getting started’ before you work on this lab. Lab01
contains the following information and instructions:
• Which IBM i server to connect to
• Which User ID to use
• How to start RDi, create a connection and connect
• How to setup the correct library list for this lab

Knowledge of basic Microsoft Windows operations such as working with the desktop, mouse operations
such as opening folders and drag-and-drop is assumed. It will also be helpful if you understand DDS and
ILE RPG.
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Conventions used in this workbook
Bold font
Mono-spaced font
Italic font

is used to highlight user interface controls
is used for user input text and code blocks
is used for variable names and glossary terms

The following icons are also used to identify categories of information:
Icon

Purpose

Explanation

Important!

This symbol calls attention to a particular step or command.
For example, it might alert you to type a command carefully
because it is case sensitive.

Information

This symbol indicates information that might not be necessary
to complete a step but is helpful or good to know.

Troubleshooting

This symbol indicates that you can fix a specific problem by
completing the associated troubleshooting information.

Client System requirements
The labs require IBM Rational Developer for IBM i (RDi) to be installed on your workstation. If you do
not yet have this, you can download it for free from http://ibm.biz/rdi_trial.

Host System requirements
The easiest way to ensure you have everything you need, is to use the demonstration IBM i server that is
set up and ready to use with these lab exercises. These labs use the RSELABxx library on that system. For
those who want to run these labs on to their own system, you can load a SAVF with the RSELABxx
library from rselabxx.savf.
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1.

Opening source members in the Remote System Explorer

This module teaches you about the Live Parsing eXtensible (LPEX) editor. How to edit source members
and how to navigate through source member.
Learning objectives:
• Open a member for edit from the Table view or the Remote Systems view
• Maximize the editor space
• Open another member for edit
• Switch from one edit session to another edit session
• Open multiple views of the same source member
• Display a structural outline of items defined in a source member

1.1

Getting started with RDi

The information about starting Rational Developer for i (RDi) is described in Lab01 the first of this series of
labs. Please start with the first lab to learn how create a connection to an IBM i system. How to use the
Remote System Explorer View to access IBM i objects. After you went through the exercises in the first
Lab, you are ready to start with this Lab and use the connection to your IBM i system that is available in the
RDi workspace.
Make sure the library list is setup so library RSELABxx, xx being your assigned team number, is part of the
library list.

__1.

Expand library RSELABxx if it is not already expanded

__2.

Expand file QDDSSRC in library RSELABxx
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1.2

Opening a source member

You are going to use the Remote Systems LPEX Editor to edit the member MSTDSP found in
QDDSSRC.
__1.

From the Remote Systems view right-click member MSTDSP in the QDDSSRC source file.
Select to Open With, then Remote Systems LPEX Editor.

The Remote Systems LPEX Editor opens. It is built right into the workbench, with rich editing
functions and is IBM i aware! It is a superset of SEU! The syntax checker is ported from SEU, and the
reference manuals are built-in and F1 cursor sensitive.
__2.
__3.

Double-click the MSTDSP tab to maximize the Editor window.
Double-click the MSTDSP tab again to return the view to its original size.

Tip: To open IBM i™ members quickly, you can use the keyboard shortcut Ctrl+Alt+Q.

1.3

Opening a second source member and multiple views

Next let’s open a second member in the editor.
To open a second source member:
__1.

In the Remote Systems view, double-click member PAYROLLFF in the QRPGLESRC source file.
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You can easily switch between the two edit sessions
__2.

Click on each tab to switch from one edit session to another edit session.

Tip: You can also switch between files that are open in the editor view by pressing CTRL+F6.

You can open multiple views of the same source member while editing in the Remote Systems LPEX
editor. To open multiple views of your RPG source:
__3.
__4.
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Double-click the PAYROLLFF tab in the editor to maximize the Editor window.
Right-click this source in the Editor view and click View > Open new view.
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Tip: You can open a maximum of five views of the same source.

__5.

Right-click in one of the source views and select View > Next view or View > Previous view
to navigate among the views.
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Note:
Any changes made in one of the views will automatically update all other views of the same
source.

__6.
__7.

Scroll down and place the cursor at line 33 in the left view of the Payroll source.
Press End key, then Press Enter.

A new line is inserted in both views.
Define a new integer variable, i with length 10:
__8.

First type in Dc and press Ctrl-Space to see what op-codes are available.

__9.

Select Dcl-S, press Space key and then press Ctrl-Space to find out what comes next

Page 10
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__10.

Enter the name i and a space then press Ctrl-Space to get content assistance on what comes next.

__11.

Select int(digits) and you are prompted to type in the number of digits in between the
parentheses.

__12.

Specify 10 digits and end the free-form statement with a semicolon

Now, in the view on the right, you can start using the new variable while being able to maintain your
view on the left on the definition of the variable.
Another nice feature is the ability to change the way the views split, if you don't like the vertical split
you can specify to split horizontal instead. Let’s try that:
__13.

Right-click a source view and select View > Horizontal split to change from a vertical split
of the views to a horizontal split of the views.
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Here is how your edit view should look now:
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If you want to close the extra views:
__14.
__15.

Right-click the source view that you want to close
(RSELABXX/QRPGLESRC(PAYROLL): 2)
Select View > Close view
Tip:
This option is not available on the first view

You have opened another member for edit and seen multiple views of a member.

1.4

Using the Outline view of a source member

The Outline view acts as an excellent resource when you want to navigate through RPG, COBOL
and DDS source in the Remote Systems LPEX editor. The Outline view displays a structural outline of
items defined in the file that you currently have open in the Remote Systems LPEX editor window.
With the editor active, you can expand the file structure in the Outline view and click various
elements in the view to jump to that location in the source itself.
To see an Outline view of your RPG source:
__1.

Click the PAYROLLFF tab in the editor and take a look at the outline view on its right.

Tip:
If you have closed the Outline view previously, you can reset the perspective by selecting
Window > Reset perspective from the workbench menu or Window > Show view > Other,
then expand General and click Outline in the Show view dialog.

The Outline view contains your source program in a tree view without the lines containing logic.
IBM Rational Developer for i Sandbox – RDi Lab 02f – Freeform RPG source
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Now you want to see more details of your source member.
__2.
__3.
__4.
__5.
__6.

Expand Files.
Expand the MSTDSP workstation file.
Expand the EMPSEL record format.
Expand EMPNO.
Click on any line number in the Outline view.

This will position the source editor accordingly.
Tip:
Clicking a field or a variable in the Outline view will position the editor to its definition.

The lines followed by a (D) mean definitions. Those followed by an M mean a modification reference
and if there is no suffix, then it is a read only reference.
__7.
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Press Ctrl-D to duplicate the line EMPNO = 0;. Notice how the outline view is immediately
updated with the new reference. Press Ctrl-Z to remove the duplicated line. We will discuss
Undo more in the next section.
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__8.

Hover the mouse over the EMPNO
variable for a little while and notice
the hover that appears and shows
the definition of the variable. This
will work for all other references as
well.

__9.

Hold down the Ctrl key and hover over any variable, for example the EMESS variable and it will
appear underlined like a hyperlink. If you click on it at this point, it will take you to the definition
of that variable. This will also work for calls to subroutines and procedures.

__10.

The other buttons on the outline view allow you to sort entries alphabetically, instead of in the
order they appear in the source, as well as collapse all sections. The yellow arrows allow you to
refresh the outline view in case external files have changed and you want to pick up the new set
of records and fields. The final divot brings up a menu that will take you to preferences to
customize your ILE RPG editor behavior.

__11.

Click the PAYROLL tab to get the PAYROLL editor window in focus for the next lesson.

You have displayed an outline of a source member while editing RPG or DDS sources.
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2.

Working with the Remote Systems LPEX editor

This module teaches you how to edit an RPG source member and learn about some of the Remote
Systems LPEX Editor’s language support features.
Learning Objectives
• Change the default settings of the LPEX Editor Parsers
• Change the color settings and font used by the Editor
• Change the default behavior of the Enter key
• Use SEU commands to edit source
• Undo and redo source changes
• View language sensitive help for the MOVE operation code
• View a list of all help contents
• Limit the search of help to specific documents
• Search the help
• Request a prompt for a specification line
• Display context sensitive help for any field in the IBM i Source Prompter
• View the beginning and ending of constructs in your source
• Use the Find and Replace window to search for an item in your source
• Filter or subset your source
• Filter lines based on line type
• Search through members in a source physical file
• Compare different versions of a program and identify the differences
• Syntax check source by line
• View help on syntax errors
• Introducing the LPEX editor
Your program editing tasks are simplified with the Remote Systems LPEX Editor. The editor can access
source files on your workstation or your IBM i system directly. When a compilation results in errors,
you can jump from the compiler messages to an editor containing the source. The editor opens with the
cursor positioned at the offending source statements so that you can correct them.
Here is a list of some of the basic editor features that you would expect in a workstation editor:
• Cut, copy, and paste
• Block marking of lines, characters, or rectangles with copy, move, and delete operations
• Powerful find and replace function
• Unlimited undo and redo
In addition, there are a few more functions that you may not have seen in a workstation editor:
• Token highlighting where different language constructs are highlighted using different colors to help
identify them in a program
• SEU-like format-line rulers to show the purpose of each column for column-sensitive
languages like RPG and DDS. These rulers can automatically update themselves to reflect the
current specification.
• SEU-like specification prompting for CL, RPG, and DDS
• Sequence numbers, which allow SEU-style commands in the prefix area
• Intelligent tabbing between columns for column-sensitive languages
• Automatic uppercasing for languages that expect uppercase
• Settings for column-sensitive languages that simplify text insertions and deletions
• On-line language reference
Page 16
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2.1

Changing default editor settings

The LPEX Editor has predefined settings, but also has an associated preferences page containing settings
that you can modify. The name of the preference category is LPEX Editor and it appears in the left pane
of the Preferences window.
You will change the default settings of LPEX Editor Parsers, Appearance and User Key Actions.
LPEX provides special support for insertion and deletion in column-sensitive languages.
When column-sensitive editing is selected, each column is considered as a separate entry space. For
example, in an RPG source member, if you are inserting into or deleting characters from a string that
is in the Factor 2 entry, the Result field entry does not move. The default editor preference is that
column-sensitive editing is off. You can switch this support on by going to the workbench
preferences window.
2.2

__1.

Autosave while editing source

In the workbench menu, click Window > Preferences from the workbench menu.

The Preferences window opens
In the left pane of the Preferences window, expand Remote Systems.
__2.
__3.
__4.

Select Remote Systems LPEX Editor.
The right pane allows you to set preferences for this feature.
When selected, each column is considered as a separate entry space. To enable or disable
autosave while editing source in the Remote Systems LPEX Editor, select or de-select the
Autosave check box in the preference dialog. By default, autosave is enabled and the value
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for the minutes is set to 5. You can specify a value between 1 and 60 minutes
Click the Apply button.

__5.

Note: The Autosave action will perform a local backup onto the workstation disk. It will not
remotely save the member onto the IBM i server. Use the Save or Save as actions to save the
member back onto the IBM i server.

2.3

Changing the editor appearance

Other interesting preference settings are located under LPEX Editor. You can use the link at the top of the
page to quickly jump to the LPEX Editor preferences. Appearance allows you to modify color settings and
font used by the Editor.
To change the editor appearance:
__1.
In the left pane of the Preferences window, expand LPEX Editor.
__2.
Select Appearance under LPEX Editor
__3.
In the right pane under the Styles list, select formatLine.
__4.
Change the Foreground color to dark green.
Page 18
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Change Font to 12.
Change Background color to light green.
Notice, how your changes are reflected in the sample edit view.

__5.
__6.

To change the current line appearance to make it more visible when editing:
Select currentLine under the Styles list.
This option highlights the line that the cursor is on. The option applies to all source files opened in the
editor area.
__8.
Change the Background color to light yellow.
__9.
If you don’t like the changes you made, you can click Restore Defaults to return to the original
settings.
__7.
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2.4

Changing key behavior in the editor

To modify the default behavior of the Enter key:
__1.
Expand LPEX Editor if not already expanded
__2.
Select User Key Actions.
The LPEX Editor has a predefined behavior for the Enter key to always add a new line and not split the
line when the Enter key is pressed. To change the default behavior for the Enter key to split the line, use
the following instructions.
__3.
Type c-i in the Key field, this means Ctrl-I as shown.
Tip:

The Key and Action fields are case sensitive. Make sure that the values typed in the
Key and Action fields are exactly as shown above.

__4.

Type findSelection in the Action field.

Tip: Use the drop-down list to select the value

__5.
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Click the Set button.
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We go through one other preferences entry that users like to change. When you enter a control opcode
LPEX can automatically indent the subsequent lines a configurable number of blanks and insert the
endxx statement with the capitalization that meets your conventions. In our case, we are using camel
case for our opcodes. Here is how to configure this behavior:
__6.
__7.
__8.
__9.
__10.
__11.
__12.

Expand Remote Systems
Expand Remote Systems LPEX Editor, and then IBM i Parsers
Expand ILE RPG
Click Key Behavior
Change the Automatic closure of control bock style combo box to the camel case option
Click OK on the Preferences window
Return to the Editor window.

Next let’s see the results of the customization.
__12.

Position your cursor around line 53, and double click on the *INKC reference.

__13.

Hold down the Ctrl key and press i.
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This finds the next occurrence of the selected text.
Hit Enter to insert a line, notice that the cursor is indented properly.
Type if *INLR=*off; and press enter

__14.
__15.

Notice how the EndIf is inserted in camel case and the cursor is indented 2 spaces all as specified in the
preferences.
You have changed some of the default editor settings and seen the results of the changes.
Feel free to change the preferences to your preferred settings.
2.5

Using SEU commands in the LPEX editor

You can configure the LPEX Editor to adopt the keyboard and command personalities of many
popular editors. Most editor profiles differ only in the keys and commands used to perform various
editor tasks. Some base editor profiles, listed below, also add prefix information and a command area
at the start of each line:
• ispf
• seu
• xedit
The editor recognizes prefix commands used by these editor profiles. Depending on which profile you
are using, you can enter SEU, XEDIT, or ISPF commands when the prefix area is active.
If you are an SEU expert, you will appreciate the ability to use SEU commands.
To enter SEU commands:
__1.
Move the cursor into the gray sequence number area to the left of the edit area
__2.
On any sequence number type dd.
__3.
Go down a few lines and type dd again and press Enter.
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Notice that the lines have been deleted.
__4.
__5.
__6.

Now type i5 in the sequence number area.
Make sure the cursor is within the sequence number area.
Press Enter.

Five new lines are inserted.
You have learned how to use SEU commands in the editor.
2.6

Requesting undo and redo operations

The editor records each set of changes you make to a file in the Editor window. The number of
changes made since the last file save is displayed on the status line. If you want to undo a set of
changes made to a file you use the Undo operation. You can also cancel the effects of an Undo
operation by using the Redo operation.
Now you are going to undo some of the changes you just made to the file. Then you will cancel the
Undo operation by using the Redo operation. Finally, you will reload the source so that it is back to its
original content.
__1.

Click Edit > Undo from the workbench menu. Notice that the 5 new lines disappear.
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__2.

Press Ctrl+Z to undo the last change.

Notice that the deleted lines reappear.

__3.

Click Edit > Redo from the workbench menu.

Notice that the lines are deleted again.
At this point you will reload the source from the IBM i server to make sure that it is back in its original
form.
__4.
Click File > Close on the workbench menu.
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Tip:

You can also click the X on the PAYROLLFF tab.
The asterisk before a file name in the tab, means there are unsaved changes.

A Save Resource dialog opens asking if you want to save the latest changes.
__5.

Click No

__6.

In the workbench, in the Remote Systems view and open the PAYROLLFF member in the
QRPGLESRC file by double clicking on it.
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You have learned how to undo and redo changes that you made to a file.
2.7

Invoking language sensitive help

Inside the editor, there is cursor-sensitive language-reference help available.
This help is invaluable if you cannot remember the order of fields in an RPG specification or the
allowed values for a variable field. This help is available from the LPEX Editor window.
To receive language sensitive help, press F1 in an Editor window. If the cursor is on an operation
code, you receive help for that operation code; otherwise, you receive help for the current specification.
To access language sensitive help
__1.

Position the cursor over the Dcl-F operation code in line 27 of the ILE RPG source
Tip:
To jump to a specific line, type the number into the editor’s command entry line (the Esc key
will take you there) and press Enter.

__2.
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Press F1.

IBM Rational Developer for i Sandbox – RDi Lab 02f – Freeform RPG source

IBM Software

Language-sensitive help for the DCL-F operation code appears in a Help window.
Text marked in blue in the Help window contains the link to detailed information about the topic in blue.

Click the link USAGE.
The Help page for Date Data Type is displayed
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__3.
__4.
__5.

Explore the Help window to see what else is available.
Close the Help window.
Select Help > Help Contents on the workbench menu

You can see the help that is available in the product.
To locate the language reference information for ILE RPG:
In the left pane of the Help window:
__6.
Expand Rational Developer for i
__7.
Expand Reference.
__8.
Expand Language reference.
__9.
Expand IBM i programming information.
__10. Expand High-level languages.
__11. Expand ILE RPG.
__12. Expand Language Reference.

Having the latest version of the manuals at your fingertips will make it easier to find programming
information. There is also the option to search the help by specifying a search string.
You have accessed language sensitive help
Page 28
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2.8

Finding and replacing text

The LPEX Editor also has a powerful find and replace text feature. You use the Find and Replace
window to search for an item. You can search for a word, a partial word, or a sequence of such. You
can also enter a pattern you want to match, provided that the pattern follows the rules of regular
expression. You can replace the found search item. If the entered text or pattern is found, the cursor
moves to either the next or previous occurrence of the search item, according to your chosen search
direction, and replaces the found text according to your selections.
To find and replace text:
__1.

Click anywhere in the editor to give it focus then press Ctrl+Home to go to the top of the
file.
Tip:
When you press Ctrl+Home to go to the top of a file or Ctrl+End to go to the bottom of a file, a
quick mark is set at your cursor position. This allows you to return to that line by pressing Alt+Q.
Ctrl+Q will set a quick mark.

__2.

Click Edit > Find/Replace from the workbench menu or press Ctrl+F.

The Find/Replace window opens at the bottom of the Editor window
At the bottom of this window, you will notice that you have some options to select from, for example,
search only in certain columns. You want to find the first occurrence of BEGSR.
__3.
__4.

In the Find field, enter BEGSR to find the start of a subroutine.
Make sure the Replace field is blank.

You would use this field for text replacement.
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The Editor moves the active line to line 52, which contains the first BEGSR phrase in the file.
__5.

Page 30

Click Next to go to the next location of BEGSR in the file
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__6.

Click anywhere in the Editor window to close the Find/Replace window.

You have searched for a string in your source using the Find/Replace window.
Next let's do some filtering
2.9

Filtering lines by string

The editor allows you to filter or subset your source so that you see only lines containing a given string.
Filtering lines makes it quick and easy to find lines without having to scroll through your source.
To filter source by string:
__1.
Double-click the variable EMPAPL, on line 56 in the Editor window, to select it.
__2.
Select Edit > Selected > Filter Selection from the workbench menu.
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A compressed source view is shown, it only displays the lines that contain the string EMPAPL. Plus signs
in front of the line numbers allow to expand the source lines following the line containing the string
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The number of occurrences is shown at the bottom of the editor view.
To expand the section of source after line 79 up to the next occurrence of the string:
__3.

Expand line 79.

This expands the section up to the next instance of EMPAPL.
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Now you want to show the entire source again:
__4.

Click Edit > Show all from the workbench menu, or right click in the editor and select
Show all from the context menu, or press Ctrl+W.

The entire source member is displayed again.
You have filtered your source so that you see only lines containing a given string.
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2.10

Filtering lines by type

To help you navigate quickly through your ILE RPG source the editor allows you to filter lines based
on the line type. Imagine you want to see where all the subroutines are defined in your source.
To filter lines by type:
__1.
Right-click in the Editor view for the PAYROLL member.
__2.
Click Filter view > Subroutines in the context menu.

All source lines containing the BEGSR or ENDSR operation codes are displayed allowing you to move
quickly and easily to the desired subroutine in your file.
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__3.

Expand the subroutine declaration for CHGCDE (line 444). to show all lines in this subroutine.

Now you could work with the source inside this subroutine.
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__4.

Right-click in the Editor window and click Show all on the context menu (or hit Ctrl-W) to
show all lines.

You have filtered lines in your source by line type.
2.11

Searching multiple files

If you would like to search through the members in a source physical file or through the files in a
local directory, you can use the Search tool. The Multi-File Search utility allows you to search for a
particular string of text in many members on the host. This function can also be used on local files.
You need to change the current library for your RSE job to your development library, so the results of
the SEARCH are placed in this library and not into the default current library QGPL.
To change the current library:
__1.
In the RSE view, right click
on the Library List filter
__2.
Click on the Change current
library action

__3.

In the Change Current Library dialog
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__4.
__5.

Key in the library name RSELABxx (do not use xx or 99, use your team number)
Click the OK button

You are done setting the current library, RSELABxx now shows a decorator (a little star) that indicates
this is the current library.

To search multiple files:
__6.
Click Search --> IBM i on the workbench menu.

The Search window opens
__7.
In the Search string field, type ENHRS.
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__8.
__9.
__10.
__11.
__12.

Use the drop-down list for Connection and ensure you use your IBM i Test System.
Under Target in the Library field, type RSELABxx. (do not use xx or 99, use your team number)
Under Target in the File field, type QDDSSRC to search all members in this source physical file.
Under Target in the Member field, select *ALL.
Click Search.

The Multi-File Search window lists all the lines in all the files that reference ENHRS.
__13.

Double-click the last line in the list at
A

ENHRS 3 1

TEXT(’EMPLOYEE NORMAL WEEK HOURS’)

The member REFMST is automatically loaded into the editor (it may take a few seconds to load, see
messages at bottom of workbench) and the cursor is placed on the correct line.
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Click the X in the REFMST tab to close the REFMST file.

__14.

You have searched through members in a source physical file.
2.12

Comparing files using the Remote System Explorer

If your code undergoes many changes, you will find the Compare utility useful. It allows you to
compare different versions of a program and find the differences.
Using the compare utility in the workbench you can view the differences between two files by
comparing them. You can compare different files, and you can compare versions in the workbench
with versions in the repository or with the local edit history.
After a comparison is carried out, the Compare Editor opens in the editor area. In the compare Editor,
you can browse through all the differences and copy highlighted differences between the compared
resources. You can save changes to resources that are made in the comparison editor.
Tip:
Make sure all lines show in the source before starting the Compare tool.

We are going to compare the fixed-format version of the PAYROLL member with the free-format version
which is member PAYROLLFF.
Click on the PAYROLL member in source file QRPGLESRC in library RSELABxx (use your
team number, not xx)
To select a second member to compare with:
__2.
Press the CTRL key then select member PAYROLL and PAYROLLFF in the same source file.
__3.
Once both members are highlighted, right click on them for the context menu
__4.
Click the Compare with --> Each other actions on the content menu
__1.
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The compare editor displays, it is best to maximize this view:
__5.

Double-click on the Compare editor tab.
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You see both members side by side, the differences are marked by markers in the right-side bar. The tool
buttons allow you to position to next or previous line with a difference. Scroll up and down to see the
difference between equivalent fixed and free format RPG.
The editor is positioned at the first difference
__6.

To position the editor on the next difference on the next difference button.

It now shows the next line with differences
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To change preferences on the compare, used the context menu by right clicking.
__7.

Right click to see how the compare can be customized
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To close the Compare Editor.
__8.

Click the X on the Editor tab

For a more typical compare
__9.

Compare the PAYROLLFF and PAYROLLFFG members

__10.

Explore the differences between the ‘good’ version of the program PAYROLLFFG and the one
with the bugs, you have yet to fix, PAYROLLFF.
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__11.

Click the X on the Editor tab

Let's have a look at the syntax checker
2.13

Checking syntax

One of the powerful features that the LPEX Editor shares with SEU is its ability to syntax check your
source. Syntax checking can be done either when the cursor leaves each line of source or all at once
on either the currently selected source or on the entire source member.
Now you will create a syntax error and watch for the prompt to correct it. To syntax check the file:
__1.
__2.

In the PAYROLL Editor window move the cursor to line 28 by typing the line number in the
sequence number column or scrolling down.
Add the Oflind(01) keyword to the end before the semicolon ‘;’.

__3.

Move the cursor off the line.

A red annotation appears in front of line 28 and the token in error is underlined.
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__4.

If you hover the cursor over Oflind(01), a hover containing the error message appears.

__5.

Click the link RNF2401 in the error message in the hover.
This opens a window with second level help for the error.

__6.
__7.

Close the Help window.
Remove the Oflind(01) keyword to correct the error. (Alternatively, you can use Edit > Undo
to correct this).
Move the cursor off the line you just fixed.

__8.

The error message is automatically removed from the editor.
Tip:
You can toggle automatic syntax checking. Click Window > Preferences from the workbench
menu and then expand Remote Systems > Remote Systems LPEX Editor > IBM i Parsers.
Now, select the language you want to change the settings for in the left pane of the
Preferences window, select or deselect the Automatic syntax checking check box and then
click OK

Tip:
You can syntax check the whole source member currently in the editor by clicking Source >
Syntax Check All.
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Congratulations!
You have successfully completed the introduction to editing IBM i source members using the LPEX
editor.
We recommend that you move on to the next lab in the sequence; or browse the list of labs on Rational
Developer for i - Hands-On Labs at http://ibm.biz/rdi_labs to choose a lab of interest.
More information, material and opportunities to discuss the product can be found at our RDi Hub:
http://ibm.biz/rdi_hub
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Enjoy working with Rational Developer for i!
Notices
© Copyright IBM Corporation 1992, 2021 All rights reserved.
U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA
ADP Schedule Contract with IBM Corp.
This information was developed for products and services offered in the U.S.A. IBM may not offer
the products, services, or features discussed in this documentation in other countries. Consult your
local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any functionally equivalent
product, program, or service that does not infringe any IBM intellectual property right may be
used instead. However, it is the user’s responsibility to evaluate and verify the operation of any
non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter described in this
documentation. The furnishing of this documentation does not give you any license to these
patents. You can send license inquiries, in writing, to:
IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.
For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual
Property Department in your country or send inquiries, in writing, to:
IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minatoku Tokyo 106, Japan
The following paragraph does not apply to the United Kingdom or any other country
where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS
MACHINES CORPORATION PROVIDES THIS PUBLICATION ″AS IS″ WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF NON-INFRINGEMENT,
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not
allow disclaimer of express or implied warranties in certain transactions, therefore, this statement
may not apply to you.
This information could include technical inaccuracies or typographical errors. Changes are
periodically made to the information herein; these changes will be incorporated in new editions
of the publication. IBM may make improvements and/or changes in the product(s) and/or the
program(s) described in this publication at any time without notice.
Any references in this information to non-IBM Web sites are provided for convenience only and do
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not in any manner serve as an endorsement of those Web sites. The materials at those Web sites
are not part of the materials for this IBM product and use of those Web sites is at your own risk.
Licensees of this program who wish to have information about it for the purpose of enabling: (i)
the exchange of information between independently created programs and other programs
(including this one) and (ii) the mutual use of the information which has been exchanged,
should contact:
Intellectual Property Dept. for WebSphere
Software IBM Corporation
3600 Steeles Ave. East
Markham, Ontario
Canada L3R 9Z7
Such information may be available, subject to appropriate terms and conditions, including in some
cases, payment of a fee.
The licensed program described in this documentation and all licensed material available for it
are provided by IBM under terms of the IBM Customer Agreement, IBM International Program
License Agreement or any equivalent agreement between us.
Any performance data contained herein was determined in a controlled environment. Therefore,
the results obtained in other operating environments may vary significantly. Some measurements
may have been made on development-level systems and there is no guarantee that these
measurements will be the same on generally available systems. Furthermore, some measurements may
have been estimated through extrapolation. Actual results may vary. Users of this document should
verify the applicable data for their specific environment.
Information concerning non-IBM products was obtained from the suppliers of those products,
their published announcements or other publicly available sources. IBM has not tested those
products and cannot confirm the accuracy of performance, compatibility or any other claims
related to non-IBM products. Questions on the capabilities of non-IBM products should be
addressed to the suppliers of those products.
All statements regarding IBM’s future direction or intent are subject to change or withdrawal
without notice, and represent goals and objectives only.
Copyright license
This information contains sample application programs in source language, which illustrates
programming techniques on various operating platforms. You may copy, modify, and distribute
these sample programs in any form without payment to IBM, for the purposes of developing,
using, marketing or distributing application programs conforming to the application
programming interface for the operating platform for which the sample programs are written.
These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot
guarantee or imply reliability, serviceability, or function of these programs.
Each copy or any portion of these sample programs or any derivative work, must include a
copyright notice as follows:
© (your company name) (year). Portions of this code are derived from IBM Corp. Sample
Programs. © Copyright IBM Corp. 1992, 2021. All rights reserved
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Trademarks and service marks
The following terms are trademarks or registered trademarks of International Business
Machines Corporation in the United States, other countries, or both.
• i5/OS
• IBM
• OS/400
• Rational
• WebSphere
Microsoft, Windows, and the Windows logo are trademarks of Microsoft Corporation in the
United States, other countries, or both. Other company, product or service names may be
trademarks or service marks of others.
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