IBM Software

IBM Software

Enterprise Modernization Sandbox for IBM i
Lab Exercise Workbook

Rational Developer for i

Lab 01 – Getting started
This lab shows you how to get connected to an IBM i server using Remote Systems
Explorer (RSE) and how to use that connection to view and work with objects.

Version 7, May 2019

The most up to date version of this document can be found on Rational Developer for i Hands-On Labs at http://ibm.biz/rdi_labs.

©2016 IBM Corporation
IBM Enterprise Modernization Sandbox – RDi Lab 01 – Getting started

Page 1

IBM Software

© Copyright International Business Machines Corporation, 2019. All rights reserved.
US Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with
IBM Corp.

Page 2

IBM Enterprise Modernization Sandbox – RDi Lab 01 – Getting started

IBM Software

LAB 01 – GETTING STARTED..........................................................................................................................4
Overview ...................................................................................................................................................4
Learning objectives .................................................................................................................................4
Skill level and prerequisites ...................................................................................................................4
Conventions used in this workbook ......................................................................................................5
Client System requirements ...................................................................................................................5
Host System requirements .....................................................................................................................5
1 OBTAINING A USER ID FOR THE IBM I DEMONSTRATION SERVER ........................................................6
1.1 Open a browser session and navigate to the User ID allocation page ................................6
1.2 Enter your details and request a User ID ..................................................................................7
2 STARTING RDI AND THE REMOTE SYSTEMS EXPLORER.......................................................................9
2.1 Starting RDi....................................................................................................................................9
2.2 Working with the Remote Systems Explorer perspective ....................................................12
2.2.1 What is a perspective? .......................................................................................................12
2.3 Configuring a connection to the IBM i server and connecting .............................................13
2.3.1 Configuring a connection to an IBM i server ...................................................................13
2.3.2 The RSE subsystems .........................................................................................................17
2.3.3 Connecting to the IBM i server ..........................................................................................17
2.4 Viewing and accessing objects in the Remote Systems Explorer ......................................22
2.4.1 Using the RSE view ............................................................................................................23
2.4.2 Using the Object Table view ..............................................................................................24
2.4.3 Customizing the Object Table view ..................................................................................25
2.4.4 Using the other Table views ..............................................................................................27
3 STARTING A 5250-EMULATION SESSION..............................................................................................29
CONGRATULATIONS! ....................................................................................................................................33
APPENDIX A NOTICES .............................................................................................................................34
APPENDIX B TRADEMARKS AND COPYRIGHTS ........................................................................................36

IBM Enterprise Modernization Sandbox – RDi Lab 01 – Getting started

Page 3

IBM Software

Lab 01 – Getting started
Overview
This lab is the first in a series of labs that introduce Rational Developer for i (RDi). The complete set of
labs show how to edit, compile, debug and sample IBM i application. The labs also show how to use the
RDi Application Diagram Viewer, Screen designer, and Report Designer.
The Labs 02 to 09 depend on the instructions in this Lab 01. You should work through this lab first to
establish a connection to an IBM i server, then it is up to you whether you work on these labs in sequence
or pick one of the labs that you are most interested in.

Learning objectives
Download the Rational Developer for i trial, if you don’t already have it installed.
Start the product and open the Remote Systems Explorer (RSE) perspective.
Use tools and views in this perspective to connect to an IBM® i system.
Work with native IBM i objects using the RSE.

Skill level and prerequisites
Introductory.
You do not need to have completed any prior labs in the sandbox before attempting these exercises.
Knowledge of basic Microsoft Windows operations such as working with the desktop, mouse operations
such as opening folders and drag-and-drop is assumed. It will also be helpful if you understand DDS and
ILE RPG.
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Conventions used in this workbook
Bold font
Mono-spaced font
Italic font

is used to highlight user interface controls
is used for user input text and code blocks
is used for variable names and glossary terms

The following icons are also used to identify categories of information:
Icon

Purpose

Explanation

Important!

This symbol calls attention to a particular step or command.
For example, it might alert you to type a command carefully
because it is case sensitive.

Information

This symbol indicates information that might not be necessary
to complete a step, but is helpful or good to know.

Troubleshooting

This symbol indicates that you can fix a specific problem by
completing the associated troubleshooting information.

Client System requirements
The labs require IBM Rational Developer for IBM i (RDi) to be installed on your workstation. If you do
not yet have this, you can download it for free from http://ibm.biz/rdi_trial. As of version 9.5, RDi
includes a built-in emulator so you will not need any additional software. If you are using a previous
version, then any 5250 emulator will work. The IBM i Access Client Solutions contains a best of breed
emulator that is freely available to those who have an IBM i that is V6R1 or later.

Host System requirements
The easiest way to ensure you have everything you need, is to use the EM Sandbox demonstration IBM i
server that is set up and ready to use with these lab exercises.
Tip

If this is not an instructor led class with PC's provided, you may need to install and setup the
IBM software on your PC first.
120 day Trial of Rational Developer for i can be downloaded here:
http://www.ibm.com/software/products/us/en/dev-ibm-i
Page to request userid for IBM i demonstration system:
http://ibm.biz/rdi_labs_getuserid
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1 Obtaining a User ID for the IBM i demonstration server
This module takes you through the steps needed to allocate your dedicated User ID on the shared
demonstration server for use while you are working on this and other labs in the EM Sandbox.
Once you have successfully allocated a User ID on the demonstration server, this will be dedicated to
your use from the point of allocation until the next reset of the demonstration server occurs. The reset
occurs normally on a weekly frequency, at about midnight on Saturday, Eastern US time. If you allocate
a User ID on Monday, you will normally be able to retain use of that User ID for the entire working week.
If for some reason you cannot obtain a User ID using the process described below, please check the
support forum here and request support from the developerWorks team:
http://ibm.biz/rdi_forum
This forum may also be used for any other question, issue or suggestion about the way the EM Sandbox is
used or accessed.

1.1 Open a browser session and navigate to the User ID allocation page



Launch a browser window. Any browser is supported
Cut and paste, or type in, the following URL:
http://ibm.biz/rdi_labs_getuserid
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You will see a page like this:

1.2 Enter your details and request a User ID



Enter you details in the form: Name, Company, E-mail ID, Phone number and the Labs you
are interested in.
Press the Get User ID button.
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While the request is being processed, you will see an update in the “Result Status” field
like this:



Do not navigate away from this window until the request completes. This may take several
seconds since an environment is being created on the IBM i demonstration server.
The request is complete when you see “ID Assigned” in the “Result Status” field. For
example:





Record the Assigned User ID and corresponding password from the Result Status field:
User ID:
Password:

WLAB____
W________

The User ID will always be of the form WLAB<NN> where NN is a two digit number (with
a leading zero if below 10). The Password will be of the form W<NN><xxxx> where NN is
the same two digit number in the corresponding User ID, and “xxxx” is a random
component.
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This User ID is normally yours to use for the remaining duration of the week. You will need
to reference this multiple times during all of the lab exercises. Keep a record of it handy.
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2 Starting RDi and the Remote Systems Explorer
This module teaches you about the workbench, the workspace, a perspective and specifically the Remote
Systems Explorer perspective.

2.1 Starting RDi
First you must start RDi. Follow these steps:




Click the Start button on the task bar of your desktop.
Select All Programs > IBM Software Delivery Platform > IBM Rational Developer for i
V9.x > IBM Rational Developer for i
During initialization, a “splash screen” is displayed while RDi loads plugins and gets ready
for use. You may see different product names displayed if you have a different configuration
of products installed.
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By default, the first time you launch RDi, a welcome screen is displayed:

You may also briefly see some other activity related to initialization, for example a check of
license status.
Tip
To open the Welcome page again, select Help > Welcome.
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If the Welcome Overview is not displayed, select Help > Welcome
Click to expand the RPG and COBOL Development Tools for i section.
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Select any of the entries and explore the topic.



When you are done, click the X next to the Welcome tab to close the Welcome page.
Closing the Welcome page will take you to the Remote Systems Explorer perspective.
Click the maximize button to maximize the workbench if it is not already full screen.



You have started the product and opened the workbench. The workbench refers to the desktop
development environment. The workbench aims to achieve seamless tool integration and
controlled openness by providing a common paradigm for the creation, management, and
navigation of workbench resources. Each workbench window contains one or more views and
an editor.
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2.2 Working with the Remote Systems Explorer perspective
If you are not sure which perspective is open at the moment, you can check for the name of the
perspective in the workbench title bar.

2.2.1 What is a perspective?
A perspective defines the initial set and layout of views in the workbench window. Within the
window, each perspective shares the same set of editors. Each perspective provides a set of
capabilities aimed at accomplishing a specific type of task or working with specific types of resources.
For example, the JavaTM perspective combines views that you would commonly use while editing Java
source files, while the Debug perspective contains views that you would use while debugging a
program. Perspectives contain views and editors and control what appears in certain menus and tool
bars.
If you see a different perspective, not the Remote Systems Explorer open in the workbench, or no
perspective, follow these steps:

Page 12

IBM Enterprise Modernization Sandbox – RDi Lab 01 – Getting started

IBM Software



Click Window > Open Perspective > Remote Systems Explorer from the workbench
menu

The Remote Systems Explorer perspective opens.
You work in the Remote Systems Explorer perspective in the workbench. This perspective is for IBM i
developers. You can display the connections that you have already configured, create a new connection,
connect to and disconnect from the connections that you have defined, work with IBM i files, commands,
jobs, and integrated file system files.
This perspective will be active when you start the product with a new workspace. If you had used the
workspace before then, the workbench would come up with the perspective that you last opened. You
will learn more about the Remote System Explorer perspective in the coming exercises as this is where
you launch the IBM i developer tools and use the views from the workbench.
In general, the term workspace refers to the local storage for the workbench on your workstation. The
workspace holds local copies of files you are working on, the current state of the workbench as well as
preferences and configuration settings you have established for your workbench.

2.3 Configuring a connection to the IBM i server and connecting
This module teaches you how to create a connection to an IBM i server, find a library in your library list,
select objects from a library and finally open a member in the Remote Systems LPEX Editor. You also
learn about several views such as the Remote Systems view, IBM i Table view, and the Outline view.

2.3.1 Configuring a connection to an IBM i server
When you first open the Remote Systems Explorer, you are not connected to any system except your local
hard drive on your workstation. To connect to a remote system, you need to define a connection. When
you define a connection, you specify the name or IP address of the remote system and you give your
connection a unique name that acts as a label in your workspace so that you can easily connect and
disconnect. When you connect to the remote system, the workbench prompts you for your user ID and
password on that host.
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All connections, filters, and filter pools belong to a parent profile. Filters are described in a later lesson.
Profiles are discussed when you create your first connection. Remember you have already opened the
Remote Systems Explorer perspective in the previous module.
In the Remote Systems view:
__1.

Click to the left of New Connection to expand if it is not already expanded to show the various
remote systems types you can connect to through the Remote Systems Explorer.

Troubleshooting
If you don't have a New connection node, use the
New connection button to create the connection.

__2.

Double-click IBM i to configure a connection to a remote system.
The Remote IBM i System Connection page opens.
Here you specify the information for your connection. The Parent profile defaults to the name of
the workstation. Your profile will be different from the one shown here.
The cursor on this page is positioned in the Host name field.
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__3.

In the Host name field, type the IP address or the fully qualified hostname of your IBM i
server.
Connection Host name information:
If you use the IBM i server on the internet, use: embox1.demos.ibm.com as the
Host name. If you use your own IBM i server use that server name.

The Connection name is automatically filled with the host name. You can leave it as is, or you
might want to change it – for example “IBM i demonstration server”. This name displays in
your Remote Systems view and must be unique to the profile.
__4.
__5.

Leave the Parent profile default value. You don’t need to change it.
Make sure the Verify host name check box is selected.
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__6.

Click Finish to create the connection to the IBM i server.

A connection node for the IBM i server appears in the Remote Systems view:
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2.3.2 The RSE subsystems
After you configure a connection to an IBM i system, you can easily connect and expand your new
connection to show the subsystems. Subsystems are pre-defined filters grouping the various types of
remote resources that can be explored in the remote system. There are four subsystems.
•
•

•

•

Objects
A PDM-like group, allowing access to libraries, objects and members.
Commands
Contains predefined commands and allows you to create command sets each of which contain one or
more often used commands. When run, all commands in a command set are sent to the remote system
and executed, and the results are displayed in the Commands log view.
Jobs
Allows you to see various jobs, subset by job attributes, and to perform a number of operations on
those jobs.
IFS Files
Allows you to explore folders and files in the Integrated File System of the remote IBM i system.

2.3.3 Connecting to the IBM i server
Although you have a connection node for the server you specified in the previous step, RSE is not yet
connected to the server. RSE creates and manages connections when they are needed. In this step you
will cause a connection to be created by accessing some objects in the connection node.
__1.

Click to the left of your system name to expand the embox1.demos.ibm.com connection.
In the Remote Systems view, your new connection is expanded to reveal your subsystems. The
Objects subsystem is the subsystem you will use most often! It is very similar to PDM, in that
it allows you to access objects in the QSYS file system, and perform actions on those objects.
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Click to the left of Objects to expand that subsystem.

__2.

Notice the first three entries under the Objects subsystem are named after the PDM options,
because they have similar capabilities.
__a. Work with libraries (similar to WRKLIBPDM)
__b. Work with objects (similar to WRKOBJPDM)
__c. Work with members (similar to WRKMBRPDM)
In addition there are entries for working with library lists and user libraries:
__d. Library list (to simulate PDM’s WRKLIBPDM you can start with the pre-defined
Library list filter, that when expanded lists all libraries in your library list.)
__e. User libraries (allows you to work with all user libraries you can access on that server.)
__3.

You also have more entries to work with under the connection itself and you can see from these
entries that Remote Systems Explorer goes well beyond PDM! It allows you to explore IBM i
jobs and commands and the IFS file system.
Now let’s work with a library in your library list and add the library that you’ll be using in this
tutorial:
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__4.

Right-click Objects and click Properties on the pop-up menu. The Properties for Objects
dialog displays.

__5.
__6.

Select Initial Library List on the left pane.
In the Library field, type RSELABxx where xx is the number component of your User ID. (Do not
use “xx” or “99”).
Click Add.

__7.
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__8.

Click OK.

This will add the library RSELABxx to your library list every time you open this connection.
You can use the properties of any of the subsystems to set connection information such as
adding a library to the library list.

Tip:
You can also change your library list using the pop-up menu items Add Library List
Entry or Change Current Library on the Library list folder in the Objects subsystem.
These changes are only valid for the current active connection, until you disconnect.
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__9.

Expand the Library list folder.

__10.

Now the connection will be activated and you will be prompted for User ID and password.
Use your allocated User ID (not WLAB99 or the example shown here) and the password you
obtained when it was allocated. Select the Save user ID check box. Select the Save
password check box.

IBM Enterprise Modernization Sandbox – RDi Lab 01 – Getting started

Page 21

IBM Software

__11.

Click OK.
Back in the Remote Systems view, you will see the libraries in your job’s library list appear
instead of the word “Pending…”

Notice that the connection node now has a small green arrow in the icon to indicate that it is an
active connection.
For each library, you can right-click and select from a number of actions. For example, there is
an action to create a new source file within the selected library. Common actions like delete,
move, copy, etc. are valid for all kinds of objects.
You have connected to an IBM i server and used the Remote Systems view to view libraries in
the library list.

2.4 Viewing and accessing objects in the Remote Systems Explorer
Now you are ready to view and access objects in your user library RSELABxx.
Tip:
Remember that the xx in RSELABxx represents your assigned User ID number. For
example, if you were allocated User ID WLAB09 use library RSELAB09 when
RSELABxx is mentioned in these workbooks.
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2.4.1 Using the RSE view
To view and access an object,
__1.

Expand your assigned user library RSELABxx (where xx is your User ID number) by clicking to
the left of it.
You will see all objects in this library appear in the Remote Systems view. For each object you
can right-click and select from a number of actions. The list of actions depends on the object
selected and whether you selected one or multiple objects. For example, for a source file the
pop-up menu has an action to create a new member within the selected file.

__2.
__3.

Scroll-down through the files in the Remote Systems view until you find QDDSSRC source file
and expand it.
Still in the Remote Systems view, locate QRPGLESRC source file and expand it as well.

Now you can see and access the members in these two source files. For each member you can
right-click and select from a number of actions. The exact list of actions depends on whether
IBM Enterprise Modernization Sandbox – RDi Lab 01 – Getting started
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the member is a data file or source file and whether you select one or multiple members. For
an RPG source member, the pop-up menu actions include:
__a.
Open with
__b.
Browse with
__c.
Verify
__d.
Compile

2.4.2 Using the Object Table view
Before you go ahead and work with these members, let’s see the members in the Object Table view as
well because that is similar to the view you are used to from PDM. You use this view to display a list of
items, for example members or objects, in a table format similar to PDM. You can also perform actions
against these items such as editing and compiling.
__1.

Right-click the QDDSSRC file and then click Show in Table on the pop-up menu.
The Object Table view takes the selected object in the Remote Systems view as input, and
displays the contents in the table. For source physical files, this step displays the members
inside, their names, types, attributes, and text descriptions.

The top of the Object Table view contains a lock icon that controls the correlation between the
Remote Systems view and the Object Table view. If the lock is disabled then whenever
you click an object or library in the Remote Systems view, the associated contents of that
item automatically populate the Object Table view. If the lock is enabled then when you click
on various items in the Remote Systems view, this view does not change the content of the
Object Table view. To enable or disable the lock, you can click it once to change its state.
You can click on the columns heading to sort the view by column.
Page 24
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__2.

In the Object Table view toolbar make sure the lock/unlock button is in the unlock position.
Leave the mouse pointer over the tool button for a second or two to display the flyover help.
That way you can check if the view is locked or unlocked.
This means now the table will automatically be updated when a different object is selected in
the Remote Systems view. This is a shortcut to open the pop-up menu for an object in the
Remote Systems view and to select Show in Table.

2.4.3 Customizing the Object Table view
You can also modify which specific columns you want to see in the Object Table view.
To modify the Object Table properties:
__1.

Click Window > Preferences from the workbench menu.
The Preferences Window opens.

__2.

In the left pane of the Preferences window, expand Remote Systems.

__3.

Expand IBM i under Remote Systems.

__4.

Click Table View under IBM i.

__5.

In the right pane of the Preferences window, select Last modified in the Available columns list

__6.

Click the Add button.
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__7.

Click OK.

Now let’s update the Object Table view.
__8.
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Click the View Menu button on the Object Table view title bar.
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__9.

Click Show columns > Customized in the pop-up menu.
Now see the extra column that you’ve added.

You can also sort the objects in the Object Table view by column.
__10.

__11.

Click any of the column headings, for example Name.
The order of the members changes as they are sorted in alphabetical order of Name.
You can click on the Name heading again to sort in reverse alphabetical order.
Select QRPGLESRC in the RSE navigation view to see a different set of objects.
The Object Table view is updated to show the members in QRPGLESRC.

Besides the Object Table view, there are also a Field Table view and a Data Table view. For a
selected data file, the Field Table view shows which fields are defined in the file and their
properties. The Data Table view displays the data contained in the file.

2.4.4 Using the other Table views
To display the other Table views:
__1.

In the Remote Systems view in library RSELABxx, right-click PRJMST object and select Show
in Table > Fields.
Make sure you click on the Physical File object in the library, not the member in QDDSSRC.
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The Field view table opens:

To display the Data Table view:
__2.

Page 28

In the Remote Systems view, right-click PRJMST again, select Show in Table > Data.
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3 Starting a 5250-emulation session
This module teaches you about how to start a 5250 green screen emulation session.
__1.

Starting in version 9.5 of Rational Developer for I and up to version 9.6.0.10, you can use the
built-in Host Connection Emulator.
If you are using a previous version, than any 5250 emulator will work. The IBM i Access Client
Solutions contains a best of breed emulator that is freely available to those who have an IBM i
that is V6R1 or later.
If you are using version 9.6.0.11 or later, you will need to open the 5250 emulator via a different
button shown below.
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To start the Host Connection Emulator on versions 9.6.0.11 and later, in the Remote Systems
view, right click on the Objects heading under your remote system and select Launch 5250
Emulator.
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To start the Host Connection Emulator on versions 9.5 to 9.6.0.10, in the Remote Systems view,
right click on the IBM i connection name and select Host Connection Emulator.
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__2.
__3.
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Sign-on to the server with your User ID and password. (use your allocated User ID: WLABnn,
and Password: Wnnxxxx – where nn is your User ID number)
You can enter a command or selection in the command line.
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Congratulations!
You have successfully completed the RDi Lab 01 – Getting Started lab exercises.
We recommend that you move on to the next lab in the sequence; or browse the list of labs on Rational
Developer for i - Hands-On Labs at http://ibm.biz/rdi_labs to choose a lab of interest.
More information, material and opportunities to discuss the product can be found at our RDi Hub:
http://ibm.biz/rdi_hub
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Appendix A Notices
This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that only
that IBM product, program, or service may be used. Any functionally equivalent product, program, or
service that does not infringe any IBM intellectual property right may be used instead. However, it is the
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter described in this document.
The furnishing of this document does not grant you any license to these patents. You can send license
inquiries, in writing, to:
IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.
For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:
IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan
The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES
CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.
This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.
IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.
Any performance data contained herein was determined in a controlled environment. Therefore, the
results obtained in other operating environments may vary significantly. Some measurements may have
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been made on development-level systems and there is no guarantee that these measurements will be the
same on generally available systems. Furthermore, some measurements may have been estimated through
extrapolation. Actual results may vary. Users of this document should verify the applicable data for their
specific environment.
Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those
products.
All statements regarding IBM's future direction and intent are subject to change or withdrawal without
notice, and represent goals and objectives only.
This information contains examples of data and reports used in daily business operations. To illustrate
them as completely as possible, the examples include the names of individuals, companies, brands, and
products. All of these names are fictitious and any similarity to the names and addresses used by an actual
business enterprise is entirely coincidental. All references to fictitious companies or individuals are used
for illustration purposes only.
COPYRIGHT LICENSE:
This information contains sample application programs in source language, which illustrate programming
techniques on various operating platforms. You may copy, modify, and distribute these sample programs
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the operating platform for
which the sample programs are written. These examples have not been thoroughly tested under all
conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these
programs.
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Appendix B Trademarks and copyrights
The following terms are trademarks of International Business Machines Corporation in the United States,
other countries, or both:
IBM

AIX

CICS

ClearCase

ClearQuest

Cloudscape

Cube Views

DB2

developerWorks

DRDA

IMS

IMS/ESA

Informix

Lotus

Lotus Workflow

MQSeries

OmniFind

Rational

Redbooks

Red Brick

RequisitePro

System i

System z

Tivoli

WebSphere

Workplace

System p

Adobe, Acrobat, Portable Document Format (PDF), and PostScript are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States, other countries, or both.
Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the United States, other
countries, or both and is used under license therefrom.
Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United
States, other countries, or both. See Java Guidelines
Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in
the United States, other countries, or both.
Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, Intel Xeon,
Intel SpeedStep, Itanium, and Pentium are trademarks or registered trademarks of Intel Corporation or its
subsidiaries in the United States and other countries.
UNIX is a registered trademark of The Open Group in the United States and other countries.
Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.
ITIL is a registered trademark and a registered community trademark of the Office of Government
Commerce, and is registered in the U.S. Patent and Trademark Office.
IT Infrastructure Library is a registered trademark of the Central Computer and Telecommunications
Agency which is now part of the Office of Government Commerce.
Other company, product and service names may be trademarks or service marks of others.
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The information contained in these materials is provided for
informational purposes only, and is provided AS IS without
warranty of any kind, express or implied. IBM shall not be
responsible for any damages arising out of the use of, or otherwise
related to, these materials. Nothing contained in these materials is
intended to, nor shall have the effect of, creating any warranties or
representations from IBM or its suppliers or licensors, or altering
the terms and conditions of the applicable license agreement
governing the use of IBM software. References in these materials
to IBM products, programs, or services do not imply that they will
be available in all countries in which IBM operates. This
information is based on current IBM product plans and strategy,
which are subject to change by IBM without notice. Product
release dates and/or capabilities referenced in these materials may
change at any time at IBM’s sole discretion based on market
opportunities or other factors, and are not intended to be a
commitment to future product or feature availability in any way.
IBM, the IBM logo and ibm.com are trademarks or registered
trademarks of International Business Machines Corporation in the
United States, other countries, or both. If these and other IBM
trademarked terms are marked on their first occurrence in this
information with a trademark symbol (® or ™), these symbols
indicate U.S. registered or common law trademarks owned by IBM
at the time this information was published. Such trademarks may
also be registered or common law trademarks in other countries. A
current list of IBM trademarks is available on the Web at
“Copyright and trademark information” at
ibm.com/legal/copytrade.shtml
Other company, product and service names may be trademarks or
service marks of others.
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