Troubleshooting
Problem
When a user runs a 'standard report' (also known as 'system report') they are displayed (by default) in HTML format. HTML reports do not show any controls which the end-user can use to save or print the report. Therefore, users may prefer to see the report as a PDF file which gives them these controls. Are there any tips and tricks for end users to work smarter with these reports? How can the end user change the default standard report format?
Symptom
.
Cause
Controller system reports can give their output as HTML, PDF or XLS. By design, Controller only displays it in HTML initially. This is because HTML is before PDF (and PDF is before XLS) *alphabetically*.
Resolving The Problem
Tips:
- It is possible to print from the (initial) HTML report directly, rather than changing to PDF and printing from here. To do this, the end-user can click CTRL-P on their keyboard
- To ensure that the PDF system renders the report as intended, ensure that Adobe Acrobat Reader is configured to display the system report in the Internet Explorer window.
- It is possible to change the order of report generation, so that (for example) PDF generates/displays (first / by default). This is done by a local preference 'StandardReportPreviewFormat'
Steps:
(2) To ensure that the PDF system renders the report as intended:
- On the client, launch 'Adobe Acrobat Reader'
- Click on 'Edit' - 'preferences'
- Select 'Internet'
- Tick the box "Display PDF in browser"
(3) To change the order of report generation:
The following must be done on a per-user basis:
- Launch Controller
- Click 'Maintain - Installation - Local Preferences
- Add a new key called 'StandardReportPreviewFormat', with a value of either 'html' or 'pdf' or 'xls' or 'xml'
- Click 'save'
Related Information
Historical Number
1031733
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Document Information
Modified date:
15 June 2018
UID
swg21346959