Troubleshooting
Problem
Since the support for WebSphere Interchange Server 4.3 and Adapter Framework 2.6 is longer than that of WebSphere MQ 5.3 and MQ 6.0, the clients are wondering if the support for WebSphere MQ 5.3 and MQ 6.0 will be extended.
Cause
End of service dates for WebSphere Interchange Server 4.3 and Adapter Framework 2.6 are later than the those for WebSphere MQ 5.3 and MQ 6
Resolving The Problem
The end of service (EOS) dates for WebSphere MQ, WebSphere Interchange Server, and Adapter Framework are available at the following site:
http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg21182185
(select option "W")
- WebSphere MQ 5.3 on most platforms went out of support on 28 Sep 2007
- WebSphere MQ 5.3 on zOS went out of support on 31 Oct 2005
- WebSphere MQ 6.0 on most platforms will go out of support on 30 Sep 2011
More information refer: WebSphere MQ Support Life Cycle
- WebSphere InterChange Server 4.2.2 and WebSphere 2.4 went out of support on 30 Apr 2007
- WebSphere InterChange Server 4.3 and Adapter Framework 2.6 do not yet have an EOS date.
More information refer:
http://www.ibm.com/software/support/lifecycleapp/PLCSearch.wss?q=websphere+interchange+server&scope=S962652E67398D77-X007925I73652A47&ibm-search.x=-1199&ibm-search.y=-340&ibm-search=Search&sort=P
The WebSphere MQ support team has an agreement with the WebSphere Interchange Server and Adapter Framework support that WebSphere MQ 5.3 and MQ 6.0 will be supported for usage with WebSphere Interchange Server and Adapter Framework with respect to the following guidelines for support requirements( beyond first 5 years of GA i.e. after Sep 2011 ):
- “Strongly encourage” clients to use the latest refreshed versions of included products. Refer the following technote for more information on the latest refresh bundle for WebSphere InterChange Server 4.3: http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg21416857
- By Sep 2010, users of WebSphere MQ 5.3 need to be on its latest fixpack level.
- After Sep 2011, users of WebSphere MQ 5.3 will receive only “Usage/Known defect support“ on WebSphere MQ 5.3 and ONLY until the end of life of Interchange Server 4.3 and Adapter Framework 2.6, respectively.
Users running WebSphere MQ 5.3 and MQ 6.0 for any other purpose after its EOS date, as a stand-alone product or on the application side of the WBI Adapter for MQ or JMS, will not be supported and will need to upgrade to an in service version of WebSphere MQ.
In general, it is recommended to upgrade to the latest CSD levels of WebSphere MQ that are compatible with the Adapter Framework 2.6.x and Interchange Server 4.3.x.
Please refer to the List of Supported Software for the most current list of currency certifications for WebSphere InterChange Server 4.3:
http://www-1.ibm.com/support/docview.wss?rs=693&context=SSBTEG&uid=swg27006396
For details on the latest recommended WebSphere MQ 5.3 CSD levels and MQ 6 fixpacks, please refer to below useful links:
1) Compatibility Matrix: WebSphere Business Integration Adapters and WebSphere Adapters (JCA)
http://www-1.ibm.com/support/docview.wss?uid=swg21252626
2) WebSphere Business Integration Adapter Framework 2.6.0.x
http://www-01.ibm.com/support/docview.wss?uid=swg21271602
describe the requirements which Adapter Framework fixpack 2.6.0.x is
needed on base of a certain MQ 5.3 or MQ 6.0 CSD fixpack level.
3) Adapter for mySAP.com, Version 6.0.9 Fix Pack
http://www-1.ibm.com/support/docview.wss?uid=swg24012767
refers to the support of WebSphere MQ 6.0, but not to a specific MQ 5.3 fixpack.
4) WebSphere Business Integration Adapter for WebSphere MQ, Version 2.8.2 Fix Pack
http://www-1.ibm.com/support/docview.wss?uid=swg24011989
does not mention a particular fixpack for MQ 5.3 or MQ 6.0 on the application side even though the upgrade to the latest fixpack level is recommended as far as possible.
As far as support extensions for WebSphere Interchange Server 4.2.2 or Adapter Framework 2.4 are concerned, the client is recommended to discuss the details of pricing for support of MQ 5.3 with the IBM sales representative.
Concerning the planning of the specific client's system landscape, the client is advised to involve IBM consulting services.
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Document Information
Modified date:
15 June 2018
UID
swg21316435