IBM Support

Superuser Unable to Access Security Applications

Troubleshooting


Problem

After upgrading to or performing a fresh installation of MAS 9.1, and logging in as the superuser (with no apparent errors during installation or upgrade), the Security applications are missing from the left-hand navigation menu.

As a result, it's currently not possible to create or manage users.

Symptom

Security applications are missing from the left-hand navigation menu.
image-20250813171121-1

Cause

The cause of this issue is a known bug DT448438.
It only happens when ALL bundle is used.
MAS core expects the deployment name to be ALL, If it is changed, the service will not be created.

Diagnosing The Problem

Log in Openshift console. 
Go to MAS core project and search for "coreapi" pods.
Search in the logs for the "WARNING Cannot verify Manage Foundation installation"
2025-08-12 17:05:00,822   mas.utils.authservice.authserviceUtil  WARNING  Cannot verify Manage Foundation installation. HTTPSConnectionPool(host='max-dev-main-foundation.mas-max-dev-manage.svc', port=443): Max retries exceeded with url: /maximo/api/ping (Caused by NameResolutionError("<urllib3.connection.HTTPSConnection object at 0x7fd994f4ef90>: Failed to resolve 'max-dev-main-foundation.mas-max-dev-manage.svc' ([Errno -2] No address found)"))
The cause of the warning is that service max-dev-main-foundation.mas-max-dev-manage.svc was not found. This service is required to mount the navigation menu properly. 

Resolving The Problem

A workaround for this bug is to remove the (1) custom name used in deployment and set ALL or (2) manually create the missing service.
(1)To change the deployment, you can follow the document below:
(2) If you can't change your deployment name you have option to create service below:
YAML below can be used as a reference, replace all environment details.
{{ instanceId }}
{{ workspaceId }}
{{ ansible_operator_meta.namespace }}
kind: Service
apiVersion: v1
metadata:
  name: {{ instanceId }}-{{ workspaceId }}-foundation
  namespace: {{ ansible_operator_meta.namespace }}
  labels:
    app.kubernetes.io/instance: {{ instanceId }}
    app.kubernetes.io/managed-by: ibm-mas-manage
    app.kubernetes.io/name: ibm-mas-manage
    mas.ibm.com/instanceId: {{ instanceId }}
    mas.ibm.com/workspaceId: {{ workspaceId }}
    mas.ibm.com/applicationId: manage
    mas.ibm.com/appType: "serverBundleService-foundation"
spec:
  selector:
    mas.ibm.com/instanceId: {{ instanceId }}
    mas.ibm.com/workspaceId: {{ workspaceId }}
    mas.ibm.com/applicationId: manage
    mas.ibm.com/appType: "serverBundle"
    mas.ibm.com/appTypeName: "all"
  ports:
    - name: 9080-tcp
      protocol: TCP
      port: 9080
      targetPort: 9080
    - name: https
      protocol: TCP
      port: 443
      targetPort: 9443
  type: ClusterIP
  ipFamilyPolicy: SingleStack
  ipFamilies:
    - IPv4
YAML file below is an example of Manage Workspace where you can find all that information (instanceId, workspaceid and namespace):
image-20250814122931-1
You also need to validate mas.ibm.com/appTypeName: "all". You may not using the name all in your pod. Go to All pod, open YAML tab.
Search for "appTypeName". Check string used in this label, if it is not all, replace all mas.ibm.com/appTypeName in the service by the value that you are using.
image-20250814123346-2
After replace all parameters create service in Openshift console.
To confirm if service was created correctly. In Manage workspace, go to Networking => Service. 
Search for "foundation" . Click on and and Pods tab after.
Check if your All pod is in the list. 
image-20250814123858-3
You don't need to restart anything. Log in Manage using Superuser and check if applications are available after.

Document Location

Worldwide

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Document Information

Modified date:
14 August 2025

UID

ibm17242092