IBM Support

Storage Agent service fails to start

Troubleshooting


Problem

The Tivoli Storage Manager storage agent cannot be started in console mode, after attempting to start in service mode fails.

Symptom

When starting a Tivoli Storage Manager storage agent service like "TSM StorageAgent1", the process fails with the following message:

The TSM StorageAgent1 service on Local Computer started and then
stopped. Some services stop automatically if they are not in use by
other services or programs.

Cause

One of the following registry key values might be missing:

  • "Path" and "PTFLevel" strings in HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent
  • "Path" string in HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1
  • Some keys like "Accounting", "License", "Options", and "Service" in HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1
(Note: The storage agent name, for example StorageAgent1, must be the same as the value specified in the registry key HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1)

Diagnosing The Problem

The Windows Event Viewer log shows the Storage Agent service started and immediately stopped.

Resolving The Problem

Re-install the storage agent or manually add the missing registry keys.

    NOTE: Modifying the registry can cause serious, system-wide problems that may require you to reinstall the Windows OS to correct them. Before proceeding, make a backup of the registry to accommodate a restore in case of accidental change, deletion or typographical error. It is suggested that you contact Microsoft support for assistance with any registry problems.

For reference, here is a complete set of v6.3.3 registry key values:


[HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent]
"Path"="C:\\Program Files (x86)\\Tivoli\\TSM\\StorageAgent"
"PTFLevel"="6.3.3.000"

[HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1]
"Path"="C:\\Program Files (x86)\\Tivoli\\TSM\\storageagent"

[HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1\Accounting]
"Filename"="C:\\Program Files (x86)\\Tivoli\\TSM\\storageagent\\dsmaccnt.log"

[HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1\License]

[HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1\Options]
"FileName"="C:\\Program Files (x86)\\Tivoli\\TSM\\storageagent\\dsmsta.opt"

[HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\StorageAgent\StorageAgent1\Service]
"LogOutputToFile"=dword:00000001
"LogFile"="C:\\Program Files (x86)\\Tivoli\\TSM\\storageagent\\console.log"

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"StgAgent","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21698186