Troubleshooting
Problem
A Query Event for Client schedules shows the event continually as "In Progress" though no backup is running. Cycling of the Tivoli Storage Manager server and client schedulers provide no relief as schedules will not start.
Cause
Reasons for this condition may be: The scheduled event completed or failed but there was a problem that prevented the Tivoli Storage Manager client from reporting the final status (ie, network, client crashed, system crashed).
The Query Event results come from 2 tables (summary and event) in which it is possible for the tables to get out of "sync" due to a crash, etc in which one table may not get updated. This may cause the Tivoli Storage Manager server to believe that a session is in progress and has not completed. If the Tivoli Storage Manager server believes there is a scheduled session in progress another session will not start.
Resolving The Problem
There are 3 solutions available but please note that these will result in the loss of prior scheduled events. Should the business environment require these records be kept it is suggested that the output of a Query Event be sent either to file or hardcopy and retained for the retention period.
1) Delete Events prior to a specific date/time for type=client. Upon doing so all events with a status of "In progress" will change to "Uncertain". Tivoli Storage Manager is operating as designed and there is no need to worry about this status.
2) Update the existing schedule. This will delete all historical events for the existing schedule.
3) Set Eventretention period to a fewer number of days which would remove all "In Progress" events. Note: Setting the Eventretention to a fewer number of days will delete ALL events not just the "In Progress" events which are older than the period specified. Once completed set the Eventretention back to the original/desired period length.
Test by doing a Define Clientaction, the schedules should now be able to run.
Product Synonym
TSM ADSM ITSM IBM Spectrum Protect
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Document Information
Modified date:
17 June 2018
UID
swg21201780