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The 'Stop' button does not stop long-running queries on server for IBM i2 iXA Search AN

Troubleshooting


Problem

A user executes a query in i2 iXa Search AN to retrieve data from a back end data source. The query continues running for a long time and consumes CPU and memory resources on the server.

The user presses the 'Stop' button in iXa Search to stop the query. The query continues running on the server.

Cause

The 'Stop' button in i2 iXa Search AN stops the query on the client side, so that the user can issue a new query from iXa Search AN. It does not send a signal to the middle tier iXa web service, or to the back end data source.  This is normal and expected behaviour.

    

Resolving The Problem

To kill a long running query on the back end data source, the DBA will need to run a commend, appropriate for the specific database manager. There is no standard SQL command to cancel a long-running query; the command that needs to be sent to the database server will depend on what kind of database it is; for example, similar to the following:

      DB2:                 db2 "force application (application_handle)"

      SQL Server:    KILL <SPID>

      Oracle:            ALTER SYSTEM KILL SESSION '<sid, serial#>'

 

Note: This is an architectural consideration, not a design limitation or product defect. When any third-party tool, from any vendor, connects directly to a live transactional Production database, there is a risk it will issue a query to the database which consumes resources excessive for the transactional platform. The alternative design approach is to run queries against a warehouse database, which is periodically updated from the Production database.

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Document Information

Modified date:
16 August 2018

UID

ibm10720111