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Steps to ensure that Notes Single logon is working as designed

Troubleshooting


Problem

In Lotus Notes, you find that Notes Single logon (NSL) stopped working although the Windows password and the Notes password is synchronized.

Cause

1. The feature is disabled.

2. The featured was never installed.

3. The feature is not set to run automatically.

4. The executable is not running as a process.

5. The registry keys were modified by a third-party application.

Resolving The Problem

Cause (1)

The feature is disabled.

Resolution:

While in the mail file (Inbox view), go to File > Security > User security > Security Basics tab.Verify that the option "login to notes using your operating system login" is selected.

 

.


Cause (2)

 

The feature was never installed

Resolution:

Go to Start > Control Panel > Add or Remove Programs. Select Lotus Notes then select "change" and during the custom setup, select "modify" and select the single logon feature.

 


Cause (3)

The feature is not set to run automatically.

Resolution:

From the Windows Desktop, right click the icon My Computer > Manage > Service and Applications (click on the plus sign ) > Services > and look for Notes Single logon (service) and ensure that it is set to " Automatic".

If it is not set to Automatic. double click the Lotus Notes Single Logon field and a dialog window will pop up. Under "Startup type", click the down arrow and choose "Automatic". This can also be done by going to Start > Run. Type: services.msc and then locate the lotus Notes single Logon service.




Cause (4)

The executable is not running as a process.

Resolution:

Check to see if nslsvice.exe is running.
Go to Start > Run. Type: msconfig (select the Services tab).

or

Hold "Ctrl+Alt+Delete" on the Keyboard and select "Task Manager".

 

 


Cause (5)

The registry keys were modified by a third-party application.

 

 

Resolution:

 

 

Warning: Serious problems may occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. IBM cannot guarantee that these problems can be solved. Modify the registry at your own risk.


Go to Start > Run. Type: regedit, and browse to:

Path: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]
Value: "ProviderOrder"="RDPNP,LanmanWorkstation,WebClient,npnotes

N.B : npnotes is the registry key associated to the Lotus Notes Single Logon.
Please note that with Windows 64 bit operating systems the key will now read npnotes64

Ensure that the Value in the "ProviderOrder" is as above. The npnotes key should always be right after "WebClient". If npnotes appears twice, remove the second entry or if there is any other "Key registry" other than the "npnotes" after the "WebClient" key, switch them back so that the "npnotes" is the key right after "WebClient". Restart the machine. This fixes most of the NSL problems 80% of the time.

Example:

Incorrect
Path: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]

Value: "ProviderOrder"="RDPNP,LanmanWorkstation,WebClient,PssoCM32,npnotes"

Correct
Path: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]

Value: "ProviderOrder"="RDPNP,LanmanWorkstation,WebClient,npnotes,PssoCM32"

Have questions about this Technote? 

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Internal Use Only

 

Notes Single logon (NSL) stopped working although the Windows password and the Notes password is synchronized. This technote desribes steps to ensure that Notes Single logon is working as designed and how to troubleshoot NSL issues.

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Document Information

Modified date:
03 September 2018

UID

swg21304525