Troubleshooting
Problem
Users receive errors whilst performing different tasks inside Controller. Example #1 - Controller system worked OK (no problems) for many weeks. Then one day a user runs any of the following menu items: * User runs a report (in Excel) - NOTE: The problem may only affect some (for example the most complex) reports. * User receives an error message. Example #2 - User opens the 'Create Reports' menu. User attempts to create/save a new report. User receives error message. Example #3 - User exports a structure from database A. User then attempts to import the structure into database B. User receives an error message. Thee import does not proceed. Example #4 - User runs a consolidation. User receives error message(s).
Symptom
Example #1
Information
Standard Error
Number: 5
Source: FrangoDirect.ExcelLinkD.FetchValues#ControllerProxyClient
Description: System.Web.Services.Prototols.SoapException: Server was unable to process request. --->
System.Runtime.InteropServices.COMException (0x800A0005): Invalid procedure call or argument
At Cognos.Controller.Proxy.CCRWS.ExcelLinkB_FetchValues(String sGuid...
Example #2
Information
Standard Error
Number: 5
SourcE: FrangoDirect.ExcelLinkD.SaveLayoutFile#FrangoDirect.ExcelLinkD.SaveLayout#Contro llerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. --->
System.Runtime.InteropServices.COMException(0x80004005): Unspecified error
at FrExcelLinkBT.ExcelLinkTClass.SaveLayout(String sGuid, String sUser, Recordset rsLayout, String sRapp)
at Cognos.Controller.Proxy.CCRWS.ExcelLinkT_SaveLayout(String sGuid, String sUser, DataSet rsLayout, String
sRapp)
--- End of inner exception stack trace ---
OK
Example #3
Information
Standard Error
Number: 5
FrangoDirect.ImportStructureD.UpdateImpServer #controllerproxyclient ...
...server unable to process request.
Example #4
Information
Standard Error
Number: 5
Source: ControllerProxyClient
Description: System.Web.Services.Prototols.SoapException: Server was unable to process request. --->
System.Runtime.InteropServices.COMException (0x800A075C): Application-defined or object-defined error at Cognos.Controller.Proxy.CCRWS.clsBatchT_Batch(String sGuid...
Cause
There are several potential causes for this problem:
- Scenario #1 - Controller application server has run out of resources (memory).
- This may be due to several possible factors, such as memory leaks
- Scenario #2 - SQL database server's temporary database ("TEMPDB") is full
- This means that Controller cannot place its required temporary ('working') information inside the shared SQL TEMPDB database, causing errors
- hard drive(s) is/are full
- Scenario #3 - Controller SQL database (for example, called 'ControllerLIVE') is full.
- In other words, the Controller database cannot expand.
Resolving The Problem
Depending on specific environment, one or all of the following will fix the problem:
Scenario #1
Obtain a short period of downtime for the Controller system. Reboot *all* Controller servers (SQL, application server(s), Citrix server(s) etc).
Scenario #2 & 3
- Ensure SQL server hard drives are not full
- If necessary, shrink the transaction log of one (or more) SQL databases, to reclaim space
- Ensure that there are no restrictions to the size of any databases. Especially check the Controller application repository database(s) and the TEMPDB
TIP: To ensure that the SQL database server automatically shrinks the transaction log, ensure that there is a suitable SQL maintenance plan in place. For an example description of how to do this for SQL2005, see the ProvenPractice document 'Creating a SQL 2005 maintenance plan for Controller 8'.
Related Information
Historical Number
1032421
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Document Information
Modified date:
15 June 2018
UID
swg21361551