IBM Support

"Standard Error: Host key verification failed" error when installing an endpoint using a secure shell (SSH)

Troubleshooting


Problem

The installation of a Linux Redhat endpoint via SSH (using the winstlcf command with the -j option), i.e: # winstlcf -j -g fede2+9494 -l 9495 astro1 can fail with the following error message: Trying astro1... Could not determine INTERP for host astro1. Remote error: (null) (null) (null) (null) Standard Error: Host key verification failed. LCF Install failed for the following machines: (see lcfhost.err) astro1

Cause

Of course, to install endpoints using SSH, you must install the SSH client on the ManagedNode from which the SSH connection is made and the SSH server on the machine on which the endpoint installation is being performed.

This error could occur if the target machine where you want to intall the endpoint is an "unfamiliar machine", that is, a machine that is not listed in the
$HOME/.ssh/known_hosts file that resides on the machine performing the installation.

When SSH encounters an "unfamiliar machine", it displays a prompt. This prompt causes Tivoli installations to fail.
Therefore, you must configure the SSH client so that it does not prompt when it connects to an unfamiliar machine.

Resolving The Problem

This can be done, performing one of the following tasks:

1 - Set the "StrictHostKeyChecking" parameter in the "ssh_config" file to NO

or

2 - Add the machine that is an installation target to the known_hosts file

[{"Product":{"code":"SSXLSW","label":"Tivoli Management Framework"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"}],"Version":"4.1.1","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

More support for:
Tivoli Management Framework

Software version:
4.1.1

Operating system(s):
Linux

Document number:
77763

Modified date:
17 June 2018

UID

swg21176401