IBM Support

'Standard Error - ControllerForms - OpenWorkbook - Object reference not set' when opening or switching between Data Entry forms

Troubleshooting


Problem

User opens data entry form. User receives error message. User tries switching between Data Entry forms. User receives same error message. User then tries to close Excel. User receives different error message.

Symptom

Error message when opening/switching-between Data Entry form:

Information
Standard Error
Source: ControllerForms
Description: OpenWorkbook
Object reference not set to an instance of an object.
OK

Error message when closing Microsoft Excel:

ControllerXlDisp
Run-time error '1004':
The macro 'cc.LoadReportType' cannot be found.
OK

Cause

There are many different potential causes for the first error.

  • TIP: For more examples, see separate IBM Technote #1406990.

This IBM Technote shall specifically deal with the scenario where the Controller Excel link client cannot query the user's printer driver for the information that it needs to correctly display the data entry form.

Again, there are several potential causes for this. This TechNote shall concentrate on the scenario where the customer is deploying Controller via Citrix. In this case, potential causes include:
1) Problem with Citrix printer auto-creation (during logon) means valid printer not available to Controller/Excel when it launches
2) User's Citrix/Windows profile contains a corrupt printer driver as the user's default printer.
For example:
  • Two different people have been logging onto the Citrix server with the same Windows username/password, causing User#1 to be configured to print to User#2's printer
  • However, the Citrix ICA protocol will not allow this to work, so at least one of these users will receive this error message.

Resolving The Problem

One or more of the following may help resolve the problem:

1) Ensure that the Citrix published application (which launches Controller/Excel) has the box 'Start this application without waiting for printers to be created' ticked

2) Reset the 'bad' end user's Windows profile (for example, rename the folder C:\documents and settings\<username> to '<username>.old'), on the Citrix server(s) (plus their Terminal Services roaming profile, if this is configured).

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4;8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21366541