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'Standard Error ... COMException (0x800A000D) ... Type mismatch' when importing data from CSV file via 'Import from Flat files' caused by incorrect Regional Settings for COM+ user on Controller application server

Troubleshooting


Problem

User launches Controller. User clicks on 'Transfer - External Data - Import from Flat files'. User chooses 'Import Specification' (e.g. "IMPORTGL"). User selects 'client' and clicks on browse (...) button. User selects CSV file (e.g. TXT file). User clicks on 'Run'. User receives error message.

Symptom

Information
Standard Error
Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable
to process request. ---> System.Runtime.InteropServices.COMException (0x800A000D):
Type mismatch
at FrDImportBT.clsExtImportClass.DoImport(String sGuid, String sUser, Boolean
bCaseExpVal, Int32 IBatchId, String sSpecName, String sStructureType, String sPrompts,
Int32 ILLocale, Boolean& bError...
<....>
--- End of inner exception stack trace ---
OK


Event Viewer (Application log):
Log Name: Application
Source: Cognos Controller
Date: 29/03/2012 13:20:34
Event ID: 0
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: SERVERNAME
Description:
Standard Error
Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x800A000D): Type mismatch
at FrDImportBT.clsExtImportClass.DoImport(String sGuid, String sUser, Boolean bCaseExpVal, Int32 lBatchId, String sSpecName, String sStructureType, String sPrompts, Int32 lLLocale, Boolean& bError, Int32& lError, String& sErrorMsg, Recordset rsFileDataAndInfo, Recordset& rsRecon, Recordset& rsLog, Boolean bIsExcelImport)
at Cognos.Controller.Proxy.CCRWS.clsExtImport_DoImport(String sGuid, String sUser, Boolean bCaseExpVal, Int32 iBatchId, String sSpecName, String sStructureType, String sPrompts, Int32 iLLocale, Boolean& bError, Int32& iError, String& sErrorMsg, DataSet dsFileDataAndInfo, DataSet& dsRecon, DataSet& dsLog, Boolean bIsExcelImport)
--- End of inner exception stack trace ---
at Cognos.Controller.ControllerSoapHttpClientProtocol.Invoke(....

Log Name: Application
Source: VBRuntime
Date: 29/03/2012 13:20:34
Event ID: 1
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: SERVERNAME
Description:
The VB Application identified by the event source logged this Application FrDImportBT: Thread ID: 3100 ,Logged: Error occured at 29.03.2012 13:20:34 in FrDImportBT, Error No=13, Source=#clsDIengine.ImportData, Description=Type mismatch, HelpFile= HelpContext=0

Log Name: Application
Source: VBRuntime
Date: 29/03/2012 13:20:34
Event ID: 1
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: SERVERNAME
Description:
The VB Application identified by the event source logged this Application FrDImportBT: Thread ID: 3100 ,Logged: Error occured at 29.03.2012 13:20:34 in FrDImportBT, Error No=13, Source=FrDImportBT#clsDIengine.String2Numeric#clsDIengine.PerformOperation#clsDIengine.ParseLine#clsDIengine.ImportDataToLocalRS, Description=Type mismatch, HelpFile= HelpContext=0

Cause

There are several possible causes for similar errors when importing CSV data

  • For more examples, see separate IBM Technote #1347811.

This Technote specifically relates to the scenario where the cause are incorrect Windows Regional Settings on the Controller application server, inside the Windows user profile that relates to the COM+ User Account.

More Information:
Specifically, in one customer's case, the problem was caused by the COM+ User running with "Norwegian" regional settings:

Resolving The Problem

Modify the Regional Settings on the Controller application server, inside the Windows user profile that relates to the COM+ User Account.

  • In one real-life customer's case, the problem was solved by changing the "Format" from "Norwegian, Nynorsk (Norway)" to "English (United Kingdom)".

Steps:
  1. Obtain a short period of downtime (no users on the Controller system)
  2. Logon to the Controller application server as an administrator
  3. Launch "Controller Configuration" from the Start Menu
  4. Open the section "COM+ Server"
  5. Make a note of the Windows user that is specified inside this section (this is the COM+ user)
  6. Logoff from Windows
  7. Logon to the Controller application server as the COM+ Windows user
  8. Open "Control Panel"
  9. Open "Regional Settings"
  10. Modify the regional settings (e.g. to English (UK))
  11. To be sure that the changes have taken place, reboot the Controller application server
  12. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21587877