Troubleshooting
Problem
During a migration of IBM Rational Requirements Composer (RRC) running in the IBM Websphere Application Server (WAS) RRC does not start up and errors are seen at the diagnostic page.
Symptom
After a migration errors are seen in the diagnostic page https://<Jazz team server>:<port>/jts/admin#action=com.ibm.team.repository.admin.serverDiagnostics during a migration and upgrade of the RRC server.
The errors consist of:
Application: the root services resource at https://<Jazz team server>:<port>/rm/rootservices for "/rm" cannot be accessed...
Application: the service contribution resource at https://<Jazz team server>:<port>/rm/scr for "/rm" cannot be accessed...
Application: the discovery resource at https://<Jazz team server>:<port>/admin/rootservices cannot be accessed...
SRVE0207E: Uncaught initialization exception created by servlet
Cause
This might happen if the built in lpa_user license is not available.
Diagnosing The Problem
On the Jazz user administration page, Client Access Licenses, check if a license entry exists for the LPA Application-Internal user.
Resolving The Problem
If there is no LPA Application-Internal user entry listed under Client Access Licenses, this might be caused by an invalid WebSphere Application cache.
To resolve this.
- Shut down WAS
- Rename the directories "temp" and "wstemp" under
...\WebSphere\AppServer\profiles\AppSrv01
- Start up WAS again
- Check if the LPA Application-Internal license entry is added under Client Access Licenses
- Check if the errors are gone under the diagnostic page.
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Document Information
Modified date:
16 June 2018
UID
swg21618437