Troubleshooting
Problem
This technote identifies how to resolve the SQLDriverConnect (08001) error which might occur when attempting to log in, or create an IBM® Rational® RequisitePro® (ReqPro) project.
Symptom
The full error message is as follows:
Unable to login to the database using the following connection information: DRIVER={SQL Server}; UID=ResolveAdmin; DATABASE=ReqPro; PWD=********;SERVER=BSILVERM. Verify that the information used matches the way the database was set up. The error message was:
SQLDriverConnect: RETCODE=-1, State=08001, Native Error=17 [Microsoft] [ODBC SQL Server Driver][Multi-Protocol]SQL Server does not exist or access denied. [Microsoft][ODBC SQL Server Driver][Multi-Protocol] ConnectionOpen (Connect()).
Cause
The error is caused by having the MultiProtocol network library selected in the client configuration dialog box for the DSN.
Resolving The Problem
To resolve this issue, you will need to select the TCP/IP network library in the Client Configuration dialog.
- Launch ReqPro and select the project you are trying to log in to
- Select Properties
- Select Configure
- Enter the server name in the Server alias
- On the next screen, select Client Configuration and make sure the settings for Network Library match the screenshot below.

- Once you have verified that TCP/IP is selected, continue the project configuration by referencing Chapter 3 in the ReqPro installation guide (c:\program files\rational\requisitepro\doc\books\rp_install.pdf).
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Document Information
Modified date:
16 June 2018
UID
swg21294168