IBM Support

SQL5099N during server start up

Troubleshooting


Problem

SQL5099N is displayed during an attempt to start the IBM Spectrum Protect server in the foreground after moving the active log mirror to a new file system.

Symptom

The following error is reported:


(SQL5099N The value "<activelogmirror path>" indicated by the database
configuration parameter "MIRRORLOGPATH" is not valid, reason code "9".
SQLSTATE=08004)

Cause

SQL5099N

The value value indicated by the database configuration parameter parameter is not valid, reason code reason-code.

reason code "9":
The path cannot be accessed.

The active log mirror was not moved correctly following the steps listed in the Knowledge Center (Note: The steps to move the active log mirror and the active log are the same for their respective directory/paths):



The problem is caused by manually copying the logs located in the original directory to the new directory.

Resolving The Problem

Delete the copied logs located in the new active log mirror directory. Ensure the folder specified for the active log mirror is empty and restart the server.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM ADSM ITSM IBM Spectrum Protect

Document Information

Modified date:
17 June 2018

UID

swg21675617