Troubleshooting
Problem
Reports in the Integrated Solutions Console are not working due to an authorization failure.
Symptom
Reports fail with the following error in Integrated Solutions Console:
SQL error #1: [ibm][db2][jcc][t4][2017][11253] Connection authorization failure occurred. Reason: User ID revoked.
In Tivoli Enterprise Portal:
Fatal error in TEP KHD_ERROR_FATAL CTX_ConnectinFailed
Cause
One known reason for this issue is that a Windows user account created during the installation is locked or disabled.
Environment
Windows
Resolving The Problem
When configuring the Enterprise Portal Server, it might fail with the following error:
SQL30082N Security processing failed with reason code 19
This error is found in <install drive>:\IBM\itm\installITM\warehouse_configuration.log
Error code 19 indicates the userid has been disabled, or the userid has been restricted from
accessing the operating environment at this time.
To unlock/enable a user account do the following:
- Right click on My Computer and choose Manage
- Under System Tools, go to Local Users and Groups and click on Users
- For users db2admin and itmuser, right click on them and go to Properties
- Under the General tab, verify that the account is not disabled or locked out
After making any changes, restart all the services in the Tivoli Enterprise Monitoring Services.
Note: db2admin and itmuser are Windows account passwords. The passwords may expire without your knowledge. To test the password, log into the Windows box using the username and password. Ensure a valid username/password are used when configuring the Tivoli Enterprise Services.
Product Synonym
TSM
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Document Information
Modified date:
23 June 2018
UID
swg21414790