Troubleshooting
Problem
Attempt to connect to database on Host server is failing with the license error SQL1598N
Cause
File with cached license conlic.bin exists under C:\ProgramData\IBM\DB2\DB2COPY1\cfgcache
Environment
Replication Center running on Windows OSs. IBM Data Server Client installed and connect to the database from the DB2 Command Window is successful. Db2licm -l output shows that you have the permanent license for product "DB2 Connect Unlimited Edition for zSeries"
Diagnosing The Problem
Run db2 connect to <database alias> user <userID> using <password>
If you have DB2 Connect server license applied on the client side then connection to Host database should not report the error.
Make a connection to database from the Replication Center. You will get [IBM][CLI Driver] SQL1598n An attempt to connect to the database failed because of licensing problem. SQLSTATE=42968
Resolving The Problem
You have 2 options to resolve the problem:
1. Activate the license on zOS server LPAR by running db2connectactivate utility: http://www.ibm.com/support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.licensing.doc/doc/t0057375.html
2. Check if you have the file conlic.bin under directory C:\ProgramData\IBM\DB2\DB2COPY1\cfgcache. If you do, then please remove or rename it.
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Document Information
Modified date:
16 June 2018
UID
swg21987426