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SPECIFIED DDNAME NOT FOUND, DMDYNALO FAILED

Troubleshooting


Problem

SPECIFIED DDNAME NOT FOUND, DMDYNALO FAILED

Symptom


SDAA004I - INFO,DD=DMMSGFIL,RETURN=DSN MSG=NZ
SDAB005I - ERROR-CODE=0438, INFO-CODE=0000, SPECIFIED DDNAME NOT FOUND.
SCMG010I - INFO CALL TO DMDYNALO FAILED. DARTNCD = 00000008
SDAA004I - INFO,DD=DMMSGFIL,RETURN=DSN MSG=NZ
SDAB005I - ERROR-CODE=0438, INFO-CODE=0000, SPECIFIED DDNAME NOT FOUND.
SCMG010I - INFO CALL TO DMDYNALO FAILED. DARTNCD = 00000008
CMB600I - BATCH# 1234567, ID "STERLING DATA", RMTID SCIDATA ROUTED T PROCESS 00000000
SDAA004I - INFO,DD=DMMSGFIL,RETURN=DSN MSG=NZ
SDAB005I - ERROR-CODE=0438, INFO-CODE=0000, SPECIFIED DDNAME NOT FOUND.
SCMG010I INFO CALL TO DMDYNALO FAILED. DARTNCD = 00000008

Cause

DD name DMMSGFIL missing from Connect:Enterprise JCL

Resolving The Problem

Add the DD name DMMSGFIL to the Connect:Enterprise JCL. This DD should point to the Connect:Direct MSG file. This DD is used when a Connect:Direct message look up needs to occur for ICO (InterConnect Option).

NOTE: When using ICO the Connect:Enterprise JCL should have the DDs below for the local Connect:Direct:

STEPLIB for the Connect:Direct link library
DMPUBLIB for the Connect:Direct PROCESS library
DMNETMAP for the Connect:Direct NETMAP
DMMSGFIL for the Connect:Direct MSG file
DMPRINT for output of the results of an attempt to SUBMIT a PROCESS.

[{"Product":{"code":"SSG266","label":"IBM Sterling Connect:Enterprise for z\/OS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Historical Number

PRI29208

Product Synonym

New install;Connect:Enterprise z/OS;Interconnect:Option

Document Information

Modified date:
17 December 2019

UID

swg21530514