IBM Support

Some Columns are missing from Excel files when importing in iBase or Analyst's Notebook

Troubleshooting


Problem

When importing an Excel file in IBM i2 iBase or IBM i2 Analyst's Notebook (ANB), some columns are missing from the Excel file.

Symptom

In the Import Specification screens of iBase or ANB, you notice that one or more columns are missing from the Excel file.

Cause

This random problem is not linked to ANB or iBase, but with the Excel file itself.
This seems to be a random problem, where the Excel was saved in a "weird" state, making some columns not showing up.
ANB's importer uses Microsoft's OleDbCommand api to open and read the Excel files.  So the Microsoft API is having a problem reading the Excel file.

Resolving The Problem

The solution is rather simple : Open back the Excel file in Microsoft Excel, and Save it again.
If you have a warning asking you if you want to unprotect the file, click Yes.
You can now load the Excel file in ANB or iBase, in the Import Specifications.
If the column is still missing, go back to Excel, and save the file as a simple CSV file.

Document Location

Worldwide

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Document Information

Modified date:
05 May 2020

UID

ibm16205892